• Random lag loading webpages

    Hi all,

    I’ve got both Antergos and Windows 10 installed on my laptop (Zenbook flip UX360UA) using the Grub dual boot and everything has been working really great. The only problem which I am facing is loading webpages in my browser (currently Chromium but I have tested on Firefox as well which has the same issue) where every now and then it takes around ~30secs to load any web page.

    This is not a problem in WIndows where it works fine without any delay in loading webpages and my ping results to google.com are absolutely fine with no packet loss, so I am reluctant to think it is a problem with my internet/router but more an issue with my Antergos setup or compatibility with my wireless hardware and Antergos. I have not tried via an ethernet cable.

    My Linux networking skills are not the best although I am aware of a few commands such as tcpdump - however I was wondering if there was anything I could run which might help me diagnose the problem unless anybody has any other ideas? I have searched around online but haven’t had any luck so thought I’d post here.

    All responses appreciated thanks in advanced.

  • @pilnet123 1.2.3. so you are wireless connected, start to take a look to wifi hardware:

    and may be logs from bootup e.t.c.

    lspci > log.txt && lsusb >> log.txt && dmesg >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1

    post the link it gives out ;)

  • Thanks joekamprad, it is https://ptpb.pw/_Sfa

    I take it this line isn’t a good sign!
    [ 2.757140] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-7265D-28.ucode failed with error -2

  • @pilnet123 said in Random lag loading webpages:


    [ 2.761677] iwlwifi 0000:01:00.0: loaded firmware version 27.455470.0 op_mode iwlmvm

  • https://wiki.archlinux.org/index.php/Wireless_network_configuration#iwlwifi

    there are some tasks you can try to solve issues with iwlwifi:

    first i would try is the lates firmware package: linux-firmware-iwlwifi-git (AUR)

    yaourt -S linux-firmware-iwlwifi-git

    You can take a look to connection settings and the Link quality with connection manager or inside terminal with wavemon.

    yaourt -S wavemon

    Bild Text
    To see if the lag is caused by bad wifi connection ore some other stuff…

  • Thanks for the advice.

    So I ran the command to get the latest firmware package and I got a curl related error but ran it again and it worked fine. My output from wavemon is below, My link quality seems to fluctuate around 50% to 70%. I am not sure exactly how to make sense of the output though and where to go from here? I am still experiencing the problem.



  • All up from 60% should be fine, also RX/TX Rates looks fine… Wifi issues can caused by different problems…
    But as you say on Windows it works without that issue it is shurely a problem related to Driver/Firmware/Configuration-Options (So only 3 fields)
    You do not use encryption? (WPA2) if you are not based outside in the Pampa somewher with no one around 150 m around you it is maybe o.k. ;)
    Or you play around with your Wifi-Router settings?

    If you do that, may try to use a nother channel as aybe channel-1 is used by other Wifi Networks (same frequency 2412Mhz) It can caus bad connection if more then 3 other networks use the same channel.
    But channels up from 10 are not supportet by some wifi chipsets…

    Wiki say: If you have problems connecting to networks in general or your link quality is very poor, try to disable 802.11n, and perhaps also enable software encryption

    $ sudo nano /etc/modprobe.d/iwlwifi.conf

    and put this inside:

    options iwlwifi 11n_disable=8

    Save and reboot

  • rThanks again for the reply - yes I do use encryption (WPA-PSK/WPA2-PSK), not sure why it is showing as off in wavemon output! Hmm how would I go about changing the channel?

    Also I have made that change now (Created the file I guess) and have restarted so will monitor how it goes with that.


  • Should I also enable software encryption as per wiki?

  • Well I don’t want to jynx it but after making the change to disable 802.11n it seems to be working well

  • @pilnet123 said in Random lag loading webpages:

    Should I also enable software encryption as per wiki?

    Take very small steps! ;)

    better to do only one change after the other and reset if not working, it will be a mess otherwise.
    (This helps to keep system healthy!)

    I keep my fingers crossed!

    @pilnet123 said in Random lag loading webpages:

    yes I do use encryption

    May need to run wavemon as root to see, or wavemon is not prepared to check it…

  • Thanks for all the advice joekamprad, I appreciate it :)

    Anyway my issue seems to be resolved with all sites, except now within chromium it appears that specifically google is very slow for me but all over sites work fine. So I am using Chrome and I will see how that goes, so far so good!

    Thanks again and will report back if I have any more issues!

loading27 random16 lag3 webpages1 Posts 12Views 1351
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.