• Where is Wayland?

    Hi respected Gnomers,

    I didn’t follow Gnome 3 and Wayland development for a long time. Now I’d like to thouroughly test proprietary Nvidia drivers on Gnome-Wayland.

    Apparently I can’t switch to Wayland on Antergos and Arch. Whichever session is selected at login screen, I always end up in Xorg. There’s no Wayland, neither with default LightDM nor with added GDM. XDG_SESSION_TYPE is always gets set to x11:

    $ date +"%Y-%m-%d %H:%M:%S" && echo $XDG_SESSION_TYPE && optirun pwd
    2017-07-20 14:14:38

    I even did a fresh Antergos Gnome installation, in default configuration. Then, tried to add (and remove) xorg-server-xwayland. Still no Wayland.

    There are three Wayland packages installed by default in Antergos Gnome:

    $ pacman -Q wayland wayland-protocols lib32-wayland
    wayland 1.13.0-1
    wayland-protocols 1.9-1
    lib32-wayland 1.13.0-1

    I’m sure that some time ago Wayland session worked in Antergos Gnome, because I did some basic tests on it at that time. But now it’s not here.

    Reading ArchWiki Wayland article, seems like Wayland may be used only from within Weston now. Yes, Wayland works with Weston. But some time ago Wayland worked without Weston.

    There’s no problem to switch between Xorg and Wayland sessions on Tumbleweed, Fedora 26 and even Mageia 6. All three use GDM and have xorg-server-xwayland installed. Weston is not installed. XDG_SESSION_TYPE gets set to wayland:

    $ date +"%Y-%m-%d %H:%M:%S" && echo $XDG_SESSION_TYPE
    2017-07-20 14:32:28

    The question is simple. Can you start a Gnome session that runs on Wayland, without Weston? If you believe that the system runs on Wayland, what does this command return for you? :

    $ date +"%Y-%m-%d %H:%M:%S" && echo $XDG_SESSION_TYPE
    2017-07-20 14:39:04

    Thanks for reading

  • Hey just.

    I’m not a veteran Antergos (or even Linux) user, I should say first.
    But yes, I run Wayland on Gnome on Antergos, and I don’t have the weston package installed. I did nothing special that I know of in order to run Wayland on my setup.
    The output from the command you wrote:

    [[email protected] ~]$ date +"%Y-%m-%d %H:%M:%S" && echo $XDG_SESSION_TYPE
    2017-07-20 13:45:51
    [[email protected] ~]$ pacman -Q weston
    error: package 'weston' was not found

    I do run GDM instead of LightDM, as I’ve had trouble with the latter. Maybe give it a try?

    Edit: Upon further checks, it seems that xorg-server-xwayland is a dependency on gdm. Maybe that’s got something to do with it?

  • @Jakobnissen said in Where is Wayland?:

    …I do run GDM instead of LightDM, as I’ve had trouble with the latter. Maybe give it a try?

    Thank you, for clear, full, and precise answer.

    So probably there’s an incongruence on my side. I tried to use GDM instead of LightDM, on freshly installed Antergos Gnome, but it didn’t help. I’ll retry the installation.

    Thanks again

  • @Jakobnissen Your reply helped to concentrate on my Gnome configuration, and not to waste time looking for a solution elsewhere.

    Yes, you’re right - it’s better to replace LightDM with GDM. But that’s not enough. I already did it earlier, but it didn’t help.

    This time I not only replaced LightDM with GDM, but also explicitely uninstalled LightDM with all its dependencies:

    sudo pacman -Rcnsu lightdm

    It removed a dozen of LightDM-related packages and rebuilt MIME associations. After reboot Wayland is finally here. Weston is not needed:

    $ date +"%Y-%m-%d %H:%M:%S" && echo $XDG_SESSION_TYPE
    2017-07-20 16:02:28

    It’s now possible to test Wayland with proprietary Nvidia.

    Thanks for help, @Jakobnissen

  • guys i used wayland with nvidia proprietary drivers and the cpu usage was near 100%!!
    nvidia drivers 381.22

    1. sudo gedit /etc/mkinitcpio.conf
      MODULES="" =>MODULES=“nvidia nvidia_modeset nvidia_uvm nvidia_drm”

    2. sudo mkinitcpio -p linux

    3. add on grub.cfg file “nvidia-drm.modeset=1”
      linux /boot/vmlinuz-linux root=UUID=xxxxx rw quiet nvidia-drm.modeset=1 resume=UUID=xxxxxxx

    *there are many ways to do the 3rd step, i used grub-customizer because i think its easier to save and auto update grub…

    when i rebooted there was too much lagging i can barely move the mouse cursor and on the conky i saw near 100% cpu usage!!!
    am i missing something?
    when i opened terminal and executed this:
    the result was wayland
    but as i said my pc wasnt usable because of lag so i reverted back on X11 for now.

  • system specs:
    memory: 32Gb
    CPU: intel core i5-3330
    GPU: nvidia GTX770
    hdd: ssd 500gb sata III

    to login with wayland i used the way as described from this link:

  • This response is going way off-topic, but I can’t leave without a reply the numbers, posted by @qaron above.

    In my tests proprietary Nvidia 381.22 has absolutely no impact, neither negative nor positive, on Antergos 17.7 Gnome 3.24.2, independently from the session in use - either Xorg or Wayland.

    Initial tests are done on i7 computer with 8G memory and GT 555M Optimus card. Both Bumblebee and proprietary Nvidia driver are installed. No tweaks to system configuration were done. Just a direct Bumblebee installation, as described in Antergos Wiki.

    The system behaves absolutely identically, whether it runs on Xorg or Wayland.


    • CPU usage ~ 1%
    • RAM usage ~ 10-12%


    • CPU usage ~ 1%
    • RAM usage ~ 10-12%

    Official Bumblebee glxspheres64 graphical performance test running on Intel GPU:

    • Xorg ~ 60 frames/sec
    • Waylnad ~ 60 frames/sec

    Official Bumblebee glxspheres64 graphical performance test running on Nvidia GPU:

    • Xorg ~ 205 frames/sec
    • Waylnad ~ 205 frames/sec

    As expected, Bumblebee and proprietary Nvidia have no impact on Wayland. Computer behaves the same way on both Xorg and Wayland, with and|or without Bumblebee and prop Nvidia installed.

    Another result is that Wayland doesn’t influence the work of such a typical X client like Bumblebee. Bumblebee perfectly works on Wayland, exactly like it does on Xorg. This time it’s a good result.

    Let’s try to stop to go off-topic in this thread. It was about starting Wayland, not about Nvidia performance on Wayland. We can open a new thread for the latter, if we want.


wayland51 Posts 8Views 7798
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.