• Strange screen corruption


    Hello. So this is kind of a weird issue, and I’m not really sure where to post it. For some reason my screen about a week ago has begun to act really strangely. Now, every time I restart it or wake it from suspend, the screen is nothing but random black and white lines and bars. However, every random number of restarts, I am able to get the screen back to normal. In fact, I’m writing it right now after four restarts and it is working fine. For reference, at any time I can plug it into an external display and have the external display work perfectly. I have a Lenovo Ideapad running 64bit Antergos and the Linux 4.11.9-1-ARCH kernel. I am running GNOME with GTK2/3 themes for the Desktop Environment and icons. I tried recompiling my kernel and reinstalling graphics drivers to no avail. My cpu is an intel i5-6200U and the gpu is an intel integrated graphics chip. My boot uses rEFInd instead of grub. On restarts rEFInd is corrupted as well. Thank you!

  • @captcha_d said

    For some reason my screen about a week ago has begun to act really strangely.

    Hi, do you remember if this happened after a kernel upgrade? Have you tried using the lts kernel instead ?
    sudo pacman -S linux-lts (also install linux-lts-headers) if you need it.
    Regenerate your GRUB: grub-mkconfig -o /boot/grub/grub.cfg
    Reboot and choose the lts kernel.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @captcha_d I had a similar problem with my sony vaio and solved reseting a bios by pushing a clips in orifice behind the note.

Posts 3Views 272
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.