• lag after suspende


    Hi, I have some issues after the laptop is back from suspend.
    the first annoying thing is that the desktop is visible for few seconds before i put the password, also it takes 4/8 second befer it resume, and from time to time the screen blinks after the resume.

    I am new but i believe the issue comes due to the graphic card.
    my laptop is an asus zen UX305c, here is my lspci, let me know if you need other specifics and thank you all!

    00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 08)
    00:02.0 VGA compatible controller: Intel Corporation HD Graphics 515 (rev 07)
    00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 08)
    00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
    00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
    00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
    00:15.1 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 (rev 21)
    00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
    00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
    00:1c.0 PCI bridge: Intel Corporation Device 9d13 (rev f1)
    00:1f.0 ISA bridge: Intel Corporation Device 9d46 (rev 21)
    00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
    00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
    00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
    01:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)
    
  • @newBee I have the same problem with my xps 9343 on gnome desktop.

    This helps: https://wiki.archlinux.org/index.php/Dell_XPS_13_(9343)#Graphical_artifacting.2Finstability_after_S3_resume

    but, gives < 1-2 fps in the login screen. So, I prefer not to use it.

  • @psscnp142 thank you, I have been having this issue since the istallation. it is probably relate to gnome as I had it with Fedora and the same laptop. But with antergos is worse thats why I was hoping someone could help.

  • Yeah me too. I posted about this a while back but still no clue except the one I posted. It works great with openbox desktop, that I tried. So, it may be Gnome issue.

  • Same here. I have the same problem under Gnome, but it is definitely just a DE thing. (I have Deepin and KDE both installed also. It’s crazy over here:smile:). and none of those have any issues like this.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • I love gnome, but if in 2 months I can’t get this issue sorted I may migrate DE, @Keegan how is your experience with Deepin? is it based on debian?

  • @newBee said

    , @Keegan how is your experience with Deepin? is it based on debian?

    In case of misunderstanding (you mentiones Debian) he s talking about using another DE (Desktop Manager) not using a different distro (Debian or Debian based).

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch your are right, sorry, i miseread the watchdistro info… thanks for the tip. Will try it out with antergos then. ty!

  • @newBee said in lag after suspende:

    how is your experience with Deepin?

    If you are just looking to install another DE until this issue with Gnome is fixed, then simply run these two commands in your terminal:

    sudo pacman -S deepin
    
    sudo pacman -S deepin-extra
    

    I have found that it does not conflict with Gnome at all, so long as you install noto-fonts first (before the two deepin commands I just mentioned).

    Deepin can be a little buggy, but @Velkerk, @karasu, and I have come up with a solution for that. Whenever a glitchy Deepin update comes along, an Antergos-alert will be issued to let you know (kind of like the antergos-alert about the password vulnerability from a month ago).

    Hope this all helped!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan ty for the tips, I installed it, and the lag issue vanished, but got few issues… icons are too small and fail to change size with right-click on desktop. But am fairly impressed, if I could solve the resolution issue would be great. Thank you @Keegan

  • @newBee

    I did some digging into arch forum. Someone suggested to drop xf86-video-intel. I was quite surprised but I see some issues with other distros as well. Even some, do not recommend using this at all. Since. i915 module is already provided by the recent kernel you cant instead drop to KMS in arch linux so GLAMOR acceleration which seems to be hardware dependent.

    So, if you would like to test this please proceed with caution:

    1- pacman -R xf86-video-intel xf86-video-fbdev xf86-video-vesa
    I don’t know why xf86-video-fbdev and xf86-video-vesa are installed by default in antergos. They are not used at all if you have xf86-video-intel.
    See here for details, https://wiki.archlinux.org/index.php/xorg#Driver_installation

    2- mv /etc/X11/xorg.conf.d/20-intel.conf /etc/X11/20-intel.conf.bak
    Here, save intel configuration as backup, in case you want to go back to this.

    3- pacman -S mesa

    I you skip steps 2-3, you may not be able to start X server. I have seen some people choke on step 2 and I did in step 3. In case, you have some problems starting X server, drop to main terminal via cntrl+alt+F2 and revert settings.

    To go back to way it was before,
    1- pacman -S xf86-video-intel
    2- mv /etc/X11/20-intel.conf.bak /etc/X11/xorg.conf.d/20-intel.conf

    Anyways, see if this works for you. Solved the issue for me, but seems like CPU temp spikes while generating windows. Need to test this a bit more to make sure.

  • @psscnp142 thank you! at the moment I am sticking with deepin, is not as usable as gnome but maybe is only a matter of habits. if in a week I will still miss gnome will try out your solution! thank you for your time, I will close this thread for the moment. many thanks to all you guys upstair!:D I appreciated your tips!

  • @newBee said in lag after suspende:

    icons are too small and fail to change size with right-click on desktop.

    I think that may just be a problem that is introduced due to the fact that you also have Gnome installed. I know they sometimes “argue” you could say and cause problems between each other:smile:. But I’m glad to hear your problem is (sort of) solved!

    Thank you @keegan

    Just glad I could help! And in addition, if you are willing to use Deepin’s login manager, this should also allow you to use Gnome without the lag issue. I know it at least works for me! If you are interested, just open up your file manager as root. (Accomplished by running ‘sudo name_of_file_manager’ in terminal. If that was confusing, an example for running nautilus, Gnome’s file manager, as root would be ‘sudo nautilus’). Next, go to the file /etc/lightdm/lightdm.conf and scroll down to this line:


    #greeter-session=blah blah blah (I don’t actually know what it says there by default:smile:)


    Just remove the ‘#’ sign from it and after the = sign replace the default text with lightdm-deepin-greeter. Here’s how it should look after making these changes:


    greeter-session=lightdm-deepin-greeter


    Here’s a picture:0_1500646754438_deepin login manager.png

    After this, just reboot your computer and you will be presented with Deepin’s login manager and the lagging issue should be gone!

    Hope this helps!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • NOTE: if you decide to use Deepin’s login manager (which is actually just a tweaked version of Antergos’ login manager I think) in order to use Gnome, just click the Deepin icon in the bottom right corner. A screen showing all of your DE’s will then be displayed and you can choose whichever one you want. There should be four versions of Gnome (for some reason unknown to me) so just click the first “Gnome” option available. (aka. the first one that says “Gnome” on the left). After this, you should be redirected to the normal login screen and upon logging in, Gnome will be presented in all of it’s glory!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan thank you; it didn’t work for me:( still the same issue with lags in gnome.
    do you know any addons for deppen that works like tweaks? I really miss gnome customable bar and the addons:(

    ty!

  • @newBee said in lag after suspende:

    I really miss gnome customable bar and the addons:(

    I don’t really know about that, but I think @Velkerk would be the local Deepin expert. I would recommend asking him about it:slight_smile:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • I don’t think the bar in Deepin is customizable, like Gnome. Some elements in Deepin are fixed, for example the color of the file window stays white, no matter what theme you choose.
    But maybe Velkerk has the solution, I have put Deepin since the beginning of the week on a sidetrack. After three months, I am a little fed up by the up and down performance of the DE. Last year on Manjaro I bumped into the same issues.
    Sorry if I sound a bit bitter, but I also work on Antergos and as a freelancer any client is welcome and I just can’t afford my work environment to freeze, lag or any other inconvenience.
    Today I gave Deepin another try and after an hour my system froze and I couldn’t get into the system.
    Luckily I have Linux mint as an emergency OS, otherwise I couldn’t present my presentation today.
    Again, my apoligies for my little dissapointed look on Deepin, but it’s out of my system now…

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

  • @bpoerwo is a good feedback you did, i agree that an unstable system/desktop is nice for testing and as a hobby.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto said in lag after suspende:

    @bpoerwo is a good feedback you did, i agree that an unstable system/desktop is nice for testing and as a hobby.

    Same here! I really appreciate it and totally agree with you! Even though I’ve been developing Deepin for Antergos doesn’t mean I don’t understand the downsides:slight_smile:. In fact, I don’t actually use it as my main DE for those exact reasons you mentioned. I just created it because I know there are people out there like @Velkerk who love Deepin. Linux is all about freedom and choices anyways, right?

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • On Antergos Deepin was never my main DE, but today I couldn’t even log into Antergos to use KDE.
    This happened an hour before I had a meeting with my client, so that’s why I brought good old, (bit boring) Mint back in action, that was hibernating on my HDD.

    Thinkpad E570 Intel core i5 (Kaby lake)
    8 GB RAM
    256 GB SSD + 1 TB HDD
    Intel HD Graphics

Posts 44Views 1545
Log in to reply