• VirtualBox Fullscreen and USB detection issue


    Hey All,
    Installed Virtualbox and using Win 8 64 as guest OS.
    Facing issues getting fullscreen and also usb devices not getting displayed in guest os.
    Already enabled the required settings but no changes found.
    Am using a Macbook.
    I have installed Vbox with the guide available in this forum.
    There is no operational issues just the window is too small and usb issues.
    Thanks in advance.

  • I was thinking that you need to install virtualbox-guest-iso on host, and then also inside windows guest. You can start this like a cd over the options menu when guestVM is started.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad Thanks for the reply.
    I have installed guest-iso in the host.
    How do I make sure its done in guest as well?

  • press “insert Guest Additions CD” from the bottom of virtualbox while the guest is running…
    This will insert the additions as a CD inside the Guest and you can install it.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Ok. I added the Optical Drive in settings before starting guest and added the guest-additions iso.
    Once booted the guest it showed the iso file and I installed it.
    But full screen is still not possible :(

  • Once I uninstalled the guest iso files from guest machine I am getting a bit higher resolution.
    Earlier it was 1280x720
    After removing I get 1600x1200. Strange
    Shouldnt it be the other way

  • usually it is that you only get support for bigger resolution and s.l.t. when the additions are installed.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @surfermj said in VirtualBox Fullscreen and USB detection issue:

    But full screen is still not possible

    To get around this, I usually just change the resolution. If you match the distro’s (or in this case, Antergos) resolution inside the VM to that of your Macbook, it should become fullcreen. Finding that resolution can be the tedious part, but if you just try out various resolutions, eventually you will hit upon the right one! It is different for everyone, due to the fact that everyone has a different laptop / PC with different screen sizes and resolutions.

    Hope this helps and welcome to Antergos!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • yea you need to change the resolution with inside the guest os and the Systemsettings from windows itself, to make it clear…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • I have updated Vbox to the latest version now. After installing the driver USB is working fine now. Issue was that Guest OS was not showing the menu bar from where driver was enabled. Now I am getting the options to resize virtual window, Auto adjust etc but nothing works. Only the max resolution to 1024x768.
    I tried adjusting different res. in Mac and then in Guest. No changes. Any idea?

Posts 10Views 451
Log in to reply