• Trackpad not working in fresh install of GNOME?


    I have been using Antergos. But for last few days, my trackpad stopped working. I even tried fresh install.

    Please assist

  • @gaurav.dighe Did you perform an update before it stopped working? Have you also tried to use it during the Live session before the installation? Did it work then?

  • It was happening for last few days. So when i tried again to create a fresh installation, I had my USB Mouse plugged in.I have updated the system using pacman -Syu. Even sudo xinput doesn’t show up synaptics.

    //[[email protected] ~]$ sudo xinput
    [sudo] password for gaurav: 
    ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
    ⎜   ↳ PixArt USB Optical Mouse                	id=14	[slave  pointer  (2)]
    ⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
        ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
        ↳ Power Button                            	id=6	[slave  keyboard (3)]
        ↳ Video Bus                               	id=7	[slave  keyboard (3)]
        ↳ Video Bus                               	id=8	[slave  keyboard (3)]
        ↳ Power Button                            	id=9	[slave  keyboard (3)]
        ↳ HP Webcam-50                            	id=10	[slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard            	id=11	[slave  keyboard (3)]
        ↳ HP WMI hotkeys                          	id=12	[slave  keyboard (3)]
        ↳ HP Wireless hotkeys                     	id=13	[slave  keyboard (3)]
    [[email protected] ~]$ 
    
  • @gaurav.dighe Do you run GDM? The first thing I do after installing Arch with Gnome is get GDM. For some reason, immediately after the initial reboot, all my trackpad issues seem to go away, and I can see the setting in the mouse and trackpad settings menu.

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

  • @gaurav.dighe What’s your laptop model and stuff? Could be a hardware specific issue. My surface pro 3 type cover 4 is running fine so even with my “moon” hardware I would think yours might be even more “moon” tech.

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • @gaurav.dighe Maybe, you can try linux-lts?

  • In addition, have you made sure you have xf86-input-synaptics installed? If not, please install it. If you do, I would suggest uninstalling it and installing xf86-input-libinput in it’s place. After that, just reboot your computer. These programs are basically two different ones used to control the trackpad and mouse. If your current one is not working, I would advise uninstalling it and then installing one of the above mentioned ones. For more information on this, please take a look at this post. (While the issues mentioned in that post are not identical, they are still dealing with the same programs that are causing you trouble. Thus, they could give you some insight into how to solve your current issue).

    Hope this helps!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

fresh24 trackpad6 gnome244 Posts 7Views 488
Log in to reply