• Disable the touchpad of my laptop while typing (Latitude E5570)


    Hello,
    former Windows and Ubuntu user here.
    I have a rather dumb question.
    I would like to disable the touchpad of my laptop (Latitude E5570) while typing in Antergos (Gnome Edition).
    The following command works perfectly: syndaemon -i 0.5 -t -K -R -d

    My question:
    How can get this command started wihle booting the system? I dont like to type it every time while starting the system…

    Greetings, Tomasz

  • Welcome to the Antergos community, friend!

    I have a rather dumb question.

    I don’t know. It seems like a pretty good one to me:grinning:. Besides, everyone has to learn somehow.

    As for your question, simply make a file using your file editor and save it in .config/autostart to make it, well, autostart with your system. To make sure it starts up, don’t forget to make your new file executable by right clicking on it, choosing Properties and the checking the box that says allow file to run as program. Make sure to end the file with .desktop also.

    Here is an example I found online for how to format the content inside of your file:

    [Desktop Entry]
    Name=MyScript
    GenericName=A descriptive name
    Comment=Some description about your script
    Exec=/path/to/my/script.sh
    Terminal=false
    Type=Application
    X-GNOME-Autostart-enabled=true
    

    Hopefully this helps! And if you still are stuck, here’s the link to that helpful site I grabbed the example from:slight_smile:.

    In addition, if you are still stuck, there is a program that lets you do this graphically here. To install it, just blindly run these commands:
    sudo pacman -S gcc-multilib git make gtk3
    git clone https://github.com/hant0508/startup-settings.git
    cd startup-settings
    make
    sudo make install
    After that, you should be able to open the program (it’s called something creative like “startup settings”) and insert your script!

    Enjoy!

    Keep trying, never give up. In the end, you will find that it was all worth it

    https://sourceforge.net/projects/antergos-deepin
    https://linuxbasicssite.wordpress.com

  • Thank you, kind sir. It all worked like a charm. Lesson learned.
    Great distribution, btw. It is the best Linux desktop expirience I had so far. (Tried many other distros and was forced to use Windows for several years). It is a good idea to keep things simple - and to learn to use the command-line.

    I found just a few little flaws (Some minor issues with Grub Menu). Is there a place where I can make some suggestions to improve things?

    Greetings, Tom

  • Just for other users iterested in this soultion, here my modified script in:
    ~/.config/autostart:

    [Desktop Entry]
    Name=TouchpadBlockerScript
    GenericName=Dont touch me while typing!
    Comment=Blocks tap to click while typing
    Exec=syndaemon -i 0.5 -t -K -R -d
    Terminal=true
    Type=Application
    X-GNOME-Autostart-enabled=true

    Btw how do I mark the query as solved?

  • @tkonicz said in Dumb newbie question:

    Btw how do I mark the query as solved?

    If you go down to Topic Tools, there should be an option to Mark As Solved. However, I have already done it for you:slight_smile:.

    Glad to hear it solved your problem!

    Keep trying, never give up. In the end, you will find that it was all worth it

    https://sourceforge.net/projects/antergos-deepin
    https://linuxbasicssite.wordpress.com

  • @tkonicz said in Dumb newbie question:

    I found just a few little flaws (Some minor issues with Grub Menu). Is there a place where I can make some suggestions to improve things?

    Sure! If you head to the Antergos Wiki, you can make an article about it. Or, you could probably just find someone else’s and expand on it, including your finding within.

    Thank you for the desire to get involved! It is people like you that help the future users solve their problems.

    Keep trying, never give up. In the end, you will find that it was all worth it

    https://sourceforge.net/projects/antergos-deepin
    https://linuxbasicssite.wordpress.com

  • @Keegan I made an wiki article, but I cannot post it: “Faild security check”.
    Can you help?

  • What browser are you using?

    Keep trying, never give up. In the end, you will find that it was all worth it

    https://sourceforge.net/projects/antergos-deepin
    https://linuxbasicssite.wordpress.com

  • firefox. I was able to save the draft, but not to submit the wiki article.

  • Hmmm… it should be working in Firefox.

    Are you sure you’re logged in?

    Keep trying, never give up. In the end, you will find that it was all worth it

    https://sourceforge.net/projects/antergos-deepin
    https://linuxbasicssite.wordpress.com

  • I am logged in in the forum, do I need an ohter login for the wiki?

  • @tkonicz said in Dumb newbie question:

    I am logged in in the forum,

    If you’re logged into the Forum, you should be good to go. What if you open another tab and go to the Wiki homepage? Then, you could see if your article comes up under New Articles. I know in Vivaldi, I get an error too. However, it actually is publishing the article, it just doesn’t show me for some reason until I check out the New Articles category.

    Keep trying, never give up. In the end, you will find that it was all worth it

    https://sourceforge.net/projects/antergos-deepin
    https://linuxbasicssite.wordpress.com

  • If this doesn’t work, it could be a glitch with the Wiki. That happens ever now and again. If that is the case, just copy and paste your content and log out of the Wiki. Then, log back in and try again. And if that still doesn’t work for you, then perhaps I can contact the developers and they can take a look at it for us:grinning:.

    Hope this helps!

    Keep trying, never give up. In the end, you will find that it was all worth it

    https://sourceforge.net/projects/antergos-deepin
    https://linuxbasicssite.wordpress.com

  • Hi there!

    In the end, I was just able to submit your article for you myself successfully. It should now be there!

    Keep trying, never give up. In the end, you will find that it was all worth it

    https://sourceforge.net/projects/antergos-deepin
    https://linuxbasicssite.wordpress.com

  • Hi, here ist the Wiki Article (Maybe you can post it? It would be a pitty to see the work wasted). I will also try it later:

    How to make Grub boot different Kernels by default

    After selecting the LTS-Kernel during installation, I found out later that it is not used by default. “uname -a

    If you want Antergos to boot the LTS-Kernel by default, you have to edit the following file:

    /etc/default/grub

    there are two ways to make grub boot the LTS-Kernel:

    1. Modify the following entry:

    GRUB_DEFAULT=“0”

    You have to change the Zero, it marks the first entry in the Grub Menu. Te second entry below is “1”, the third “2”, and so forth. (I had to fill in the “2”)

    1. The other method: Uncomment the following entry:

    #GRUB_SAVEDEFAULT=“true”

    Simply remove the “#” and save. This will force Grub to use your last selected Kernel as default - until you change it again.

    Unfortunately, none of these methods is working out of the box, because Antergos is using a submenu in Gurb after installation. Hence you have to install grub-customizer from the AUR to get rid of the submenu. Its a GUI-tool, pretty self-explanatory. After that, both aforementioned methods work again.

    This is a rather unfortunate situation. My suggestion for the devs: Make the LTS kernel the default, if this kernel is selected during installation (ask the user eventually if he wants it). Get rid of the submenu, keep things simple, list all the kernel options without Grub-submenus.

  • Maybe you can post it?

    Just take a look at my last post in this thread:grinning:. I already have.

    Keep trying, never give up. In the end, you will find that it was all worth it

    https://sourceforge.net/projects/antergos-deepin
    https://linuxbasicssite.wordpress.com

  • ok, great.

  • However, I think it will show the article as being created by me. If you wish to fix that, just go to the article and Edit It. After making some change (even be it a closing sentence or even one extra word) it should now show you as the author.

    Keep trying, never give up. In the end, you will find that it was all worth it

    https://sourceforge.net/projects/antergos-deepin
    https://linuxbasicssite.wordpress.com

  • @tkonicz said in Dumb newbie question:

    Make the LTS kernel the default

    I agree! That would be a great change! However, I actually like the sub-menus as it keeps the screen cleaner and the entries that I don’t use often are tucked away. But making the LTS kernel the default one would be a nice change.

    Keep trying, never give up. In the end, you will find that it was all worth it

    https://sourceforge.net/projects/antergos-deepin
    https://linuxbasicssite.wordpress.com

Posts 38Views 613
Log in to reply