• Can't change image with LightDM-GTK+ settings


    Dear members,

    I installed the lightDM-gtk-greeter and its accompanying GUI setting tool, modified the conf file accordingly, and then used the GUI setting tool to choose my background image and avatar. While the greeter did get changed from LightDM-webkit2 to lightDM-gtk, my wished background and avatar just won’t show up. I also applied chmod 775 to both image files.

    Did I forget something? Any suggestions?
    Thanks!

    Doihara

  • @doihara I always configure lightdm-gtk-greeter by hand, so don’t know how a grphical tools for it work.

    Edit /etc/lightdm/lightdm-gtk-greeter.conf and explicitely indicate the full path to images that must be used for background and user image. Both images may reside on any statically mounted partition. For example:

    [greeter]
    background=/1st/pic/wallpapers-phone/material-375.png
    user-background=/1st/pic/wallpapers-avatars/just-avatar-256x256.png
    ...
    

    Very important: both images must be in PNG format. Otherwise they won’t be displayed.

  • @doihara Do you run lightdm-gtk-greeter-settings as root?
    If you are under Gnome this will be automatic (if you do not change something related) but may you do not have gnome-keyring enabled/installed?

    What @just was offering will work for shure, but i think you choose lightdm-gtk-greeter because of the config GUI to change the design?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Thank you both for the help!

    Surely I should have read the wiki article about LightDM more carefully before I posted this question. Let me briefly summarize what was actually going wrong and how it was (temporarily) fixed.

    I have to admit that I am still not 100% clear about every details, but at least I know more than before. And here is what I know so far:

    1. I edited the wrong file.
      Instead of

    /etc/lightdm/lightdm-gtk-greeter.conf

    I modified

    /etc/lightdm/lightdm.conf

    I think that was the reason why it didn’t work even if I configured using the non-GUI way.

    1. The images type and size
      While jpg images seem to be working just as well as png, the image should be resized to the exact dimension that fits the theme.

    2. GUI-settings
      As far as I can see, the GUI setting tool should do exactly the same thing as /etc/lightdm/lightdm-gtk-greeter.conf, which is logical. But even if it was run as root, the images just won’t show up.

    Yes, I switched to lightdm-gtk+ because it has a quick and lazy gui tool. In my other computer, which also runs Antergos, but with Gnome instead of xfce, the same gui tool is working perfectly. It does even auto-scale the images.

    More comments and suggestions are welcome:)

  • So after manually editing /etc/lightdm/lightdm-gtk-greeter.conf, now I have my background and avatar images.

    The remaining question is, how can I get the avatar image auto-scaled? While it is no problem to resize the background image to the exact size, because we know the screen resolution, isn’t it impractical that we have to guess the required dimension of the avatar? I needed 3 attempts to get a somehow reasonable size.

    I am pretty sure this is not the way it should be working. Any hint?

  • You are on Gnome here?
    As i remember it will use the avatar you choose for user settings for gnome, if you leave it empty inside the lightdm-gtk-greeter-settings

    If you want to use the GUI i recomment to leave the lightdm-gtk-greeter.conf untouched by manual edit.

    To change the greeter hopefully you do this by editing the lightdm.conf

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • 256x256 is what should work as @just give this hint before

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • I am on xfce here.
    I did take 256x256, as you suggested, as my starting point. But it was, due to whatever reason, way too big. Finally it turns out to be something around 96x96, but it still doesn’t look 100% right.
    Yes sure. I edited /etc/lightdm/lightdm.conf to change the greeter, and then /etc/lightdm/lightdm-gtk-greeter.conf for greeter specific settings. Actually everything is so clear and logical, but it won’t help if someone, like me, is ignorant and blind :D

  • Archwiki say: using a 96x96 PNG image file.
    Note: Make sure that both created files have 644 permissions, use chmod to correct them.
    https://wiki.archlinux.org/index.php/LightDM

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @doihara said in Can't change image with LightDM-GTK+ settings:

    …The remaining question is, how can I get the avatar image auto-scaled?..

    I have no answer, but can confirm that both images, the screen background and user avatar, are auto-scaled.

    The background I use comes from Material phone images. It’s 2664x2664 in size, and it’s zoomed down to 1920x1080 for login screen, correctly loosing original square image proportions.

    The user 256x256 image is about 5 times larger the a normal icon, but it’s not that huge on login screen and is scaled down to a normal square icon size, keeping proportions.

    Both are true PNG images. I wouldn’t exclude that LightDM can’t auto-scale non-PNG images. I use lightdm-gtk-greeter in Cinnamon and Mate. It works this way on Arch and all its clones and derivatives.

image10 lightdm-gtk1 Posts 10Views 370
Log in to reply