• Delete/Disable HFP/HSP Audio Profile


    Hi guys.

    One of my really big annoyances right now with Antergos (and also Fedora) is for some reason, the bluetooth drivers are messed up.

    I have a pair of bluetooth headphones that I pair to Linux. Everytime I connect, it goes directly to the HSP/HFP profile, and I can’t change the settings. This means I always have to unpair, re-pair, and reconnect my headphones every single time I want to use them, i.e. every day.

    Is this a gnome bug, or a bluetooth issue in general? I also experienced the same issues on Fedora 25.

    I’d like to remove the HSP/HFP option entirely, since the mic on my headphones sound like crap anyway, and I have a usb headset for all my skype needs. How can I go about doing this?

  • I use GDM. Thanks for the guide. I tried it and it doesn’t work, and still auto-connects to HSP/HFP.

  • as it will autoconnect to the last profile, you need to gett a a2dp profile link, may need to remove your headphone, and reconnect with cli tool (bluetoothctl). If you are connected with a2dp profile power off headset and power on again, you should get connected automaticly to a2dp profile now.

  • Thanks Joekamprad. I think it works now. The hard part is actually getting it started as A2DP. It seems to like to stay at HSP/HFP when I pair and it doesn’t switch over sometimes.

audio45 profile3 deletedisable1 hfphsp1 Posts 5Views 1559
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.