• Issues with Pacman Update/Upgrade


    Hello all, my name is Alex and I am a first time poster to these forums and a long time reader. I have run into an issue with updating my system. Pacman is complaining about corrupted packages and will not complete the update; I have seen this issue before and resolved it, though this time seems to be different.

    I will post the output of pacman:

    //[[email protected] alex]# pacman -Syyu
    :: Synchronizing package databases...
     antergos                 154.0 KiB   670K/s 00:00 [######################] 100%
     core                     125.3 KiB   670K/s 00:00 [######################] 100%
     extra                   1662.8 KiB  1756K/s 00:01 [######################] 100%
     community                  3.9 MiB  1859K/s 00:02 [######################] 100%
     multilib                 171.8 KiB   818K/s 00:00 [######################] 100%
    :: Starting full system upgrade...
    resolving dependencies...
    looking for conflicting packages...
    warning: dependency cycle detected:
    warning: kinit will be installed before its kio dependency
    
    Packages (162) akonadi-17.04.2-4  appstream-0.11.1-2  appstream-qt-0.11.1-2
                   attica-qt5-5.36.0-1  automake-1.15.1-1  avogadrolibs-1.90.0-4
                   baloo-5.36.0-1  bind-tools-9.11.1.P3-1  bluez-qt-5.36.0-1
                   breeze-icons-5.36.0-1  btrfs-progs-4.11.1-1  cups-2.2.4-2
                   cups-filters-1.14.1-1  deepin-daemon-3.1.12-1
                   deepin-desktop-base-1:2016.12.1-1
                   deepin-desktop-schemas-3.1.12-1  deepin-icon-theme-15.12.46-1
                   deepin-notifications-3.0.6-1  deepin-polkit-agent-0.0.10-1
                   deepin-qml-widgets-2.3.5-1  deepin-tool-kit-0.3.0-1
                   deepin-wallpapers-1:1.4-1  device-mapper-2.02.172-2
                   docbook-xsl-1.79.2-3  dolphin-root-17.04.2-1
                   frameworkintegration-5.36.0-1  fuse-common-3.1.0-1
                   geoip-database-20170704-1  glib2-2.52.3-1  gnutls-3.5.14-1
                   grep-3.1-1  iproute2-4.12.0-1  jemalloc-1:5.0.1-1
                   kactivities-5.36.0-1  kactivities-stats-5.36.0-1
                   karchive-5.36.0-1  kate-root-17.04.2-1  kauth-5.36.0-1
                   kbookmarks-5.36.0-1  kcmutils-5.36.0-1  kcodecs-5.36.0-1
                   kcompletion-5.36.0-1  kconfig-5.36.0-1  kconfigwidgets-5.36.0-1
                   kcoreaddons-5.36.0-1  kcrash-5.36.0-1  kdbusaddons-5.36.0-1
                   kdeclarative-5.36.0-1  kded-5.36.0-1  kdelibs4support-5.36.0-1
                   kdesu-5.36.0-1  kdnssd-5.36.0-1  kdoctools-5.36.0-1
                   kemoticons-5.36.0-1  kfilemetadata-5.36.0-1
                   kglobalaccel-5.36.0-1  kguiaddons-5.36.0-1  khtml-5.36.0-1
                   ki18n-5.36.0-1  kiconthemes-5.36.0-1  kidletime-5.36.0-1
                   kinit-5.36.0-1  kio-5.36.0-1  kitemmodels-5.36.0-1
                   kitemviews-5.36.0-1  kjobwidgets-5.36.0-1  kjs-5.36.0-1
                   kjsembed-5.36.0-1  knewstuff-5.36.0-1  knotifications-5.36.0-1
                   knotifyconfig-5.36.0-1  kpackage-5.36.0-1  kparts-5.36.0-1
                   kpeople-5.36.0-1  kplotting-5.36.0-1  kpty-5.36.0-1
                   kross-5.36.0-1  krunner-5.36.0-1  kservice-5.36.0-1
                   ktexteditor-5.36.0-1  ktextwidgets-5.36.0-1
                   kunitconversion-5.36.0-1  kwallet-5.36.0-1  kwayland-5.36.0-1
                   kwidgetsaddons-5.36.0-1  kwin-5.10.3.1-1  kwindowsystem-5.36.0-1
                   kxmlgui-5.36.0-1  kxmlrpcclient-5.36.0-1  lib32-mesa-17.1.4-1
                   lib32-ncurses-6.0+20170527-1  lib32-readline-7.0.003-1
                   libblockdev-2.10-1  libbsd-0.8.5-1  libcups-2.2.4-2
                   libinput-1.8.0-1  libmariadbclient-10.1.25-1  libnm-1.8.2-1
                   libnm-glib-1.8.2-1  libofa-0.9.3-7  libpng-1.6.30-1
                   libsystemd-233.75-3  libtirpc-1.0.2-1  libtommath-1.0-2
                   libuv-1.13.1-1  libvoikko-4.1.1-1  libxml2-2.9.4+96+gfb56f80e-1
                   linux-4.11.9-1  logrotate-3.12.3-1  lvm2-2.02.172-2
                   mariadb-10.1.25-1  mariadb-clients-10.1.25-1  mesa-17.1.4-1
                   mesa-vdpau-17.1.4-1  modemmanager-qt-5.36.0-1
                   networkmanager-1.8.2-1  networkmanager-qt-5.36.0-1
                   numix-icon-theme-1:0.r1944-1  oxygen-icons-1:5.36.0-1
                   plasma-framework-5.36.0-1  prison-5.36.0-1  protobuf-3.3.2-1
                   psmisc-23.1-1  pyqt5-common-5.9-1  python-pyqt5-5.9-1
                   python-sip-4.19.3-1  python2-2.7.13-3  python2-pillow-4.2.1-1
                   python2-pycparser-2.18-1  python2-pyqt5-5.9-1
                   python2-sip-4.19.3-1  qt5-base-5.9.1-2  qt5-declarative-5.9.1-2
                   qt5-graphicaleffects-5.9.1-1  qt5-imageformats-5.9.1-1
                   qt5-location-5.9.1-2  qt5-multimedia-5.9.1-2
                   qt5-quickcontrols-5.9.1-2  qt5-quickcontrols2-5.9.1-2
                   qt5-script-5.9.1-2  qt5-sensors-5.9.1-2  qt5-speech-5.9.1-2
                   qt5-styleplugins-5.0.0.1r36-2  qt5-svg-5.9.1-2
                   qt5-tools-5.9.1-3  qt5-webchannel-5.9.1-2  qt5-webengine-5.9.1-3
                   qt5-webkit-5.212.0alpha2-4  qt5-x11extras-5.9.1-2
                   qt5-xmlpatterns-5.9.1-2  sip-4.19.3-1  solid-5.36.0-1
                   sonnet-5.36.0-1  syntax-highlighting-5.36.0-1  systemd-233.75-3
                   systemd-sysvcompat-233.75-3  threadweaver-5.36.0-1  tidy-5.4.0-2
                   tp_smapi-0.42-19  udisks2-2.7.1-2  unrar-1:5.5.6-1
                   xscreensaver-5.37-1
    
    Total Download Size:     17.15 MiB
    Total Installed Size:  1536.58 MiB
    Net Upgrade Size:        13.77 MiB
    
    :: Proceed with installation? [Y/n] Y
    :: Retrieving packages...
     dolphin-root-17.04....     3.4 MiB   907K/s 00:04 [######################] 100%
     kate-root-17.04.2-1...     6.0 MiB  1418K/s 00:04 [######################] 100%
     numix-icon-theme-1:...     3.6 MiB  1953K/s 00:02 [######################] 100%
     qt5-styleplugins-5....   413.5 KiB  1042K/s 00:00 [######################] 100%
     libblockdev-2.10-1-...   154.3 KiB   760K/s 00:00 [######################] 100%
     appstream-0.11.1-2-...  1842.5 KiB  2031K/s 00:01 [######################] 100%
     appstream-qt-0.11.1...    53.1 KiB  2.59M/s 00:00 [######################] 100%
     avogadrolibs-1.90.0...  1330.9 KiB  1882K/s 00:01 [######################] 100%
     tidy-5.4.0-2-x86_64      342.8 KiB  2.66M/s 00:00 [######################] 100%
     libtommath-1.0-2-x86_64   53.3 KiB  1616K/s 00:00 [######################] 100%
    (162/162) checking keys in keyring                 [######################] 100%
    (162/162) checking package integrity               [######################] 100%
    error: dolphin-root: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is marginal trust
    :: File /var/cache/pacman/pkg/dolphin-root-17.04.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: kate-root: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is marginal trust
    :: File /var/cache/pacman/pkg/kate-root-17.04.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: numix-icon-theme: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is marginal trust
    :: File /var/cache/pacman/pkg/numix-icon-theme-1:0.r1944-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: qt5-styleplugins: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is marginal trust
    :: File /var/cache/pacman/pkg/qt5-styleplugins-5.0.0.1r36-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: failed to commit transaction (invalid or corrupted package)
    Errors occurred, no packages were upgraded.
    [[email protected] alex]# 
    
    

    As you can see, it complains of marginal trust and corrupted packages. I have tried refreshing the repos keys, though to no avail. Perhaps I have done something wrong, because I doubt that the issue is a bug. Thank you all in advance, and any assistance would be greatly appreciated.

  • Maybe this article from the Wiki can help you?

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • @Keegan Will do. Give me just a moment, and I will report back to you on the results.

  • Thanks😀.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • Thank you! Finally, I have success. Along with attempting each and every step throughout this guide, what finally offered me my solution was the, “Alternative 1” solution.

    I had to move the old gnupg folder, init my keyring, after reinstalling them, and then repopulating it. I am sure that this issue will occur again, so I have bookmarked the page for further reference.

  • Glad you were able to get it solved! May the rest of your Antergos experience be painless🙂.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

pacman107 issues81 updateupgrade2 Posts 6Views 884
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.