• Bumblebee Install BTRFS Errors on Boot


    Hi guys. I’ve been trying to get Bumblebee installed and configured on my system and have been following the official Antergos install guide that came out a few days ago. However, when I got to the point of rebooting, I selected Antergos, I had a bunch of errors pop up saying the following:

    BTRFS error (device sda9): Error removing orphan entry, stopping orphan cleanup.
    BTRFS error (device sda9): could not do orphan cleanup -22
    BTRFS error (device sda9): Open-ctree failed
    mount: wrong fs type, bad option, bad superblock on /dev/sda9

    You are now being dropped into an emergency shell.

    I don’t know what went wrong during the installation. I’m assuming there is a ctree error somewhere. Any advice would be awesome.

    BTRFS

  • btrfs check --repair <device>
    (device needs to be unmounted)
    ? but this is a dangerous command, if you do not have any backups.

    https://wiki.archlinux.org/index.php/Btrfs#btrfs_check

    But this seems to not be related to bumblebee installation, more to btrfs and his heavy development state…

  • Hi Joekamprad. Thanks for the tip. I can’t seem to be able to execute the command in the emergency terminal. There is no “btrfs” command available, it says.

  • no! you need to bootup with a liveiso and do it from there.

  • My bad. I tried the repair command and it didn’t work, and said it was unsuccessful.

  • i am not the expert for btrfs so i am out of idea now.

  • No problem, thanks for pointing me in the right direction at least.

    Update: This is what comes up when I try to perform the btrfs repair: 0_1499717306986_Screenshot from 2017-07-10 13-04-35.png

  • i find this to fix checksum error:
    btrfs check --fix-crc <device>

  • Do you advice going this route? I heard some people say to be very cautious when clearing or fixing checksum errors.

  • As i say before: but this is a dangerous command, if you do not have any backups.

    btrfs is not ready it is a heavy beta filesystem…
    I would not use it for my daily system, maybe in 2 years but not 2017.

    mount: wrong fs type, bad option, bad superblock on /dev/sda9
    

    So you can not mount it… this is may be related to software failure and also the crc-errors are related to software and not for real.
    https://btrfs.wiki.kernel.org/index.php/Status

  • It didn’t seem to recognize the command…

    Yeah, I’m assuming it has to be software based, but just not sure where to look.

  • Post this link in case anyone needs Btrfs mount options

    https://btrfs.wiki.kernel.org/index.php/Mount_options

  • BTRFS = Better Try a Real File System
    J.

  • Thanks for all the help guys. I finally figured out a solution (still no idea the cause) where I did --init-csum-tree, then --init-extent-tree, and finally --repair. It seemed to fix the root issue, but there were tons of corrupted files everywhere, so I had to check lost+found and restore/reinstall those files, and just to be safe, reinstall all packages on my system. Ended up working out ok in the end.

    Someone told me the issue might be TLP or Powertop trying to throttle sata power too low, and it was my SSD that was creating the BTRFS errors. I’ll do some checking and see what the results are.

boot280 bumblebee44 btrfs13 Posts 14Views 1718
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.