• System freezes/crashes often (journalctl)


    Hello antergos community,

    recently I switched from debian to antergos and have problems with system freezes/crashes. Sometimes it starts to react again after some time but isn’t performing as it should (cannot open applications etc.), so I have to hard shutdown.

    I cannot identify a pattern when it does but it happens often enough to not get it set up and running.

    I reinstalled several times and it seems to be runnning at first but after some time it starts freezing again. I’m now on a new default install with GNOME and activated extensions.

    I have captured journalctl and can see erros from GNOME and others. Someone can read this properly? :)

    What I have done:

    1. bootet system
    2. idle for minutes
    3. installed keepassx2 via pacman (qt4 libs as dependency)
    4. initiated keepassx2 launch via GNOME dash
    5. freeze
    6. waited and initiated terminal start to verify if system is responsive
    7. waited
    8. system reacted and terminal started (no keepassx2)
    9. system not usable (cannot open applications, wrong/missing icons etc.)
    10. hard power off
    11. issued journalctl -b -0

    I did run memtest86 without errors.

    Hope I get this to work, cause what I have seen from distro and community in the past days debugging - this is awesome. Kudos!

    Thanks for taking time. :)

    //EDIT: journalctl https://filebin.ca/3SupdPq622Ra/logs.tar.xz

  • upload here https://filebin.ca/ and post the url ;)

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • For me the problems looks like typically to wayland… do you try to choose Xorg Gnome Session too?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in System freezes/crashes often (journalctl):

    upload here https://filebin.ca/ and post the url ;)

    https://filebin.ca/3SupdPq622Ra/logs.tar.xz

    @joekamprad said in System freezes/crashes often (journalctl):

    For me the problems looks like typically to wayland… do you try to choose Xorg Gnome Session too?

    Nope, didn’t do that. I have to reinstall for testing. Am currently trying out standard arch installation with GNOME.

    Thanks for quick tips! :)

  • No reinstallation nessesary! from loginmanager (lightdm) you can change the session from “Gnome” to “Gnome Xorg” on the run…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in System freezes/crashes often (journalctl):

    No reinstallation nessesary! from loginmanager (lightdm) you can change the session from “Gnome” to “Gnome Xorg” on the run…

    Yep, thanks. I ment to test with antergos installation. Currently testing with basic arch + GNOME. I will see if it happens on this installation with wayland, too. If so will see what happens with Xorg. Good advice!

  • ah o.k. you mean you will do a Archlinux installation with gnome to see if it is the same…
    I have try this before too… but on my system i have a nvidia card with nouveau issues, so same on Archlinux for me.

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • i can see a lot acpi errors and fails from your log, you can try to add
    acpi_enforce_resources=lax
    to kernel parameter, this often is a solution for not working acpi stuff.
    you can do this (if you are using grub) like this:

    sudo nano /etc/default/grub
    paste acpi_enforce_resources=lax after GRUB_CMDLINE_LINUX_DEFAULT="quiet
    save the file and do rewrite the grub.cfg:

    sudo grub-mkconfig -o /boot/grub/grub.cfg

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in System freezes/crashes often (journalctl):

    i can see a lot acpi errors and fails from your log, you can try to add
    acpi_enforce_resources=lax
    to kernel parameter, this often is a solution for not working acpi stuff.
    you can do this (if you are using grub) like this:

    sudo nano /etc/default/grub
    paste acpi_enforce_resources=lax after GRUB_CMDLINE_LINUX_DEFAULT="quiet
    save the file and do rewrite the grub.cfg:

    sudo grub-mkconfig -o /boot/grub/grub.cfg

    Reading your answer before the edit I added the parameter to GRUB_CMDLINE_LINUX="" before the cryptdevice. Does this work too or should I change?

    Also at boot before decrypting I see this messages:

    platform wdat_wdt: failed to claim resource 4: [io   0x0071-0x0072
    ACPI: watchdog: Device creation failed: -16
    

    Does this relate to the ACPI fails or can I ignore?

  • kernel parameter sequence does not play a role…

    Lets see if your log is clean after the reboot with my kernel parameter…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in System freezes/crashes often (journalctl):

    kernel parameter sequence does not play a role…

    Lets see if your log is clean after the reboot with my kernel parameter…

    So, yesterday I install antergos again with your kernel parameter improvements and set GNOME under Xorg up. Just extensinos and gtk-theme. Otherwise the system is still pretty standard.

    Today I bootet up and got message about new updates. I clicked on the notification from pamac and the system was frozen this moment. After a minute or two the system ‘responded’ again but I wasn’t able to do anything, no applications started etc. -> hard shutdown.

    Here are ‘journalctl_crash’ for the boot with instant crash and ‘journal_good’ for the fine boot after hard shutdown till the moment I’m writing this.

    https://filebin.ca/3T0ye94Jtbtr/logs.tar.xz

    ACPI errors are less IMHO, but still there. A lot of gnome-shell errors.

  • This gnome-shell errors seems to be mostly normal, i have the same number and a full functional Desktop.

    I was wondering if you cann pass your system specs: lspci/lsusb

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in System freezes/crashes often (journalctl):

    This gnome-shell errors seems to be mostly normal, i have the same number and a full functional Desktop.

    I was wondering if you cann pass your system specs: lspci/lsusb

    $ lspci
    
    00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
    00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
    00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
    00:04.0 Signal processing controller: Intel Corporation Broadwell-U Processor Thermal Subsystem (rev 09)
    00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
    00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
    00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
    00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
    00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)
    00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
    00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
    00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
    00:1f.6 Signal processing controller: Intel Corporation Wildcat Point-LP Thermal Management Controller (rev 03)
    01:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)
    
    $ lsusb
    
    Bus 001 Device 002: ID 8087:8001 Intel Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 002 Device 006: ID 04f3:2033 Elan Microelectronics Corp. 
    Bus 002 Device 005: ID 8087:0a2a Intel Corp. 
    Bus 002 Device 004: ID 0c45:64cb Microdia 
    Bus 002 Device 003: ID 0483:91d1 STMicroelectronics Sensor Hub
    Bus 002 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    
  • @apt-get said in System freezes/crashes often (journalctl):

    HD Graphics 5500
    do you have this file?

    cat /etc/X11/xorg.conf.d/20-intel.conf
    

    if not create it:

    sudo nano /etc/X11/xorg.conf.d/20-intel.conf
    

    with this inside: (copy paste and save with Ctrl+X)

    Section "Device"
            Identifier "Intel Graphics"
            Driver     "intel"
            Option     "AccelMethod" "uxa"
            Option     "DRI" "2"
    EndSection
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in System freezes/crashes often (journalctl):

    @apt-get said in System freezes/crashes often (journalctl):

    HD Graphics 5500
    do you have this file?

    cat /etc/X11/xorg.conf.d/20-intel.conf
    

    File wasn’t there and I created as you told.

    // EDIT: Again crashed after reboot when clicked update on pamac. Was put into shell after some time. Had to hard shutdown. Sideeffect - I’m now located in Ghana referring to automatic timezone…

    journalctl and Xorg logs
    https://filebin.ca/3T1Y2Pi8390U/logs.tar.xz

  • So better remove this again:

    sudo rm /etc/X11/xorg.conf.d/20-intel.conf
    

    I have no idea looks like a corrupted installation to me, but as you say it was a fresh install…
    Hardware sided i do not see problems, should work mostly out of the box.

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in System freezes/crashes often (journalctl):

    So better remove this again:

    sudo rm /etc/X11/xorg.conf.d/20-intel.conf
    

    I have no idea looks like a corrupted installation to me, but as you say it was a fresh install…
    Hardware sided i do not see problems, should work mostly out of the box.

    It’s not like the file made it worse. Just same problem.

    I could install arch linux again and test if it makes a difference… not sure. I could also try another DE but I really like GNOME with its extensions.

    Antergos made me switch and try out Arch Linux, which I really started to like. So I really don’t want to revert to debian (which is definitely awesome in its own way, too). Very unfortunate, but many thanks for your great support! Awesome distro and community. :)

  • If you do a reinstall i advise to clean the drive with zeros (dd if=/dev/zero of=/dev/sdX) before new installtion.

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in System freezes/crashes often (journalctl):

    If you do a reinstall i advise to clean the drive with zeros (dd if=/dev/zero of=/dev/sdX) before new installtion.

    I will do so. Can you explain to me, why I should do this? Thanks!

  • I am not shure but it seems that because without cleaning the drive files will not be erased and if you reinstall system with exact the same scheme, files will be on exact the same place on the disk. so it comes to irregularities.

    I investigate into this on my actual System, having a unstable system after fresh installation with unusual errors, and also incomplete. After overwriting with zeros and a new installation with same structure and media… all fine.

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

Posts 24Views 1157
Log in to reply