• Bumblebee Installation Stuck


    Hey guys. I’m trying to get Bumblebee and I came accross this awesome article on how to do it: (antergos …uncategorized/bumblebee-for-nvidia-optimus) (blame askimet)

    I’m stuck at the whole “modprobe.blacklist=nouveau” step, not being sure what file I edit. When I did this on Fedora, it was a different process. Can anyone point me in the right direction about how I am supposed to go about this?

    Thanks for the help guys.

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

  • @mach01dan said in Bumblebee Installation Stuck:

    …I’m stuck at the whole “modprobe.blacklist=nouveau” step, not being sure what file I edit…

    When LiveUSB or LiveDVD starts up, Antergos installation menu is presented. It’s mostly white-to-light grey background, with blue Antergos logo at the top of the screen, and startup menu, which consists of:

    • Boot from Hard Disk
    • Start Antergos Live
    • Non-Graphical Boot

    At the bottom of screen the kernel’s boot parametrs line automatically appears. It content changes when you move among three boot options.

    Select the second one:

    • Start Antergos Live

    Now, simply start typing in modprobe.blacklist=nouveau. The text you type in will be automatically added and appear at the end of the boot line.

    Then simply press Enter to start booting into the Live session.

    It’s really a very easy process, much easier than navigation in Anaconda 🙂 .

  • Hi Just.

    Thanks for the info. This may be a really stupid question, but how do I get into that mode? Do I need to insert my Antergos installer USB stick?

    Agreed, I’m liking Arch much better than Fedora so far, once I did all my system mods.

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

  • @mach01dan I’m not sure to correctly understand your question.

    Download the Antergos ISO. Write it to USB stick or burn it to a DVD disk. These are live media. Boot the computer from LiveUSB or LiveDVD. Antergos installation menu will appear. As described above.

    That’s it.

  • Awesome, thanks for clearing that up. That’s what I suspected, but just wanted to make sure.

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

  • @just At the section where it says known issues with the GTX 960M,

    When rebooting your computer might not start again. To solve that issue add acpi_osi="!Windows 2015" as a kernel parameter. See issue #764(comment) on github.
    To make that change permanent in grub add in /etc/default/grub

    When you say kernel parameter, how exactly am I supposed to do that? I am a bit of a noob on antergos.

  • @boonierat said in Bumblebee Installation Stuck:

    …When you say kernel parameter, how exactly am I supposed to do that?

    I think the article is clear enough about how to do it:

    To make that change permanent in grub add in /etc/default/grub

    GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=\"!Windows 2015\""
    

    and create grub config after with the command

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    The “Known Issues - GeForce GTX 960M” section was not added by me. I do not have 960M card, and cannot check how the suggested solution works.

  • @just The boot menu is different now and not as it was before. I do not see where to type in the above text.

    Sorry for the dumb questions.

  • @boonierat said in Bumblebee Installation Stuck:

    The boot menu is different now and not as it was before. I do not see where to type in the above text.

    Ok, I see. Those changes are to be applied to existing /etc/default/grub file and to regenerate Grub 2 boot loader. They aren’t for being typed in by hand on the boot line.

    I do not use Grub 2 boot loader, included in Antergos (and all other distros, nowdays). For this reason, I’m not very familiar with its commands to edit the boot line.

    Search in Internet, or ask here, in the forum, for how to edit Grub 2 boot line. It’s better than get wrong indications from my side. Editing of Grub 2 boot line is really a very simple job.

    Good luck.

installation251 bumblebee37 stuck33 Posts 9Views 777
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.