• pacman -Syu dependency.


    Already a while ago I’m with dependencies below to update my system:

    :: Synchronizing package databases...
     core is up to date                                                                0.0   B  0.00B/s 00:00 [---------------------------------------------------------------]   0%
     extra is up to date                                                               0.0   B  0.00B/s 00:00 [---------------------------------------------------------------]   0%
     community is up to date                                                           0.0   B  0.00B/s 00:00 [---------------------------------------------------------------]   0%
     multilib is up to date                                                            0.0   B  0.00B/s 00:00 [---------------------------------------------------------------]   0%
     antergos is up to date                                                            0.0   B  0.00B/s 00:00 [---------------------------------------------------------------]   0%
     pantheon is up to date                                                            0.0   B  0.00B/s 00:00 [---------------------------------------------------------------]   0%
    :: Starting full system upgrade...
    warning: gala-git: local (0.3.0.r97.05b5a7e-1) is newer than pantheon (0.3.0.r96.66b5d4a-1)
    warning: pepper-flash: local (1:25.0.0.171-1) is newer than extra (26.0.0.131-2)
    resolving dependencies...
    looking for conflicting packages...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: gnome-perl: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
    :: gnome-vfs-perl: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
    :: gnomecanvas-perl: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
    :: perl-gnome2-wnck: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
    :: perl-goo-canvas: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
    :: perl-gtk2-imageview: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
    :: perl-gtk2-unique: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
    
    

    What is the time to launch these packages?

  • Hi,

    All those packages are AUR packages, right? You’ll have to wait until their maintainer updates them. Perl is 5.26 now.

    If you don’t need those packages remove them.

    Cheers!

syu7 dependency9 pacman80 Posts 2Views 265
Log in to reply