• Resolving Host Issues


    I’ve been having issues with my network connection that I’ve failed to figure out so far. I’m running Antergos on an HP Elitebook 755 G3 laptop. When I first boot my laptop, the wifi internet connection runs great but sometimes within a few seconds or several minutes, typing in a new address or clicking on a link Chrome will sit with “resolving host” and eventually the network will timeout. All other internet applications will be affected by this. The only way to get the connection back is to disconnect from the wifi connection and to reconnect. It will then work for a while only to come back with the same issue.

    Thus far I have tried disabling IPV6, I’ve tried specifying Google DNS servers. My default resolve.conf reads the following:

    nameserver 8.8.8.8
    nameserver 192.168.1.1
    nameserver 71.10.216.1
    nameserver 71.10.216.2
    nameserver 8.8.4.4

    I’ve tried disabling everything but the Google DNS servers but that doesn’t seem to help much either (plus resolve.conf seems to get rewritten every time my network settings change).

    I’ve also tried disabling Chrome DNS caching (per other threads I’ve read) and that doesn’t seem to help.

    Any help would be greatly appreciated!

  • @slameradamis Well the Arch wiki says:

    “To use alternative DNS servers, edit /etc/resolv.conf and add them to the top of the file so they are used first, optionally removing or commenting out already listed servers. Currently, you may include a maximum of three nameserver lines.”

    So if the order you listed them in your post is the order in your file ( and you want to use Google DNS), Try this: List them in this order:

    nameserver 8.8.8.8
    nameserver 8.8.4.4
    nameserver 192.168.1.1
    #nameserver 71.10.216.1
    #nameserver 71.10.216.2

    The 192.168.1.1 is a router address I don’t have that in mine. move it down or comment it out by putting a “#” in front of it if you don’t need it.

    The other two numbers are Charter DNS(?) if you want to use that, make them the first 2 entries and comment out the Google DNS

    Edit: Network manager can overwrite etc/resolve.conf so change your DNS in network manager if different.

  • When you still have a DNS server enabled on the Router it is not a good idea to do this behind the Router… (if you do not pipe through this by a service…) also if you still have the Router IP added as a DNS server…

    I would do this inside the Router, provider mostly have there own DNS Server and the Router is linked to this ones.

    Better to have the Router as local DNS Server inside your Computers config, and the Router have the DNS config (google Servers as you want) on the outside network (internet)

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Thanks for the suggestions so far. I’m beginning to think this might be a driver issue instead of a router or dns issue. The reason I’m thinking this is because while Chrome is stuck saying “resolving host”, I pulled up a terminal window and tried pinging my router by typing in the IP address and it could not even do that. It just sat there (wouldn’t even move line by line like it usually would, it just sat like the command was unresponsive. I then disconnected my wifi connection and reconnected and immediately it started pinging the router.

    I also looked into seeing if this was a power management issue thinking that may be the kernel was sending my wifi into low power use. I used the following command (gleaned from some other threads)dmes:

    sudo iwconfig wlp2s0 power off

    It did not seem to make a difference though. Are there any other commands / tools that might be helpful in diagnosing this problem? My computer is the only device on the network that is having these issues so I do not think it is a config issue with the router itself.

issues51 resolving2 host3 Posts 4Views 277
Log in to reply