• X-Box controller blinking issue (Solved in Antergos-17.10)


    i’ve been using antergos for a while now and i stayed using if because its is based on Arch and im familiar with pacman (i use msys2 in windows). i started using installer 17.6 with had no issues up to the last update i made which had kernel 4.11.7(or sometime last week). i wanted to reinstalled today so i can do upgrade and change to efi in one go. and sadly, the new install broke x-box wired controller. this used to work but now its having this dreaded blinking issue wherein you can only unplug and replug it to make it work regardless if using xboxdrv or steamos drivers and other methods found in the net.

    i went ahead and reinstalled stuff and used vanilla arch installer instead(using the same Xfce4) and everything is well OK. i hope this can be looked into so i can come back and use antergos
    thanks.

  • decided to have another run at Antergos. I downloaded Antergos 17.7-minimal. booted it up and was a bit happy when my x-box controllers is now not blinking even if its running kernel 4.11.9-1. decided to install it, took a bit of time(i do not have the best internet speed, one installation using xfce takes about 2hours to complete). when its done, it still has this “x-box blinking problem”. antergos 17.6 used to worked sometime before 4.11.9-1 was used. and using vanilla arch does not have this issue (also installed xfce, and yes i installed and updated it)

  • please pastebin your log and give us the link, uploading on forum has some issues.

    textbased: https://paste2.org/
    filebased: https://filebin.ca/

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Jul 11 14:08:01 linux kernel: input: Microsoft X-Box 360 pad as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0/input/input13
    
    Jul 11 14:08:01 linux kernel: usbcore: registered new interface driver xpad
    

    only related stuff from logs…

    Looks like find the device and also load the driver correctly…

    I find this:

    Known issues with Wireless controllers

    Support for wireless controllers are still experimental. And although the controllers work, the following issues exist:

    The LED indicator on the controller continues to blink even after the controller has been connected.
    There is no way to turn the controller off, save removing the batteries.
    Some programs may require that you resync the controller after starting them in order for the controller to work.

    there is also a dkms driver on AUR:

    https://aur.archlinux.org/packages/steamos-xpad-dkms/

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad

    im using wired controller but i’ve read it does have the same issue with wireless controllers. already tried using streamos-xpad and xboxdrv both still needs controller to be unplugged and replugged for it to work.

    i’ve been using installer 17.6 and that time all worked out-of-the-box that was why i prefered Antergos over Manjaro. but sometime when kernel 4.11.9 was used, this broke x-box controller compatiblity. For comparison, i did fresh vanilla install of Arch and updated it to latest sources and it does not have this issue. the antergos 17.7 installer i used also does not have this blinking issue and it just works.

    Considering is used to work in Antergos and mainstream Arch does not have this issue, then i wonder if this can be fixed so i can continue to use Antergos.

  • I see that Team Antergos already reverted this at least on version 17.10 and now xbox controller is working fine without the need to unplug-replug each time you reboot.

    Thanks.

Posts 7Views 372
Log in to reply