• Grub does not show Antergos


    I am a new member here and i am totally new to Antergos as well. This is my first Arch-based distro to try.

    I have a dual-boot ready 1TB HDD and already have Ubuntu installed on the first partition. I installed Antergos on the 2nd partition but when Ubuntu’s Grub shows up, it does not display Antergos as another option to choose for booting.

    Can anyone help?

  • two options ;)

    more easy would bring Ubuntu-Grub to include Antergos, as you can boot easy into it.

    But as i do not have any knowledge on ubuntu i can not give you detailed instruction now…

    To give you second option (install grub from within Antergos) i need to know some specs:

    EFI System or Bios? and the output of sudo fdisk -l

  • @joekamprad

    I am using EFI. Here’s the result of the result of fdisk -l:
    Ubuntu is on /sda3. Antergos is on /sda5. /sda4 is a actually a custom mouse point I use for media files and other temporary content.

    Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: 3FCAF030-4482-4E00-AE21-7B5C06FCF063

    Device Start End Sectors Size Type
    /dev/sda1 2048 3905535 3903488 1.9G EFI System
    /dev/sda2 3905536 37107711 33202176 15.9G Linux swap
    /dev/sda3 37107712 818747391 781639680 372.7G Linux filesystem
    /dev/sda4 818747392 1406638079 587890688 280.3G EFI System
    /dev/sda5 1406638080 1953523711 546885632 260.8G Linux filesystem

  • Could try from Ubuntu with:

    # os-prober
  • @judd Tried that. Rebooted. Nothing changed.

  • needs to rewrite the grub.cfg

    sudo os-prober
    sudo grub-mkconfig 
    sudo update-grub

    i do not know if os-prober is installed inside your ubuntu…

  • @joekamprad okay that wored :)

    But now I have a different problem. When I choose Antergos from Grub this is what I get:


    What am I doing wrong?

  • Not you it was a missunderstanding by grub-mkconfig i think ?

    It is possible to copy missing information from Antergos to ubuntu from Antergos grub files…
    But i am niot shure how to at the moment…

    I think the proper way is to create a seperate file for adding the Antergos entry to Ubuntu grub.

    I also find this:
    Arch not found from other OS
    Some have reported that other distributions have trouble finding Arch Linux automatically with os-prober. If this problem arises, it has been reported that detection can be improved with the presence of /etc/lsb-release. This file and updating tool is available with the package lsb-release in the official repositories.

  • gksudo gedit /etc/grub.d/40_custom
    sudo update-grub

    mounting Antergos root and open /boot/grub/grub.cfg there you will find Antergos menu entry from grub…

  • Hey, also an Arch Linux newb (not to linux though) and I came across a similar issue. Try running " sudo grub-mkconfig -o /boot/grub/grub.cfg" to see if GRUB recognizes the image. If you chose not to install it because you already had GRUB, this is very likely the issue.

  • As i know now this is a bug with grub + os-prober here detection goes wrong may because of intel-ucode

    I got a similar problem here with triple boot system (win10 / Archlinux /Antergos)
    I get it solved by running os-prober and rewrite the grub.cfg out of Antergos, booting with LiveIso and chroot into it… then wait like forever to get os-prober ends (i think 15-20 Minutes) and voila i get also a fullscreen Grub-Boot screen with all the 3 Bootentries aviable and working

grub126 show24 Posts 11Views 1921
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.