• System boots to blackscreen after major update


    after some time I did a system update and after booting again, I got only a black screen. I have a Asus ux305, I assume there might be some problem with the intel driver. Can someone help, please?

    # uname -a
    Linux babbage 4.11.7-1-ARCH #1 SMP PREEMPT Sat Jun 24 09:07:09 CEST 2017 x86_64 GNU/Linux

    In dmesg I see the following:

    [    2.146215] ------------[ cut here ]------------
    [    2.146253] WARNING: CPU: 2 PID: 254 at drivers/gpu/drm/i915/intel_pm.c:3749 skl_compute_wm+0xbf5/0x1550 [i915]
    [    2.146253] WARN_ON(!intel_pstate->base.fb)
    [    2.146254] Modules linked in: sparse_keymap mac80211 snd_soc_skl snd_soc_skl_ipc snd_soc_sst_ipc iwlwifi snd_soc_sst_dsp snd_hda_ext_core snd_soc_sst_mat
    ch nls_iso8859_1 intel_rapl snd_soc_core x86_pkg_temp_thermal nls_cp437 intel_powerclamp coretemp snd_compress kvm_intel snd_pcm_dmaengine vfat cfg80211 fat 
    kvm irqbypass ac97_bus crct10dif_pclmul crc32_pclmul crc32c_intel ghash_clmulni_intel i915 pcbc aesni_intel snd_hda_intel idma64 snd_hda_codec uvcvideo aes_x
    86_64 crypto_simd glue_helper cryptd videobuf2_vmalloc drm_kms_helper intel_cstate videobuf2_memops videobuf2_v4l2 snd_hda_core intel_rapl_perf videobuf2_cor
    e snd_hwdep drm videodev snd_pcm media evdev snd_timer intel_gtt syscopyarea snd mei_me sysfillrect input_leds sysimgblt mac_hid pcspkr fb_sys_fops processor
    _thermal_device soundcore
    [    2.146275]  i2c_i801 mei i2c_algo_bit shpchp intel_pch_thermal intel_soc_dts_iosf intel_lpss_pci i2c_hid thermal elan_i2c hid wmi int3403_thermal hci_uar
    t intel_lpss_acpi battery int3406_thermal int3402_thermal intel_lpss btqca video int340x_thermal_zone ac tpm_crb int3400_thermal asus_wireless acpi_thermal_r
    el acpi_als led_class kfifo_buf button industrialio acpi_pad tpm_tis tpm_tis_core tpm btusb btrtl btbcm btintel bluetooth rfkill sch_fq_codel sg ip_tables x_
    tables ext4 crc16 jbd2 fscrypto mbcache sd_mod serio_raw atkbd libps2 ahci libahci xhci_pci libata xhci_hcd scsi_mod usbcore usb_common i8042 serio
    [    2.146300] CPU: 2 PID: 254 Comm: kworker/u8:4 Not tainted 4.11.7-1-ARCH #1
    [    2.146301] Hardware name: ASUSTeK COMPUTER INC. UX305UA/UX305UA, BIOS UX305UA.201 10/12/2015
    [    2.146305] Workqueue: events_unbound async_run_entry_fn
    [    2.146306] Call Trace:
    [    2.146310]  dump_stack+0x63/0x81
    [    2.146312]  __warn+0xcb/0xf0
    [    2.146314]  warn_slowpath_fmt+0x5a/0x80
    [    2.146345]  skl_compute_wm+0xbf5/0x1550 [i915]
    [    2.146379]  intel_atomic_check+0x5ac/0x11a0 [i915]
    [    2.146386]  ? drm_mode_object_unreference+0x15/0x20 [drm]
    [    2.146392]  drm_atomic_check_only+0x39e/0x580 [drm]
    [    2.146397]  drm_atomic_commit+0x18/0x50 [drm]
    [    2.146400]  restore_fbdev_mode+0x222/0x280 [drm_kms_helper]
    [    2.146402]  drm_fb_helper_restore_fbdev_mode_unlocked+0x2e/0x80 [drm_kms_helper]
    [    2.146405]  drm_fb_helper_set_par+0x2d/0x60 [drm_kms_helper]
    [    2.146435]  intel_fbdev_set_par+0x18/0x70 [i915]
    [    2.146437]  fbcon_init+0x484/0x650
    [    2.146440]  visual_init+0xd6/0x130
    [    2.146441]  do_bind_con_driver+0x1fc/0x420
    [    2.146443]  do_take_over_console+0x82/0x1b0
    [    2.146445]  do_fbcon_takeover+0x5c/0xb0
    [    2.146446]  fbcon_event_notify+0x587/0x780
    [    2.146448]  notifier_call_chain+0x4a/0x70
    [    2.146450]  blocking_notifier_call_chain+0x43/0x60
    [    2.146452]  fb_notifier_call_chain+0x1b/0x20
    [    2.146453]  register_framebuffer+0x24d/0x360
    [    2.146455]  ? vga_switcheroo_client_fb_set+0x5b/0x70
    [    2.146458]  drm_fb_helper_initial_config+0x230/0x3e0 [drm_kms_helper]
    [    2.146487]  intel_fbdev_initial_config+0x18/0x30 [i915]
    [    2.146489]  async_run_entry_fn+0x37/0x150
    [    2.146491]  process_one_work+0x1e0/0x490
    [    2.146493]  worker_thread+0x48/0x4e0
    [    2.146494]  kthread+0x125/0x140
    [    2.146495]  ? process_one_work+0x490/0x490
    [    2.146497]  ? kthread_create_on_node+0x70/0x70
    [    2.146499]  ret_from_fork+0x2c/0x40
    [    2.146500] ---[ end trace b45da8c5dcb81a7f ]---
    [    2.146501] ------------[ cut here ]------------


  • @adammar said in System boots to blackscreen after major update:

    after some time

    How long is the last update?

  • It was an updated after two weeks or so (after the exam period). It definitely contained among many other things a new kernel.

  • So if you can still login over TTY2 ?
    (Console Login)

    first thing you can do is rebuild the images:

    mkinitcpio -p linux

    then reboot and see if you can go forward to get X started, second one can be try to use anothe DM like GDM SDDM e.t.c. (instead of Lightdm)

  • @joekamprad I can do that, but blindly. When I change consoles (^+alt+fX), the screen keeps being black. But, when I write the root login and pwd, type “reboot” and hit enter, the system reboots, so I guess everything underneath is OK, it’s only the screen that’s black. I even got the sshd to start after boot so I can log in remotely and do stuff.

    Since the problems started I updated several times hoping for a lucky fix of the problem, so the image was rebuilt several times during those updates (I remember at least one of them was also a kernel update).

    I tried to rebuild the images anyway and it didn’t help. When I was logged in via ssh I also checked the syslog and it seems that lightdm starts and works just fine.

  • good to know, then it looks like a problem with graphic driver at last?

    What is your Chipset/Card ?

  • @joekamprad I have an asus UX305UA with i7-6500U CPU and intel HD520 graphics card.

  • intel graphics should not be a problem…
    And also if you have Lightdm running and only the screen blacked it is not a X problem (GRAPHICDRIVER RELATED) i can only think of acpi stuff, powermanagement …
    May screen brightness is putting to zero or stuff like this…

    diggin in the dark here… if you want you can try to post log data…

  • @joekamprad I got what I could. If you could take a look at them I’d be very happy. Hopefully you can spot something weird: db-link

  • i will take a look deeper inside, but on a first view i see a lot of kernel traces.
    This looks like a kernel related problem, so without going deeper i would give the LTS-Kernel a chance.


    sudo pacman -S linux-lts 
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    and choose “advanced option”" from grub boot menu, and then Antergos Linux-lts to boot from this one.

    Long term support (LTS) Linux kernel and modules from the core repository.

  • @joekamprad I already tried the LTS kernel (could have mentioned earlier, sorry) and it unfortunately doesn’t work: I also get a lot of kernel traces and on first site they look very similar. I can send you the logs from the lts kernel boot as well, if you think it could help.

  • i am o.k. with the logs from latest kernel ;)

  • ASUSTeK COMPUTER INC. UX305UA/UX305UA, BIOS UX305UA.201 10/12/2015

    BIOS 201 > your Bios is upto date…

    And this is what comes before the traces:

    [    1.983503] WARNING: CPU: 0 PID: 104 at drivers/gpu/drm/i915/intel_pm.c:3749 skl_compute_wm+0xbf5/0x1550 [i915]
    [    1.983503] WARN_ON(!intel_pstate->base.fb)

    try to use one of this kernel parameters may help:



  • @joekamprad I tried rebooting with those parameters, but the problem still persists and in syslog I can still see those tracelogs :(

  • @joekamprad said in System boots to blackscreen after major update:


    i just find a related bug here:


    “The computer boots and the screen becomes black when starting the DRM.”

  • @joekamprad Thank you! I will continue solving it there.

  • But as i can see they all say kernel 4.10 are working as you have the prob also on 4.9 (LTS) i am not shure abaout ;)
    But feel free to try the GIT driver:


    From AUR

  • @joekamprad Thank you! Is switching between the two drivers only a matter of installing/removing the packages?

  • yes! installing git version will remove the repo version.

  • @joekamprad Just a little follow-up: I ended up downgrading the whole system to a point where I was sure it worked using arch archive repo. I then proceeded to update package by package, discovering, that the fault is truly with the kernel, not the other driver packages! The problem, weirdly enough, affects both the vanilla and the lts version, and it appeared between the versions 4.11.4 -> 4.11.5 and 4.9.33 -> 4.9.35 for the lts kernel.

system145 boots13 major5 blackscreen4 Posts 22Views 3348
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.