• Sounds & Notifications


    I do apologize for all the topics I have been creating.

    New DE and system so help is needed.

    I don’t know what I did to cause this because at first when it was still a fresh install it was fine. Certain notifications and sounds are simply not working now.

    Before if I emptied the trash in Dolphin it would make a nice sound.
    Before if I adjusted the volume for my sound it would make a nice sound for each change.

    Many applications like Geary for mail show notifications but no sound at all.

    Also when I do empty the trash I get this message in the top right corner - http://imgur.com/a/edLbn

    I am hoping someone can help. I’d really like all the sounds and notifications to be working.

    Another note as it could be related is that this is a laptop connected to a screen as well as a USB speaker system. So I do have USB speakers as well as the ones built into the laptop. I am trying to use the USB ones of course.

  • @noobertroon said in Sounds & Notifications:

    I do apologize for all the topics I have been creating.

    Don’t worry about it! This is what the community is here for:slight_smile:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • I know this is a kind of simple question, but have you tried clicking "Revert back to Device… when the notification pops up?

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Also, when sound was working for you, were you using the built in audio or the USB speaker system?

    Thanks!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Yes I have clicked that and nothing happens.

    The sound was working for both the laptop speakers and the USB speakers when they were working before.

    And to be clear, the sound is working, youtube, videos etc all makes sound, and even Chrome notifications are making sound. So it’s not like sound isn’t working.

  • Hve you installed anything since then?

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • There could be a program competing with it.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Yes there has been lots of things that have been installed.

    I can’t think of anything that would cause issues though.

    The only two things that are even remotely related to media related is DuckieTV and Lollipop. Both of which are not even running.

    Unless you have an idea of a program that could cause this?

  • @noobertroon said in Sounds & Notifications:

    Unless you have an idea of a program that could cause this?

    Perhaps it is an update concerning KDE? If so, it should be resolved shortly. I know things like this happened when Gnome had a big update a month ago.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Actually that is another thing about this.

    I don’t get notified about updates. I have to actually open up the Software Update App to see the updates.

    Yes within that app it is set to show an icon in the tray for any updates. There is for sure something going on with notifications but it seems all over the place, some things work, some don’t.

  • That is actually really wierd! I don’t know what to suggest then.

    I wish I could have been of more help to you:disappointed:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @noobertroon said in Sounds & Notifications:

    I don’t get notified about updates.

    Hi!
    Try to launch pamac-tray in a terminal and see if will give you some error message…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • I ran pamac-tray and no errors. It actually showed the icon in the system tray.

    I then CTRL+C to quit the terminal session and it went away :(

  • @noobertroon
    yes, then pamac-tray is not being initialized with your system. Which desktop are you using?
    You can simple add it to start with your desktop (should be happening as standard config)

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • I am using KDE and I don’t really want to just add it to the startup.

    It should be happening already, it’s kind of an important app isn’t it?

    I also think this could be related to my other notification issues (other apps not showing up and stuff). So I’d like to figure out why.

    If there are any logs or settings or anything that could cause this I would want to find it.

  • So both popups and sound notification are screwed up?
    0_1499262138724_kde-notifications-manage-nq8.png
    Do you try to reset defaults in knotify?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @noobertroon said in Sounds & Notifications:

    I am using KDE and I don’t really want to just add it to the startup.

    Ok, i understand, i thought you could be using i3-wm like me, where all the apps must be configure to autostart, and nothing comes pre-configured.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Not exactly, it is mostly sound issues. I was referring to some applications not showing up in the system tray like what was just shown for the update pamac

    I have tried clicking default in that area but mine is very different.

    I don’t have any of those menu options that are shown there.

    This is mine - http://imgur.com/a/zTb4c

  • Was hoping that last reply would have clicked with someone for an idea.

    What I have now noticed is that there are certain sound notifications and sounds that are working.

    Every website within Chromium makes sound. I also just installed Riot which to put simply is a chat program but is written in electron (my understanding, web wrapper) and it works.

    It seems web based things are working (or maybe chromium based, because Firefox does not).

  • I found the solution.

    It’s actually a bug of some sort and there is a workaround.

    See bug report here - https://www.mail-archive.com/[email protected]/msg1521177.html

    Basically the notification sounds volume settings is stuck at 0% and the main volume controller in KDE isn’t working.

    You need to open up pavucontrol to change this setting and then it’s saved.

    I was hoping this was related to my other issue with icons in the system tray but oh well. At least I have my sounds back again!

sounds1 notifications8 Posts 22Views 737
Log in to reply