• SPL/ZFS reversion to zfs-1:0.6.5.10+git0.4.11.7_1-1


    spl 1:0.6.5.10+git0.4.11.7_1-1 will not dkms build under kernel 4.11.7.
    Why the reversion from spl 0.7.0rc4.r2861.4.11.2_1-1? The latter will build!

  • Hi,

    Maybe @lots.0.logs can help with this one

  • spl builds now (6.5.10+git0.4.11.1_1-1) but the system wil not import the root pool. WIll work on it tomorrow…

    • list item
  • I’m in the same boat now, unable to boot due to the new features that were introduced by zfs 0.7.0 and now we’ve been downgraded to zfs 0.6.5.

  • Sorry about this. ZFS has become a real hassle to keep working on the default kernel because of how closely the default kernel tracks official kernel releases. To get back to a working state, try using June’s install ISO to mount your ZFS partitions. Then you can use arch-chroot command to downgrade the packages with pacman. In the meantime we’ll try and figure how best to move forward with the maintenance of the ZFS packages.

  • Thanks for the update, I’m currently trying to get a newer install iso as the one I’m having is also zfs 0.6.5 and cannot mount it read write. Also, on a different note, I really hope zfs is not beeing ditched, it was one of the reasons why I chose Antergos.

  • Ok, I was able to boot successfully after downgrading spl/zfs.
    Maybe this will help others, booting in a live full antergos(the last June iso) and running arch-chroot, i’ve done the following:

    # pacman -U linux-4.11.7-1-x86_64.pkg.tar.xz linux-headers-4.11.7-1-x86_64.pkg.tar.xz spl-0.7.0rc4.r1026.4.11.2_1-1-x86_64.pkg.tar.xz spl-utils-0.7.0rc4.r1026.4.11.2_1-1-x86_64.pkg.tar.xz zfs-0.7.0rc4.r2861.4.11.2_1-1-x86_64.pkg.tar.xz zfs-utils-0.7.0rc4.r2861.4.11.2_1-1-x86_64.pkg.tar.xz
    

    I’ve ended up with errors due to spl not beeing initially installed, and I had to manually run:

    # dkms install zfs/0.7.0rc4 -k 4.11.7-1-ARCH
    # mkinitcpio -p linux
    
  • I followed the same path as bsdwave (above) to get my system working again. There seems to be a couple of altrenatives at this point:

    1. It looks like the spl/zfs packages have been pulled from the repo, so you can use the archzfs (unofficial) repo at archzfs.com. Jesus Alvarez is the owner/maintainer & does a good job of staying current with new kernel releases, provided the zfsonlinux code cooperates. His packages are non-dkms so the changover from the Antergos repo is a bit tricky. You have to enable his repo, remove the Antergos dkms packages, install the appropriate spl, spl-utils, zfs, zfs-utils from from the archzfs repo. i had some issues, initially, with the hostid being wrong and the pool not wanting to mount. I had made a copy of the hostid file, so I copied it over the “wrong” one, did a mknitcpio -p linux and it worked. Do this at your own risk!! (and don’t blame me if it goes sideways on you!) I used this repo for a non-Antergos ZFS on Archlinux system for quite some time. Jesus also has his automated build scripts up on github - maybe those could be used for maintainance. (see https://github.com/archzfs/archzfs)
    2. SInce the there aren’t any spl/zfs packages in the Antergos repo for now, you should be able to update with no issues (but I haven’t tried that, yet). You can also edit pacman.conf to ignore the spl, spl-utils, zfs, zfs-utils packages. Both will work until the next kernel update.

    Now for the sermon/rant: One problem i see is that kernel development outpaces zfsonlinux development - zfsonlinux is always playing catch-up. ZFS (IMO) is an important technology and was (for me, at least) a major selling point for Antergos. BTRFS is supposed to be an in-kernel alternative, but (IMO, again) cumbersome and less versatile in use. It would be nice if the linux and LLNL (zfsonlinux) gurus could somehow work out the licensing issues and include ZFS in the kernel tree. It or something similar in functionality really needs to be there!

    end of rant.

  • From what I can see here: https://github.com/zfsonlinux/zfs/releases there has been a new release v0.6.5.10 of zfs(zfs on linux), while the 0.7.x were pre-releases, I assume antergos just grabs the latest release and does not follow a branch or something similar. I think this triggered the issue. Also, it’s possible that people that have not upgraded the zfs pool with the features in 0.7.x, are unaffected by this.

  • @henryz said in SPL/ZFS reversion to zfs-1:0.6.5.10+git0.4.11.7_1-1:

    It looks like the spl/zfs packages have been pulled from the repo

    I pulled the packages from our repo to avoid making any more users’ systems unable to boot normally.

    @henryz said in SPL/ZFS reversion to zfs-1:0.6.5.10+git0.4.11.7_1-1:

    One problem i see is that kernel development outpaces zfsonlinux development - zfsonlinux is always playing catch-up.

    Indeed that is the main problem as far as using ZFS on Arch is concerned.

    Personally, I think that things would go a lot more smoothly, both from a user’s perspective and from a package maintenance perspective if we were to package ZFS exclusively for the LTS kernel. I know that some people won’t want to use the LTS kernel for various reasons and thus would not be happy. I just dont see any better options at this point.

  • I agree 100% - LTS is the way to go for now. BTW - Nvidia was like this a few years back. Any out-of-tree kernel modules tend to be maintenance nightmares. Too bad some of the best technologies give the linux (GPL) gurus licensing headaches. I’ll have to see if I can convert to LTS without trashing my system or hope that Mr. Alvarez keeps the 0.70 packages going. We’ll see what happens when Arch picks up the 4.12.x kernel.

    BTW - tnx for the valiant effort from the Antergos side - no ill will intended.

  • I have not been able to repair my system the same way as bsdwave. trying to see if latest kernel update will work. but I am not hopefull. is there a chance for some ZFS update wil fix my system soon? or should i just reinstall?

  • @hhelle said in SPL/ZFS reversion to zfs-1:0.6.5.10+git0.4.11.7_1-1:

    is there a chance for some ZFS update wil fix my system soon? or should i just reinstall?

    You can try to fix it chrooting to your system with the help of Antergos ISO (it should have zfs module loaded).

    If it’s too complicated (or you don’t want to spend your time fixing it) yes, a new install should work (not using zfs, I mean).

  • @karasu
    I have chrooted and tried to fix this man ways now. As i Said bsdwaves solution didnt work for me. Neither is there q solution in arch wiki.

    Im used to chroot into my system most times a kernel updates. But i cant find info on how to disable the new function wich prevents my system from booting.

    So its not as much a question about to complicated. But more of finding nessecary information. The error i get is posten in my separate thread . Maybe the problems are related but diffrent?

  • @hhelle said in SPL/ZFS reversion to zfs-1:0.6.5.10+git0.4.11.7_1-1:

    Maybe the problems are related but different?

    I wouldn’t know without more info.

    What I would do:

    1. Boot with antergos
    2. arch-chroot
    3. rebuild spl and zfs with dkms, like this:
    dkms install -m spl -v 0.6.5
    dkms install -m zfs -v 0.6.5
    

    You must use the version you have installed in your system (pacman -Qs zfs)

    Cheers!

reversion1 splzfs1 Posts 15Views 518
Log in to reply