• [Solved] 2 fingers tap not working (Gnome) Dell XPS 13 (9360)


    Hi,

    I’m new to Antergos, but not to Linux.

    I’m facing a problem with my touchpad. Usually, I tap with 2 fingers and get like a right clic. It doesn’t work. The only way I can get a right clic by taping is with 3 fingers tap, and it’s not responding that well.

    So, I went to the Arch Wiki for the Dell XPS 13 (9360) There’s nothing about that. There’s a thing about blacklisting psmouse, but that shouldn’t be the reason of my problem.

    I went to the Arch Wiki about libinput, but I can’t seem to find how to solve my problem.

    Any help would be greatly appreciated.

    Thanks

  • This question was answered many times in the forum. For example, here and here. The solution is simple:

    • uninstall xf86-input-synaptics
    • check that xf86-input-libinput is installed
    • very important - the X session must be restarted, either by logging out and then logging back in, or by reboot.
  • A word of warning though.

    While xf86-input-libinput will offer a proper right click menu with the two finger tap, it will also have TERRIBLE scrolling effects. I did what @just suggested a month ago, and while many people like the change, I ended up reverting back to xf86-input-synaptics. To me it’s the importance of scrolling vs. the importance of a two finger tap. For me personally, scrolling is used more and thus more important:smile: .

    Who knows? Perhaps you won’t have this issue? It has been a month since I tried it, so things could have changed. I just thought it would be best to make sure you were provided you with all the information:slight_smile:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @just

    Thanks, I will try that.

    I had a similar problem on another Arch distro, with another computer, and I managed to solve the issue by editing some .conf file. I just don’t remember how…

  • @just

    It worked.

    But…

    Like @Keegan said, now the scrolling is not great.

    Also, it made libinput-gestures not work anymore. Which is not cool.

    So, I will look around for another solution. Thanks anyway. :-)

  • @ClaudeC said in 2 fingers tap not working (Gnome) Dell XPS 13 (9360):

    I will look around for another solution.

    If you find one, please let me know!

    Thanks!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan

    Well, I poke around some Arch Wiki about libinput, touchpad, ect. for a few hours. I tried a couple of things, but I haven’t found THE solution. Looks like something’s missing in the Arch kernel.

    So, maybe I’m not Arch educated enough to use Antergos. I went back to Manjaro, where I didn’t have those issues. Since they patch the Arch kernel, maybe it has something to do with it.

    I’ll have to live with updates not released as fast, but with a better working touchpad.

  • OK. Sad to see you go:disappointed:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan

    So, any updates on that since then ?

    Just hoping here…

    EDIT : I managed to make it work !!!

    You have to install GDM and remove Lightgdm. Then, remove the synaptic driver.

    sudo pacman -S gdm

    sudo systemctl disable lightdm && sudo systemctl enable gdm

    Reboot

    Uninstall Lightgdm from Pamac

    Reboot

    Uninstall the synaptic driver like said in the post that was linked above.

    uninstall xf86-input-synaptics pkg

    sudo pacman -Rcnsu xf86-input-synaptics

    check that xf86-input-libinput is installed

    pacman -Qi xf86-input-libinput

    Reboot

    After that, I could also install libinput-gestures (on Xorg)

  • Not that I know of, sorry:disappointed:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan

    Check my post above. Edited. :-)

  • Install and use GDM. (or not)

    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    #reboot
    

    Select Xorg session instead of wayland at the login screen.

    add:

    Section "InputClass"
            Identifier "touchpad catchall"
            Driver "synaptics"
            MatchIsTouchpad "on"
            
    #add these lines
    
            Option "TapButton1" "1"
            Option "TapButton2" "3"
            Option "TapButton3" "2"
    	Option      "VertScrollDelta"          "-111"
    	Option      "HorizScrollDelta"         "-111"
    

    to your /etc/X11/xorg.conf.d/50-synaptics.conf

    This also enables threefinger tap if your touchpad supports it. Genius for pasting etc…

    I dont like the feel of xf86-libinput (at all!)

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @ClaudeC said in [Solved] 2 fingers tap not working (Gnome) Dell XPS 13 (9360):

    EDIT : I managed to make it work

    Yay! Glad to hear that:grinning:. Welcome to Antergos then!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @izznogooood said in [Solved] 2 fingers tap not working (Gnome) Dell XPS 13 (9360):

    I dont like the feel of xf86-libinput (at all!)

    Same here:disappointed:. I much prefer the other…

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

Posts 14Views 557
Log in to reply