• Hyper Threading Broken


    I came across this as I now have the System76 Galago Pro.

    https://lists.debian.org/debian-devel/2017/06/msg00308.html

    Is this a concern even if you aren’t using Debian/Ubuntu. I ran the tests and my CPU would be included in the ones that have this issue.

    There is some micro-code that can be installed for ubuntu to fix this…is Antergos aware of this and is there a fix?

  • Geez. Intel is seriously fucked up.

    As far as I know intel-ucode package is available from Arch linux, there is no equivalent package in Antergos.

    See here,
    https://wiki.archlinux.org/index.php/microcode

    First, you need to install intel-ucode for Arch extra repo. Then, you need to add image to your bootloader. With grup it is as simple as grub-mkconfig -o /boot/grub/grub.cfg. See the website for others.

    I think this is a concern from debian side especially. Since they are strictly opposed to proprietary drivers. In ubuntu, it is enabled by default. At least it was when I was using ubuntu. :)

  • I’m fairly new to Linux and I have never done anything like that.

    How do I know that is the correct command that I need to use, maybe there is a better way? It seems you can update it directly in the BIOS. That sounds like it would be better to do right?

    I guess no one else here has this system or similar?

  • See here for more details:
    https://fixmynix.com/update-cpu-microcode-in-linux/

    'Hardware manufacturers stores the CPU microcode data in the BIOS or UEFI firmware, so the CPU could update microcode form the BIOS/UEFI. So when a relatively newer microcode update available, do we have to update the BIOS/UEFI firmware ?

    No, the Linux kernel could update the CPU microcode easily at the early stage of boot process, thou this type of update is volatile, i.e. lost after each shutdown. But it’s fairly more simple than updating the BIOS/UEFI.’

    In short, it is possible but I would recommend against it. For a relatively new user, updating BIOS is definitely way much harder and prone to error and the process is specific to your hardware. Also, you need to do this every BIOS update to get the latest intel microcode. Even I found myself nervous doing that.

    Honestly, system76 support forums would be a better choice, if you want to go down that route.

  • So I checked my system and “intel-ucode” was already installed.

    If it was installed already do I need to do anything else? Would that mean it’s already being updated and I don’t need to do anything else?

    Are you saying I should go to System76 about doing the BIOS or the Grub thing? The issue is that they use Ubuntu and not sure if they really support anything else.

    I guess I am not sure who I need to be asking or doing what exactly. I was hoping for real information about this. I assumed other people using these processors who are using Arch/Antergos would have resolved this already and have detailed instructions.

  • I mean for the BIOS. It is not important whether you use windows or any other linux distro. There are some tools to flash BIOS from the operating system but the best is to do that from BIOS itself. Grub is completely another story. You dont need grub to flash BIOS.

    I quote from arch linux website that I linked above. If you see something like this you are golden. Maybe Antergos took care of this already during the install. I am not sure.

    Use /usr/bin/dmesg to see if the microcode has been updated:

    $ dmesg | grep microcode
    

    On Intel systems one should see something similar to the following, indicating that microcode is updated early:

    [    0.000000] CPU0 microcode updated early to revision 0x1b, date = 2014-05-29
    [    0.221951] CPU1 microcode updated early to revision 0x1b, date = 2014-05-29
    [    0.242064] CPU2 microcode updated early to revision 0x1b, date = 2014-05-29
    [    0.262349] CPU3 microcode updated early to revision 0x1b, date = 2014-05-29
    [    0.507267] microcode: CPU0 sig=0x306a9, pf=0x2, revision=0x1b
    [    0.507272] microcode: CPU1 sig=0x306a9, pf=0x2, revision=0x1b
    [    0.507276] microcode: CPU2 sig=0x306a9, pf=0x2, revision=0x1b
    [    0.507281] microcode: CPU3 sig=0x306a9, pf=0x2, revision=0x1b
    [    0.507286] microcode: CPU4 sig=0x306a9, pf=0x2, revision=0x1b
    [    0.507292] microcode: CPU5 sig=0x306a9, pf=0x2, revision=0x1b
    [    0.507296] microcode: CPU6 sig=0x306a9, pf=0x2, revision=0x1b
    [    0.507300] microcode: CPU7 sig=0x306a9, pf=0x2, revision=0x1b
    [    0.507335] microcode: Microcode Update Driver: v2.00 <[email protected]>, Peter Oruba
    

    It is entirely possible, particularly with newer hardware, that there is no microcode update for the CPU. In that case, the output may look like this:

    [    0.292893] microcode: CPU0 sig=0x306c3, pf=0x2, revision=0x1c
    [    0.292899] microcode: CPU1 sig=0x306c3, pf=0x2, revision=0x1c
    [    0.292906] microcode: CPU2 sig=0x306c3, pf=0x2, revision=0x1c
    [    0.292912] microcode: CPU3 sig=0x306c3, pf=0x2, revision=0x1c
    [    0.292956] microcode: Microcode Update Driver: v2.00 <[email protected]>, Peter Oruba
    
  • When I run that code I get this.

    [    0.673451] microcode: sig=0x806e9, pf=0x80, revision=0x4e
    [    0.673539] microcode: Microcode Update Driver: v2.2.
    
    
  • Then, you are good and your BIOS is already up to date, at least CPU-wise.

    I did some digging and found this: https://bbs.archlinux.org/viewtopic.php?id=227711

    So, Arch linux is all good.

  • That is great to hear.

    Thank you for your awesome searching skills!

hyper2 broken17 threading1 Posts 9Views 424
Log in to reply