• How to install on MBR instead of EFI?


    I have a laptop where I want to Install Antergos, but after installing it I found that I couldn’t boot it, further investigation lead me to find that my laptop doesn’t support EFI (yes, my i7 laptop with an nvidia maxwell gpu, it does not have a UEFI, it’s got a classic BIOS, don’t ask)

    I tried to reinstall without EFI but if I did not select an EFI partition the GUI installation software wouldn’t let me install.

    Is there any way to install Antergos with grub on the MBR instead of an EFI partition? Or alternatively is there a way I could install it normally and then replace the EFI grub with a basic MBR grub? What should I do here?

  • I habitaully install Antergos and all other Linuxes on MBR disks only. I don’t have GPT partitioned disks, don’t have WindOS, don’t have EFI partition, nowhere. Most of my computers have legacy BIOS. In those with UEFI and Secure Boot I disabled both features years ago and boot in legacy mode only. I never install Grub 2. All computers are controlled by the human Grub, aka Grub Legacy now. Everything works nicely.

    So yes, installing Antergos on MBR is more than possible.

    Some tips:

    • disable bootloader installation in Cnchi
    • select advanced installation mode
    • choose all partitions you want to use in the installed system, assign mount points
    • do not select EFI partition, if it exists

    Antergos will be installed, but not visible for existing bootloader. With Grub, I simply add an entry to boot Antergos to Grub’s /boot/grub/menu.lst file. Done.

  • @just I have no pre-existing grub, and like I said earlier, if I do not select an EFI partition it will not let me proceed with the installation (e.g. if I go to advanced installation I HAVE TO select /boot/efi or it will not let me press that little next button) there is no other OS on the laptop, I’m not a huge fan of dual booting.

    I don’t know how to disable bootloader installation in Cnchi I saw no such option. There’s a “Use the device below for bootloader installation” tickbox, but unticking it has no effect on what I said before.

  • @cestarian
    but as you say cnchi automatic choose EFI, it is caused by starting LifeIso’s efiboot.
    Do you get a EFI menu on startup the ISO?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad I’m not sure if it’s an EFI menu, I get some menu. You saying I should install from the minimal ISO instead or something?

  • No the ISO has two bootup mechanisms, so it is capable to start from all different systems.
    EFI-Boot menu looks like this:
    0_1499238867120_efi-boot.png
    Grub-Bios boot like this:
    0_1499238903173_biosboot.png

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad I get the EFI one. Is there any way to force it to boot from Grub-Bios?

  • you will need to take a look into your Bios, may there is option to boot only with legacy mode

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad found a pxe oprom policy option, seems to be what I was looking for, hopefully this solves my problems, I noticed (kinda late maybe?) that there was an add boot option (for efi) in my bios settings but it didn’t seem to work. I’m gonna try installing to mbr instead hopefully it will work now.

  • Now it says that there are temporary packaging issues that would interfere with the installation. Wat? Could this error be less specific? (pacman works fine so it’s not locked)

  • Close cnchi and open from terminal like this

    sudo cnchi -f -i
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad I ended up not needing that after all, tried installing again booting the installation from mbr today and it just worked now. My system is poperational now :)

    Thanks for your help.

  • Yes seem that devs fixed this fast.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

efi6 mbr4 Posts 13Views 632
Log in to reply