• How to disable low disk space warning?


    Dear members,

    I have Antergos with Gnome 3.24 running on my computer. At startup it always shows a notification of low disk space in one of my hard drive. I know the space is low, but since it is a data drive, I actually don’t have any problem with it. But it is pretty annoying that I have to close this notification at every system startup.

    I have googled this issue and found some solutions from people running Gnome in Ubuntu. But those methods seemed not working in Arch. Could anyone give me a hint?

    Many thanks in advance!

    Best,
    Doihara

  • The easiest way is to simply disable notifications for the file manager in Gnome. To do so, open Settings and then “Notifications”. Under that, scroll down to “files” and turn the switch to “off”.

    Hope this helps!

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • if it’s a large ext4 drive you might want to reduce the reserved blocks size to get back some free space.
    by default 5% is reserved.

  • @Keegan Thank you for the hint. While disabling the notification completely would be a quick fix, I do want to keep this function intact. In some cases, like converting a large video or making a disk rip, it would be really helpful to get notified as soon as the job is finished.

    @deadite66 Yes, it is indeed a large ext4 partition. However, I have no intention to make more free space out of it and just want to keep it full. It may sound weird, but what I have here is that several hard drives get combined with mhddfs, so that they appear to be a single large drive. New files will be dynamically allocated to disks where there is free space. So I have no problem with one or some of the drives being completely full. But I do have a problem with the low disk notification, because firstly, I am fully aware of it, secondly I don‘t need or want to deal with it.

    The utility which keep giving out this notification seems to be the Disk Usage Analyzer in Gnome. I could not find any preference or setting options in this software. Maybe I just overlooked something?

  • Sorry, I do not know how to really help any further:disappointed:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan No problem, bro!While waiting for more hints from other members who might be more familiar with such kind of issue, I will also try to consult the mighty, all-encompassing internet to help myself in the meantime :D

  • @doihara said in How to disable low disk space warning?:

    I will also try to consult the mighty, all-encompassing internet

    hehehe…

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan I would like to briefly go back to your suggestion of disabling the notification. I tried it in hope of having a temporary solution. But to my surprise, even that didn’t work. I tried to either disable file notification or all popups. But in both cases the low disk notification still persists. Any suggestion?

    0_1499081583008_Screenshot from 2017-07-03 13-16-14.png

    0_1499081608040_Screenshot from 2017-07-03 13-01-14.png

  • That’s unexpected:confused:

    I have no idea. I really thought that would work!
    I wish I could have been more help to you…

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Here I would like to briefly report my temporary workaround.
    Following the suggestion by @deadite66 , I set the reserved block size of all my ext4 data drives to 0 with

    sudo tune2fs -m 0 /dev/sdxx

    According to some other users’ remarks I found after quick googling, a low block reserve (as low as 0!) would have no significant negative impact on performance, as long as the concerning drive is mainly for long-term archiving purposes, i.e. without frequent, intensive read/write operations. Please correct me if I am wrong. I have to admit that I don’t have a deep understanding about this topic,

    Moreover, mhddfs has a default emergency margin of 4GB, so that the drives will never be actually filled up. The remaining question is, however, what the exact threshold of the low disk warning is? If it is lower than 4GB, than it is all set and I am good to go! But as I implied in my earlier post, my real concern is that I could not find any configuration possibilities of a certain Disk Usage Analyzer, which I believe is responsible for issuing this warning. The graphic is no doubt pretty fancy, but without any apparent setting options, unenlightened users may have a hard time playing with it…

    0_1499084476066_Screenshot from 2017-07-03 14-20-09.png

    Currently I won’t be able to make any further test either to support or to override my assumptions though, because with the newly released space, I have to wait until they get filled up again;) But at least for the time being, the annoying low disk space warning is gone ~

  • At least it is fixed for now…

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

space4 low5 disable12 disk5 Posts 11Views 361
Log in to reply