• Mobile broadband greyed out


    Hello, I am currently staying at my grandmother’s place, however, she doesn’t have Wi-Fi but instead uses a mobile broadband dongle (Huawei E353) for her very limited networking needs. The dongle is currently connected to her very slow Windows computer, on which I am typing. With me I have my Antergos laptop on which I would like to use her mobile broadband. When I tried to run lsusb with the dongle inserted it showed up as a modem. Also, when I opened my networking menu (on XFCE) it showed up, however, it was greyed out and I was not able to click it. How do I resolve this issue?

    1. Check that modemmanager package is installed. In Arch it may be done with

      sudo pacman -Syu modemmanager
      
    2. It may be downloaded from Arch Linux Archive (ALA) using any available OS, including WindOS. This is the direct link to the most recent 64bit modemmanager package in ALA. This one is 32bit version.

    3. Install downloaded pkg with

      sudo pacman -U /path/to/package
      

      For example

      sudo pacman -U /1st/dnl/modemmanager-1.6.8-1-x86_64.pkg.tar.xz
      
    4. Enable ModemManager service

      sudo systemctl enable ModemManager
      
    5. To start the service either reboot or start it by hand without reboot

      sudo systemctl start ModemManager
      
    6. For mobile broadband to work, the ModemManager service must be:

      • loaded
      • enabled
      • active
      • running

      For example

       ┌──[just]@[alexarg]:~$
       └─> systemctl status ModemManager
       ● ModemManager.service - Modem Manager
          Loaded: loaded (/usr/lib/systemd/system/ModemManager.service; enabled; vendor
          Active: active (running) since Sat 2017-07-01 11:57:11 MSK; 1h 14min ago
        Main PID: 473 (ModemManager)
           Tasks: 3 (limit: 4915)
          CGroup: /system.slice/ModemManager.service
                  └─473 /usr/bin/ModemManager
      
       ┌──[just]@[alexarg]:~$
       └─>
      
  • @just Yes, I did all that, but it is still greyed out :/.

    Here’s my log:

    * ModemManager.service - Modem Manager
        Loaded: loaded (/usr/lib/systemd/system/ModemManager.service; enabled; vendor preset: disabled)
        Active: active (running) since Sat 2017-07-01 10:36:57 EEST; 3h 3min ago
    Main PID: 298 (ModemManager)
        CGroup: /system.slice/ModemManager.service
                `-298 /usr/bin/ModemManager
    

    Also, I got some warnings:

    <warn>    (ttyUSB2): port attributes not fully set (got that one twice)
    <warn>    Could not set default storage:    'Cannot set default storage when current mem1 storage is unknown'
    
broadband3 greyed2 mobile3 Posts 3Views 143
Log in to reply