• Geary Password - KDE


    Hey,

    I have gotten a new system and have gone with KDE.

    I still prefer Geary for email but am now having an issue with passwords. Everytime I close it or reboot the machine it’s asking me for my password, once I enter it I then need to enter a keyring password.

    How do I disable the keyring for Geary and also why does it keep asking for my email password. It did not ask me when I was running Cinnamon. It should ask me once during setup and remember it for good?

  • Cinnamon is using gnome keyring, KDE has KDE Wallet for it.
    May you need to use gnome-keyring to get this working or take a look into k-wallet

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • That is the issue.

    It asks for the keyring, I create one…and it still does not remember my password.

    I also can’t seem to find the actual keyring application to edit it or anything. It’s installed though.

  • Geary is GTK and used the gnome-keyring.

    I have the kwallet installed by default but does not work with Geary.

    Again it is keyring, it just does not seem to be remembering the actual password

  • i do a little search and i can see geary directly depending on gnome-keyring… so may not calling to kwallet…
    So what you need is maybe seahorse installed to get a tool to handle the key for geary.

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • So that kind of works.

    Seahorse allows me to unlock the keyring which in term makes Geary work normal when I open it.

    The issue is after a reboot or anything like that I would have to manually open Seahorse and unlock the keyring. Which isn’t what I want. I simply don’t want the stupid keyring, and geary to just remember the password for my email.

  • you can set login password to empty, then it do not ask (inside seashorse)

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Thanks, that worked.

    I also now remember I had a previous post about this and Chrome. I forgot about that, or thought it worked differently but I guess not.

    Changed it to blank and all is well. Thanks dude

kde171 password28 geary2 Posts 9Views 1207
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.