• Pacman invalid or corrupted packages


    Hi, whenever I try to upgrade/update my packages now pacman fails. Here’s the end of the output where pacman fails.

    (310/310) checking keys in keyring                                                [##############################################] 100%
    (310/310) checking package integrity                                              [##############################################] 100%
    error: antergos-keyring: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is unknown trust
    :: File /var/cache/pacman/pkg/antergos-keyring-20170524-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: antergos-alerts: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is unknown trust
    :: File /var/cache/pacman/pkg/antergos-alerts-17.6.25-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: antergos-mirrorlist: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is unknown trust
    :: File /var/cache/pacman/pkg/antergos-mirrorlist-20170527-2-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: pamac: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is unknown trust
    :: File /var/cache/pacman/pkg/pamac-4.3.7-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: pepper-flash: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is unknown trust
    :: File /var/cache/pacman/pkg/pepper-flash-1:26.0.0.131-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: qt5-styleplugins: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is unknown trust
    :: File /var/cache/pacman/pkg/qt5-styleplugins-5.0.0.1r36-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: failed to commit transaction (invalid or corrupted package)
    Errors occurred, no packages were upgraded.
    

    A couple things I’ve tried to do is deleting all the files in /var/cache/pacman/pkg/ directory and in /var/lib/pacman/sync/ then subsequently running pacman -Sy and pacman -Syu respectively to no avail.

    Is there anyway this can be fixed?

  • @wurmy
    hi friend!
    Open a terminal and try the commands below:

    sudo pacman-key --init
    sudo pacman-key --populate archlinux antergos
    sudo pacman-key --refresh-keys
    sudo pacman -Syyu

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto Hello, thanks for the response.

    I ran the commands you posted and everything seemed to go smooth and upgrade, the final test however is to see if the system reboots properly haha. I’ll edit this post once I reboot.

    Edit: It reboots fine, everything is working great still and the packages and system are all updated now. Thanks very much, you saved me from having to reinstall.

    Sorry for posting an almost duplicate thread by the way, I see someone already posted a thread nearly exactly like this.

  • @wurmy
    You’re welcome, i’m glad you managed to fix evrything!

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @wurmy said in Pacman invalid or corrupted packages:

    …Edit: It reboots fine, everything is working great still and the packages and system are all updated now…

    Would you mind to mark the topic as Solved then?

    0_1498666595360_antergos-unsolved2solved.png

invalid10 corrupted7 pacman80 Posts 5Views 920
Log in to reply