• Gigabyte 970A-D3P slow internet connection


    Hello,
    I just installed a new motherboard after my old one broke, which this new gigabyte motherboard uses the same ethernet driver as my old mobo (r8168). For some reason my internet connection is 1/4 the speed it should be. I have tried to find a solution online but the problem is that the solutions require me to have Gigabyte’s windows only tools/drivers installed. Does anyone have an idea on how to fix this issue?
    Thanks,
    Darthgravis

  • enable IOMMU in the original BIOS may solve some problems on this board.#
    for more help w need some more specs:

    lspci > specs.txt && echo ----- >> specs.txt && lsusb >> specs.txt && echo ----- >> specs.txt && journalctl -b -1 >> specs.txt && cat specs.txt | curl -F [email protected] https://ptpb.pw/
    

    and give the link it produces

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad

    I already have IOMMU enabled in the bios, and in my grub file I have it set to “iommu=soft” since that’s what makes usb 3.0 work.

    Also here’s the link that command produced: https://ptpb.pw/XtXA

  • you can try this:

    https://aur.archlinux.org/packages/r8168-dkms/
    https://archlinuxhacks.wordpress.com/2012/05/02/realtek-r8169-odyssey/

    Or first if do not need it disable IPV6 .

    Jun 27 13:27:45 AMD kernel: IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
    Jun 27 13:27:45 AMD kernel: r8169 0000:03:00.0 enp3s0: link down
    Jun 27 13:27:45 AMD kernel: r8169 0000:03:00.0 enp3s0: link down
    Jun 27 13:27:45 AMD kernel: IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad

    So I installed r8168-dkms and disabled r8169 even though I have done it before since my old motherboard had the same issue just to make sure. After restarting I had no internet connection so I had to download the r8168 package on another pc and then reinstalled it and then restarted. The connection is back now but still slower than it should be. I disabled IPV6 and the speed is still the same.

  • @Darthgravis

    yaourt r8168
    echo "blacklist r8169" > /etc/modprobe.d/r8169_blacklist.conf
    

    is what you try?

    i just see that there is also community/r8168 package…

    But if you want to have no problems with speed i would promise it would be the best to get another card and disable this one complete…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    I installed it through the community package, and yes that’s what I tried. Well that sucks that I’m going to need to get an ethernet card. Thanks for the help.

970a-d3p1 slow16 internet18 gigabyte1 Posts 7Views 287
Log in to reply