• Qt font rendering issue

    Hi, I have recently installed Antergos with XFCE. en_US.UTF_8 is the locale.

    Qt applications are not rendering the font correctly. I don’t even know what they are displaying. When I copy this unreadable text and paste it in a text editor, it pastes proper English term!! Why is it not rendering properly?
    Has anyone faced similar problem?

    I tried to change the locale to fr_FR UTF_8. The issue exists in French also.

    alt text

    Screenshot - http://i.imgur.com/jIM7DcK.png

    Thank you

  • Have you ever installed any other DE than XFCE on Antergos?

    I know I ran into a similar problem once after installing Deepin DE along with the Gnome setup that I had chosen during installation in Cnchi.

    Hope this helps😀.

  • I have not tried installing anything other than XFCE.

    Thank you for your inputs.

  • I’m sorry, but I think I may be out of ideas then😞

    I have never actually used XFCE myself and have never come across this problem in Gnome, the DE I use. Thus, I just don’t know enough to be able to help you.

    I wish I could help more, but maybe someone more knowledgeable than myself will come along and help you, such as @joekamprad.

  • Looks not like related to language looks more that the wrong font is choosen…
    You can also run applications with the prefix:

    LANG=C qt5ct

    to run in C language

    also may remove



  • @joekamprad Thank you very much. It worked!

    I removed


    In terminal, I ran,

    LANG=C qt5ct

    Now everything is working fine.

    Thanks a lot for help.

  • great!
    You are welcome!

  • Glad it’s working for you!

font36 rendering6 Posts 8Views 1446
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.