• pacman -Syu all antergos packages marginal trust - error


    Hello fellow antergos users. I have the following problem. I can’t udpate my system because everytime it tries to update any antergos package I get an error like this:

    Fehler: cinnamon-session: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is marginal trust
    :: Datei /var/cache/pacman/pkg/cinnamon-session-3.4.1-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
    Soll die Datei entfernt werden? [J/n] n
    

    and it asks me if I want to delete it. I have tried refreshing the keys which has helped another time I had a similar problem but this time with no reward. Reinstalling antergos-keys is not possible either, only if I change SigLevel to Never in /etc/pacman.conf but it doesn’t solve the problem.

    EDIT: by @joekamprad @developers !!!

  • Schon wieder ?

    It is now second post with this issue again…

    https://antergos.com/wiki/system-admin/package-management/update-error-involving-keyrings/

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Hab diese Seite gesehen. Hat aber leider nichts genützt.

  • wget http://mirrors.antergos.com/antergos/x86_64/antergos-keyring-20170524-1-any.pkg.tar.xz
    pacman -U antergos-keyring-20170524-1-any.pkg.tar.xz
    sudo pacman -Scc
    sudo pacman-key --refresh-keys
    sudo pacman -Syu
    

    you can also say not to delete the file and do :

    $ sudo pacman -U /var/cache/pacman/pkg/cinnamon-session-3.4.1-1-x86_64.pkg.tar.xz
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • still the same errors. So do you mean I should download all packages from antergos that need an update and install them this way?

    Edit: I installed them all manually. I hope it won’t happen again, if so I’ll just write it in here.

  • oh i think it was only one package ;)

    what gives you:

    sudo pacman-key -l antergos
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • pub   rsa2048 2014-05-09 [SC] [verfällt: 2019-05-10]
          D95436A2E18DA94A72B1A5E2AEA529BF122902E5
    uid        [vollständig] Dustin Falgout (Antergos Developer) <[email protected]>
    uid        [ unbekannt ] [jpeg image of size 3969]
    
    pub   rsa4096 2014-08-04 [SC] [verfällt: 2019-05-10]
          24B445614FAC071891EDCE49CDBD406AA1AA7A1D
    uid        [  marginal ] Antergos Build Server (Automated Package Build System) <[email protected]>
    
    
  • @Tigatoo

    pub   rsa2048 2014-05-09 [SC] [verfällt: 2019-05-10]
          D95436A2E18DA94A72B1A5E2AEA529BF122902E5
    uid        [vollständig] Dustin Falgout (Antergos Developer) <[email protected]>
    uid        [vollständig] [jpeg image of size 3969]
    
    pub   rsa4096 2014-08-04 [SC] [verfällt: 2019-05-10]
          24B445614FAC071891EDCE49CDBD406AA1AA7A1D
    uid        [vollständig] Antergos Build Server (Automated Package Build System) <[email protected]>
    
    

    is mine…

    $ sudo rm -R /etc/pacman.d/gnupg
    $ sudo pacman-key --init
    $ sudo pacman-key --populate archlinux antergos
    

    should solve this

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • I’ve done this, but for the moment I don’t have any packages left to try if it works because I have installed them manually. The next time there are antergos package updates I’ll write if it works. Thx for helping ;)

  • @joekamprad said in pacman -Syu all antergos packages marginal trust - error:

    sudo pacman-key -l antergos

    you can check again with:

    sudo pacman-key -l antergos
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad

    Thanks Joe! Refreshing the keys after purging /var/cache/pacman/pkg/ gave me no love.

    Executing as you recommended

    $ sudo rm -R /etc/pacman.d/gnupg
    $ sudo pacman-key --init
    $ sudo pacman-key --populate archlinux antergos
    
    

    fixed the corrupted package/PNP error and I’m now able to update.

  • So… is this “Solved” or not?

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Today upgrading my system worked fine. Thank you very much @joekamprad ;)

  • Yay!!!
    :grinning:

    Keep trying, never give up. In the end, you will find that it was all worth it

    Community ISO: https://antergoscommunityeditions.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • No luck here, after the same problem i did:

    sudo rm -R /etc/pacman.d/gnupg
    sudo pacman-key --init
    sudo pacman-key --populate archlinux antergos
    
    

    But still not possible to update.
    When i command (already tried two times) this:

    sudo pacman-key -l antergos
    

    i get still this:

    pub   rsa2048 2014-05-09 [SC] [verfällt: 2019-05-23]
          D95436A2E18DA94A72B1A5E2AEA529BF122902E5
    uid        [vollständig] Dustin Falgout (Antergos Developer) <[email protected]>
    uid        [ unbekannt ] [jpeg image of size 3969]
    
    pub   rsa4096 2014-08-04 [SC] [verfällt: 2019-05-23]
          24B445614FAC071891EDCE49CDBD406AA1AA7A1D
    uid        [  marginal ] Antergos Build Server (Automated Package Build System) <adm[email protected]>
    

    Any help?

  • @bartatantergos said in pacman -Syu all antergos packages marginal trust - error:

    uid [ marginal ]

    edit /etc/pacman.d/gnupg/gpg.conf and change the keyserver line to:

    keyserver hkp://pgp.mit.edu:11371
    

    If this does not help either, change the keyserver to the kjsl keyserver, which provides this service through port 80 (the HTTP port), which should always remain unblocked:

    keyserver hkp://keyserver.kjsl.com:80
    

    If you have IPv6 disabled, gpg will fail when it found some IPv6 address. In this case try with an IPv4-only keyserver like:

    keyserver hkp://ipv4.pool.sks-keyservers.net:11371
    
    $ sudo pacman-key --populate antergos
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad This worked for me too. Thanks Joe

syu7 trust4 marginal2 pacman80 Posts 17Views 2610
Log in to reply