• error: failed to prepare transaction (could not satisfy dependencies)


    Hello!
    Since perl have been updated I cant update whole system by “sudo pacman -Syu”.
    It tells me:

    [[email protected] ~]$ sudo pacman -Syu
    :: Synchronising package databases...
     antergos is up to date
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
     DEB_Arch_Extra                                                                                      1952.0   B  0.00B/s 00:00 [#############################################################################] 100%
     DEB_Arch_Extra.sig                                                                                   280.0   B  0.00B/s 00:00 [#############################################################################] 100%
    :: Starting full system upgrade...
    resolving dependencies...
    looking for conflicting packages...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: gnome-perl: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
    :: gnome-vfs-perl: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
    :: gnomecanvas-perl: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
    :: perl-gnome2-wnck: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
    :: perl-goo-canvas: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
    :: perl-gtk2-imageview: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
    :: perl-gtk2-unique: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
    

    I can update any other package but only by hand, using pacman to update just it.
    So how can I break dependency of perl versions?

  • Perhaps Shutter is installed? I know that this can cause your problem to occur.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • @Keegan
    Yes! Thank you!
    That was it!

    All those problem packages was needed only by Shutter.
    Removing solved the problem!

  • Thanks! Glad I could help🙂.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

error261 transaction8 satisfy4 prepare4 Posts 4Views 681
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.