• The long dark won't start


    Hey every game works fine on mys system besides the long dark … it starts and it’s names appears among the tabs but it wont get further then that ?

    Any solutions for this ?

  • hi.
    So we don’t really have a whole lot of information to go by.
    You don’t mention anything about how it does not go any further.
    What do you mean?
    It crashes?

    So what are the graphic considerations for this game?
    One of the 1st things to consider if you’ve got all the necessary requirements.
    have a look at the Stream requirements page first :)

    Let us know.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc I have all the requirements and have run higher requirement games in the past.

    Also there are no errors or graphical things to go by , it just is a window with nothing in it , I reinstalled the game and downloaded it from somewhere else to see if that changes anything which is not the case :/ , is there any way to give more info about the problem ?

  • hey @lukadominiek :)
    so you might want to check journalctl. perhaps try filtering it with grep
    so I don’t know if your game is a steam game or not but if you look at journalctl | grep steam and see what is there.
    It’s just a guess, though.
    There are probably alternate ways, though.
    but you can also check /var/log
    can also try to see if anything is in journalctl --since=today

    have you looked at the arch wiki?
    it’s got to be one of the first places you would want to have a look at:
    https://wiki.archlinux.org/index.php/Steam/Game-specific_troubleshooting
    https://wiki.archlinux.org/index.php/Steam/Troubleshooting

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • journalctl | grep steam does not say anything about the logn dark :/
    The game is from steam http://store.steampowered.com/app/305620/The_Long_Dark/http://store.steampowered.com/app/305620/The_Long_Dark/

    The arch wiki has nothing about it … what do I do now ?

  • Hey. :)
    So I take it that you read through the Steam troubleshooting part of the wiki, most especially where it states that a game can crash and the possible considerations for it.
    I can’t test this for you of course.
    Only you can so I"m assuming you’ve done that.

    What is your file partition?

    Run steam from a terminal.
    Select to play your game and paste me the output on a pastebin.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hello there.

    I’m not sure if this is still relevant to you, but maybe because other could be interested, here some thoughts. As you seem to be pretty new to linux, I will do it a bit more detailed:

    If you installed Steam along with Antergos (ticked the field in the installer) you will have two versions:

    1. Steam (Native)
    2. Steam (Runtime)
      The first will use your (usually more recent) system libraries, but can’t guarantee that everything will work. If a game doesn’t work, you should defenitely try using Steam (Runtime), as it provides all necessary libraries in a specific version the developers tested the games with. In most cases this solves issues like yours for me.

    If that won’t work, go to the game directory (usually in /home/YourUsername/.steam/steamapps/common/GameName (you will only see the .steam folder if you show hidden folders). Than right click -> Open Terminal here -> Type "./GameExecutable
    Than you will see if any problem occurs.

  • This is a known issue with Unity - Unity technically only supports Ubuntu, in a recent release they broke the reference to some SDL libs. You can either remap them manually or just run the 32bit bin.

    OR edit the steam Launcher settings

    LD_PRELOAD=~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0 %command% -screen-fullscreen 1 -screen-width 2560 -screen-height 1440

    (dont forget to change the screen resolution )

    Also there is another problem with the mouse disappearing in the game ,so you just have to go to control options and set lock mouse to the screen —> UNLOCKED
    (it helps a lot if you press the (window icon in your keyboard ) so you can see where is your mouse pointer)

    After all these you will be good to go :)

dark4 Posts 8Views 834
Log in to reply