• BIOS Settings resetted [Lenovo Laptop]


    Hey guys!

    I recently moved from Ubuntu to Antergos.
    In the beginning I had a Dual Boot System with Antergos next to Ubuntu.

    But there’s the issue that after I booted Antergos, that on the next boot my Laptop (Thinkpad Yoga 20CD) welcomes me with the message “Configuration changed - restart system” and restarts, but then boots without such a notification.
    While doing so, my BIOS settings are discarded (e.g. Keyboard settings).

    What works is the following:
    I boot into BIOS, set the values as I want. Then save and boot into Antergos.
    Here my settings are present.
    Now when I shutdown or restart, the named message occures and the settings are reverted.

    BUT:
    When I boot and shutdown Ubuntu everything works fine and the settings are kept.

    I now freshly installed Antergos deleting the Ubuntu installation.
    But the Problem still persists.

    Hope someone has any idea.

  • @MarcelMu strange behavoir… resetting Bios settings looks n first like a weak Bios battery.
    But as you say that it do not reset on other OS…

    could you give us a log:

    journalctl -b | curl -F [email protected] https://ptpb.pw/
    
  • Yes sorry. I wanted to upload the Zip, but the Forum says I don’t have the privilege.

    Here you go: https://ptpb.pw/m5VL

    I think that I will nevertheless change the battery. It can’t hurt I guess.

  • Jun 25 10:13:27 thinkpad kernel: NX (Execute Disable) protection: active
    Jun 25 10:13:27 thinkpad kernel: efi: EFI v2.31 by Lenovo
    Jun 25 10:13:27 thinkpad kernel: efi:  ACPI=0xdcffe000  ACPI 2.0=0xdcffe014  SMBIOS=0xdce7e000 
    Jun 25 10:13:27 thinkpad kernel: efi: [Firmware Bug]: Invalid EFI memory map entries:
    Jun 25 10:13:27 thinkpad kernel: efi: mem46: [Reserved           |   |  |  |  |  |  |  |   |  |  |  |  ] range=[0x0000000000000000-0x0000000000000000] (invalid)
    Jun 25 10:13:27 thinkpad kernel: efi: mem47: [Reserved           |   |  |  |  |  |  |  |   |  |  |  |  ] range=[0x0000000000000000-0x0000000000000000] (invalid)
    Jun 25 10:13:27 thinkpad kernel: efi: mem48: [Reserved           |   |  |  |  |  |  |  |   |  |  |  |  ] range=[0x0000000000000000-0x0000000000000000] (invalid)
    Jun 25 10:13:27 thinkpad kernel: efi: mem49: [Reserved           |   |  |  |  |  |  |  |   |  |  |  |  ] range=[0x0000000000000000-0x0000000000000000] (invalid)
    Jun 25 10:13:27 thinkpad kernel: efi: mem50: [Reserved           |   |  |  |  |  |  |  |   |  |  |  |  ] range=[0x0000000000000000-0x0000000000000000] (invalid)
    Jun 25 10:13:27 thinkpad kernel: efi: mem51: [Reserved           |   |  |  |  |  |  |  |   |  |  |  |  ] range=[0x0000000000000000-0x0000000000000000] (invalid)
    Jun 25 10:13:27 thinkpad kernel: efi: Removing 6 invalid memory map entries.
    

    This looks a bit dangerous to me but maybe only because i do not understand it now…

  • I tried reinstalling Antergos using different Settings, formatting and repartitioning the drive.
    Still always the same issue.

    Seems like I have to switch back to Ubuntu or something again :-(

  • i find that there is a Bios Update from mai: Version 1.32 from 2017/05/15

  • Yes I know. It’s already installed.

  • @MarcelMu said in BIOS Settings resetted [Lenovo Laptop]:

    Seems like I have to switch back to Ubuntu or something again

    If that is the case, why not look into Manjaro? It is also Arch based, so you will still get a rolling release distro with the AUR.

  • @MarcelMu said in BIOS Settings resetted [Lenovo Laptop]:

    Thinkpad Yoga 20CD

    First before leaving Antergos, try to install and startup with LTS Kernel, as Ubuntu using older Kernel may this is caused by the Kernel only.

    $ sudo pacman -S linux-lts linux-lts-headers
    $ sudo grub-mkconfig -o /boot/grub/grub.cfg
    
  • Unfortunately this didn’t change anything regarding this issue.

  • So now I installed Manjaro.
    With that the problem does not occure anymore.

    So it must be a n Issue with Antergos :-(

  • @MarcelMu said in BIOS Settings resetted [Lenovo Laptop]:

    So it must be a n Issue with Antergos

    Possibly. However, I think it may actually be a problem with Arch instead because Antergos is basically just an Arch installer. However, Manjaro tweaks Arch a bit more, and that is probably why you aren’t experiencing the same issue there. Issues still plague Manjaro, but they are often different ones than the ones that plague Arch, and therefore Antergos.

  • thats odd ;(
    As i can not find any other failure like this related to Arch/Antergos, i would bet on a kernel related BUG.
    But also simple some wrong startup configuration.

    acpi_enforce_resources=lax
    

    added to the kernel paramater on bootup may solve this too.

  • YES!!!

    NOW IT WORKS!

    Thank you so much!

  • YOU"RE SAVED!!!

    Glad to see you back at Antergos!

    Welcome back😀,
    @Keegan

  • If you have tiime, it would be nice to have this information in the Wiki somewhere. It could really save someone else!

  • acpi_enforce_resources=lax is for buggy acpi drivers and mostly to get sensors working.

    but if this works here i can do some research to find out what it fixes…

    may a new log can give a hint:

    journalctl -b | curl -F [email protected] https://ptpb.pw/
    
  • This would of course be even better!

    https://ptpb.pw/4TC-

  • @joekamprad said in BIOS Settings resetted [Lenovo Laptop]:

    Jun 25 10:13:27 thinkpad kernel: NX (Execute Disable) protection: active
    Jun 25 10:13:27 thinkpad kernel: efi: EFI v2.31 by Lenovo
    Jun 25 10:13:27 thinkpad kernel: efi:  ACPI=0xdcffe000  ACPI 2.0=0xdcffe014  SMBIOS=0xdce7e000 
    Jun 25 10:13:27 thinkpad kernel: efi: [Firmware Bug]: Invalid EFI memory map entries:
    Jun 25 10:13:27 thinkpad kernel: efi: mem46: [Reserved           |   |  |  |  |  |  |  |   |  |  |  |  ] range=[0x0000000000000000-0x0000000000000000] (invalid)
    Jun 25 10:13:27 thinkpad kernel: efi: mem47: [Reserved           |   |  |  |  |  |  |  |   |  |  |  |  ] range=[0x0000000000000000-0x0000000000000000] (invalid)
    Jun 25 10:13:27 thinkpad kernel: efi: mem48: [Reserved           |   |  |  |  |  |  |  |   |  |  |  |  ] range=[0x0000000000000000-0x0000000000000000] (invalid)
    Jun 25 10:13:27 thinkpad kernel: efi: mem49: [Reserved           |   |  |  |  |  |  |  |   |  |  |  |  ] range=[0x0000000000000000-0x0000000000000000] (invalid)
    Jun 25 10:13:27 thinkpad kernel: efi: mem50: [Reserved           |   |  |  |  |  |  |  |   |  |  |  |  ] range=[0x0000000000000000-0x0000000000000000] (invalid)
    Jun 25 10:13:27 thinkpad kernel: efi: mem51: [Reserved           |   |  |  |  |  |  |  |   |  |  |  |  ] range=[0x0000000000000000-0x0000000000000000] (invalid)
    Jun 25 10:13:27 thinkpad kernel: efi: Removing 6 invalid memory map entries.
    

    This messages do not show up at all on your boot with acpi_enforce_resources=lax

    So seems to be related to what the problem causes…

bios19 [lenovo1 laptop]1 resetted1 Posts 19Views 2901
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.