• Unable to log in with default kernel, black screen issues.


    Hi. After a clean install where I choose XFCE as my desktop environment I was only able to log in using the LTS kernel. When I tried with the “normal” kernel I just got a black screen, no blinking cursor or nothing. I was able to get in to command line using CTRL+ALT+F3 but didn’t know what to do from there so I just decided to use the LTS kernel. I tried searching the forums but all posts seem to regard the Nvidia cards and I’m on integrated Intel graphics so I gave up until I stumbled uppon a post that seem to describe almost identical symptoms that I was having. The fix, or maybe we call it a workaround ,was simply to remove the lightdm packages and replace them with the gdm packages, now I could finally enjoy my new Antergos to the fullest! So, here we go: You can do this from the LTS kernel if you are able to log in there, like I did.
    1- sudo pacman -Rcns lightdm
    2- sudo pacman -S gdm
    3- sudo systemctl -f enable gdm
    Thats it folks, hope this will help someone, maybe the @developers could build a fix in to the official ISO if they could find the time. I don’t know what the actual problem was, I just found a fix on a different forum somewhere on the great interweb.

    Peace, Love and Penguins.

  • Nice! I really like your easy-to-understand, detailed instructions @catsndogs.

    Perhaps you could consider copy and pasting this onto the Wiki? I’m sure there are other people out there who would benefit from it🙂.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • @Keegan thank you, will do after work. Have a nice day!

    Peace, Love and Penguins.

  • @catsndogs said in Unable to log in with default kernel, black screen issues.:

    Have a nice day!

    Thanks! You too.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • @catsndogs would be interesting what the hardware specs are on the machine:

    lspci | curl -F [email protected] https://ptpb.pw/
    

    Also i remember last 2 kernel updates comes one on the other, so looks like some failure was correctet…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad what an useful command! Output: https://ptpb.pw/cWlr
    thanx

    Peace, Love and Penguins.

  • @catsndogs do you have knowledge about that maybe a nvidia card is disabled inside BIOS?
    The output looks like an Notebook with hybrid Graphics to me but lspci only give intel integrated …

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad OMG, I think / hope you might be right my friend. This is like getting a 1GB dedicated graphics card in present from you! But I’m not really sure, my laptop, a HP EliteBook 840 G1 (A3009DD10303) is delivered in a bunch of configurations, I have the 1600x900 non-touch version. (sold in Norway, we are not in the EU, but we often get the EU product lines) I will investigate further later this day. The box came pre-installed with Windows 10, which I had to get rid of with the help of garlic, holy water and a GParted live ISO. Only problem now is that I can’t get in to my BIOS (don’t have password), the PC was acquired used from a friend, so now I must find a way to unlock it, I doubt my friend remember the PW, but I will ask him of course. I keep you updated! Thank you for helping!

    Peace, Love and Penguins.

  • @catsndogs said in Unable to log in with default kernel, black screen issues.:

    HP EliteBook 840 G1

    Bios-password reset is hard for HP Books 😉
    You will need to ask HP-Support for a smi file to do so… better to get the password from your friend.

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Looks like there wasn’t a second graphics card on my laptop. Bummer. Only integrated Intel for me, thanks though.

    Peace, Love and Penguins.

  • @Keegan @neoes1um Pasted 2 Wiki, thanks everybody.

    Peace, Love and Penguins.

  • @catsndogs said in Unable to log in with default kernel, black screen issues.:

    Pasted 2 Wiki

    Yay !!!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

installation256 lightdm119 kernel106 black screen10 Posts 12Views 1325
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.