• Apache error 403


    hi,
    i installed apache, want changed the DocmentRoot of apache in my home file, so i changed the DocumentRoot in my httpd.conf but i am an error 403.
    my file httpd.conf :

    DocumentRoot “/home/thibaut/Public”
    <Directory “/home/thibaut/Public”>

    else i see in the doc Apache that it was necessary to a chmod but i don’t no where to use it

  • what for you choose to open a directory under your personal home to public Server?

    From Arch-Wiki:

    DocumentRoot "/srv/http"
    

    This is the directory where you should put your web pages.
    Change it, if you want to, but do not forget to also change

    <Directory "/srv/http">
    

    to whatever you changed your DocumentRoot to, or you will likely get a 403 Error (lack of privileges) when you try to access the new document root.
    Do not forget to change the Require all denied line to Require all granted, otherwise you will get a 403 Error. Remember that the DocumentRoot directory and its parent folders must allow execution permission to others :::
    can be set with:

    chmod o+x /path/to/DocumentRoot
    

    otherwise you will get a 403 Error.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • in my personnal home.
    I did all his but It still does not work
    My file where i want my document root is /home/thibaut/Public

    But here is my file httpd.conf:

    DocumentRoot "/home/thibaut/Public"
    #<Directory "/srv/http">
    #   Options Indexes FollowSymLinks
    #   AllowOverride All
    #    Require all granted
    #</Directory>
    <Directory /home/thibaut/Public>
    	Options FollowSymLinks
    	AllowOverride None
    	Require all granted
    </Directory>
    #
    # DirectoryIndex: sets the file that Apache will serve if a directory
    # is requested.
    #
    <IfModule dir_module>
        DirectoryIndex index.html
    </IfModule>
    
    #
    # The following lines prevent .htaccess and .htpasswd files from being 
    # viewed by Web clients. 
    #
    <Files ".ht*">
        Require all denied
    </Files>
    SSLRandomSeed connect builtin
    </IfModule>
    

    and the chmod :

    $ sudo chmod g+xr-w /home/thibaut
    $ sudo chmod -R g+xr-w /home/thibaut/Public
    
  • So what do you want to do?
    A full featured Internet side for public internet? Or what else?
    They are mostly more simple solutions then apache.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • just changed my location of localhost move /srv/htpp to /home/thibaut/Public
    and don’t have the error 403 and i don’t understant because i follow the doc of apache

  • solved by this:
    <Directory “/home/domain/www”>
    Options Indexes FollowSymLinks ExecCGI
    AllowOverride AuthConfig FileInfo
    Order allow,deny
    Allow from all
    </Directory>

  • Hey, Did you tried to access the same page from some other pc or laptop? If the problem persists then it may be beacuse the webiste owner has restricted you from access that page. Well there’s a simple soln. to it…Install gom vpn extension from http://www.hackbs.com/gom-vpn-free-tricks-to-bypass-cyberoam-2015/

apache2 error170 4032 Posts 7Views 168
Log in to reply