• Language is arabic in qt applications?


    I installed Antergos with GNOME3 a week ago and so far, everything worked flawlessly. Before, I used Ubuntu for quite a long time (>5jrs).

    My system language is German, and in all applications so far, this was also respected. But now I installed Okular (a KDE app using Qt5 I suppose?) and it will only be displayed in some Arabic language:
    Screenshot
    I also tried to open some other qt application (in the screenshot the configuration tool of qt5) and experienced the same behavior. In contrast, all other applications using GNOME3 work as expected.

    I tried to switch the system language to English but nothing happened. I also tried everything mentioned in https://wiki.archlinux.org/index.php/Locale with no effect. Starting Okular via the terminal with setting environment variables like LANG=de okular also had no effect (I tried LANG, LANGUAGE and LANG_ALL).

    Any ideas how to fix this are highly appreciated.

  • That s really weird! I would start with:
    @fr34q said i

    But now I installed Okular

    How did you install it?
    I would also be curious to see, if I completely removed it
    sudo pacman -Rnsc okular
    and then re-installed it
    sudo pacman -S okular
    would bring it in the same odd language? (I doubt it is arabic, by the way)

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I just reinstalled it like you suggested, but still the same behavior. I also doubt that it is related to okular because other apps using Qt5 show the same strange symbols:
    Screenshot

    Qt4 apps seem to work normally btw…

    And another strange thing, if I try to make an annotation in the pdf with okular, this happens (one symbol for every character I typed):
    Screenshot
    That made me thinking that it might not be a problem with a wrong language translation but with a corrupt font that qt5 uses?

    Unfortunately, I have no idea how to verify this hypothesis…

    Thanks for your help!

    Edit:
    Whoa, I just looked through my fonts and it looked like “Aakar” font (Hindi I think?) so I tried

    sudo pacman -Rnsc ttf-devanagarifonts
    

    and now I can read it again:
    Screenhot
    But the font size seems a bit unnatural large and I am not sure why removing the used font fixed the issue anyway…

    It just seemed to use the first font (in alphabetical order) it found?

  • @fr34q said

    But the font size seems a bit unnatural large and I am not sure why removing the used font fixed the issue anyway…

    You can never be sure how Qt apps will behave under a GTK environment (or vice versa).
    I have to admit you ve proved to be very creative in solving this, though you missed the chance to learn…Aakar -:)
    Will you mark the topic as SOLVED , then? On the bottom R-H corner, click on the TOPIC TOOLS to find the option.
    Thanks

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch It feels a bit unsatisfying to mark this issue as closed as the underlying problem continues to exist meaning that it is still unclear why the font was chosen in the first place…

    I can understand that qt apps may behave differently in a gtk world but choosing some arbitrary font seems to be a bug in my opinion…

    But I understand that this might not be related to Antergos so I can mark it as solved anyway if you like…

  • Ok, its up to you to decide. TBO I don t remember anyone reporting a similar issue ever, here. I don t know how many GTK-based DE users use qt apps, but there are some quite popular (VLC, for instance)… But again, VLC is not related directly to the KDE project (as okular).
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • The font was devanagari (Hindi). I am getting Tamil fonts (another Indian language) in Qbittorrent and calibre. I do need devanagari fonts installed for some web pages I visit but I don’t want them in my applications. Moreover, I don’t understand Tamil.

  • just give the full explanation here: https://forum.antergos.com/topic/7813/qt5-is-making-some-apps-guis-look-terrible/5

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

kde106 qt510 translation3 gnome38 Posts 8Views 275
Log in to reply