• Weird Desktop environment behavior after install (lightdm not working)


    Hi! I am new to antergos and arch,
    I just installed Antergos to my laptop and while it is now functional, a lot of features seems broken.
    At first I was getting a black screen after grub, so I switched from lightdm to sddm without success, then after switching to gdm, I could get a login screen and access the gui (gnome). However the environment seems broken (wallpaper is blue and cannot be changed, windows themes and style cannot be changed, etc). When I change to KDE plasma it freezes (cpu gets to 100%+ usage), when I change to mate I get an other black screen

    I tried fixing lightdm without success:
    https://mikaela.info/english/2015/10/17/antergos_change_login_dm.html

    I also tried installing different driver for nvidia and intel graphic without success
    spec:
    Asus 15" k501ux i7 with nvidia geforce 950M
    dual booted with windows 10

    Any suggestions where to look for?

    Thanks

  • optimus?

    lspci -vnn | grep '\''[030[02]]'
    

    gives you two lines like this:

    00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09) (prog-if 00 [VGA controller])
    
    01:00.0 3D controller [0302]: NVIDIA Corporation GK107M [GeForce GT 750M] [10de:0fe4] (rev ff) (prog-if ff)
    

    Bild Text

    https://antergos.com/wiki/en/hardware/graphics/bumblebee-for-nvidia-optimus/

    If this looks to complicated to you try the Antergos installer:

    $ sudo pacman -S nvidia-installer
    nvidia-installer -b -t
    

    ([-t] to test installation)
    then if no error is shown up:

    $ sudo nvidia-installer -b
    
  • @joekamprad that fixed it, thanks man!

  • 0_1498027783816_2fa9a75f-4539-4071-ae2d-65e28c8b4d28-ภาพ.png I agree with the contributors on this subject.

lightdm131 weird14 environment9 behavior7 Posts 5Views 1136
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.