• Evolution won't start from Xwayland on Gnome-shell 3.24.2


    So, yesterday, I downloaded the newest Antergos ‘minimal’ iso, and did a clean install of Antergos Gnome-Shell.

    I decided to switch from X.org to XWayland at login using gdm. I have Evolution in ~/.config/autostart. But it didn’t start. Curious. I went to a terminal and grepped ps for it and there is was with a process id. Yet it is not in background ‘jobs’. I kill the process and try to launch Evolution again. Still nothing and the same symptom. A process id shows for it.

    I guess the first question should be, is Evolution Wayland compliant?
    I googled to see if I could find anything but nope.

    Is anyone else having this issue? Is anyone running Evolution in the Wayland environment?

    Thoughts? – Dietrich

  • i am using wayland.
    I don’t use evolution (i always have issues with gmail) but i run it to see if it works.
    it works fine to me…

  • @czam
    I was hoping someone would know of an issue with it. Hokay.
    I guess it would mean I have to compile it from source with debug enabled and then run it with gdb to see what’s going on…

    I’ll wait to collect more answers here – thanks for your feedback and test.
    Regards, Dietrich

  • Can you launch it from a terminal and see if their any error messages ?

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • There were no errors from a Terminal. Oddly. And none in journalctl.
    I completely removed evolution and evolution-data-server and reinstalled evolution from the Xwayland environment.

    It’s working now. Thanks.

  • @dtschmitz , nice! Will you mark the topic as SOLVED , then?
    Thanks

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

gnome-shell16 evolution7 3.24.21 xwayland1 Posts 6Views 791
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.