• Asunder closes when changing folders


    I use Asunder in GNOME to rip my CDs into .ogg files. Recently, I have run into a slight nagging issue with Asunder. When I go into preferences to set the destination folder before ripping, the application closes. As a result, I have to rip the CD into whatever the previous destination folder was and then move it where I want it. (I sort everything by genre, then by artist and album.)

    When I launched Asunder from the terminal and went through the same process, I got the same result. The application closed/crashed with the following:

    Fatal error: g_mkdir() failed. Couldn't create folder.```
    

    Anyone else run into this or have any suggestions for fixing this problem? Thanks.

  • I should also say that the destination folder Asunder said it could not create was already present.

    Does anyone else use Asunder? If not, what do/did you use to rip your CDs?

  • @WaltH Did you try to uninstall/reinstall the package?

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto - No, I haven’t tried that. Guess I’ll give that a try. Thanks.

  • @fernandomaroto - Just tried it, and it still closes with the same error message (in terminal) when I try to change the destination folder, even though the new folder already exists. I’ve installed RipperX, which works so far, though it seems a bit more cumbersome when it comes to changing the destination folder.

  • @WaltH
    ok, and what about downgrading the package?
    As far as you described the program is unable to overwrite an existing folder (what happens if the folder doesn’t exist? That error you first posted?), maybe something wrong in the program itself, not your system. i don’t use this program so i’ll try to test it in VM when i have more time.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto - Well, I could try downgrading the package (have to figure out how). The program isn’t trying to overwrite an existing folder but is trying to rip files to an existing folder. You actually have to create the destination folder or use an existing folder before it will rip the CD.

  • @WaltH ok, did you noticed the problem started after some update?
    check for versions here https://archive.archlinux.org/packages/a/asunder/
    you can try the one from 13th may 2016 or previous, go testing at least 3 versions of them, if none work then i don’t know hehehe

    OBS1: You just need to download and execute, the system will install.
    OBS2: Example, download asunder-2.8-3-x86_64.pkg.tar.xz

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto - Downgrading to the previous version appears to have solved the problem. I guess I’ll wait for a new version before upgrading again and hang on to the May 2016 version just in case.

  • @WaltH nice! Probably it’s a bug with the package then. I’m glad you fixed!
    Cheers!

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • That’s what I figured. Guess I’ll wait until next year when someone repackages it again. :smiley:

  • Since Asunder is in the Community repository (and not, apparently, AUR), I gather that means it is/was packaged by an Antergos user. Any chance then that the latest version (2.9-3) will be fixed/replaced? I’m getting a little tired of seeing that there is an update knowing that the newer version crashes on me.

  • It has been three months since I first asked about this. I was wondering whether anyone had noticed the problem improving with the various updates and upgrades to other software and libraries. Does anyone else even use Asunder?

    The last time I tried the latest version of Asunder, the problem of it closing when trying to select the folder into which to rip a CD was still present. I’ve looked for other alternatives, but I remember only finding RipperX, which does not integrate as well visually as Asunder and was also quite old, as I recall. Brasero doesn’t do this particular task as far as I can tell, although I do use it for other tasks. Any other suggestions out there for applications that will allow me to rip my CD collection to ogg files?

  • @WaltH said in Asunder closes when changing folders:

    Does anyone else even use Asunder?

    i never used it…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • there is i fix for this upstream from 2017-08-20 but Archlinux/community is last updated 2017-07-02

    https://littlesvr.ca/bugs/show_bug.cgi?id=45

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

changing10 closes1 asunder1 folders6 Posts 15Views 490
Log in to reply