• Wifi connectivity issues (rtl8821ae)


    I have an ASUS X550VX laptop, on which I recently installed Antergos. Previously, I had Kubuntu dual booted with Windows 10 (W10 is still on PC, I replaced Kubuntu with Antergos).

    I use a Realtek rtl8821ae wireless card, at least lspci -k gives

    “Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter”

    I experience issues with my wifi at home.

    The symptoms are:

    • At one point, usually once every 2-10 mins, I lose internet connection, while the system tray indicator still says I am connected, then the signal strength drops to near zero, I get disconnected, then in a few seconds it reconnects.

    • Sometimes it won’t be able to reconnect at all, and I need to reboot the OS (probably removing and then reloading the kernel module also does that).

    Further comments:

    • This is most likely an issue with my driver. I had no prior issues with the router, and wifi worked fine on Kubuntu.

    • I use Gnome 3 with the standard config as installed by cnchi. I connect to wifi via the system tray plugin on Gnome (which by the way sucks and gets unresponsive even when trying to totally turn off the wifi).

    • Direct ethernet connection works. At least that’s what I thought, but just as I wrote this, it also disconnected and I had to reinsert the cable.

    Attempted solutions: I created a file /etc/modprobe.d/rtl8821ae.conf where I added

    “options rtl8821ae ips=0 swlps=0 fwlps=0”

    but this did not fix the issue.

    I realize this is a fairly widespread issue, at least internet searches gave me many results, but the above solution was the only one I found that I could safely apply. I have found some other stuff but were for different network cards or different distros.

    I would appreciate any help, as I really like Antergos and would like to make it my long-term OS, but if wifi is gonna misbehave like this I’ll probably have to switch to another distro.

    Edit:
    Many search results gave me threads in which people apparantly solved the issue by undergoing a kernel update. Neofetch says I use 4.11.5-1-ARCH, and since Antergos is a rolling release distro and pacman -Syu does nothing, I assume my system is fully up to date.

  • Your kenel is the latest and greatest. Have you tried using the LTS kernel?

    I battled a Realtek wi-fi card for far too long in my Lenovo TP using various Ubuntus, Fedora, and Antergos. Nothing i did worked reliably. You symptoms are similar to what I experienced. I had brief kernel bliss with 4.9, but then it started acting up at some point in 4.10 and newer. There were even inconsistencies between the Ubuntus on the same kernel - wifi only worked with Ubuntu Gnome 16.04 and not in any of the other flavors. I gave up and replaced the Realtek with an Intel card. This is probably your easiest solution.

    If i’m not mistaken, there’s one guy, Larry Finger, that maintains the Realtek drivers for Linux, and he uses openSUSE. If replacing your wifi card isn’t an option, then you might want to give openSUSE a spin.

  • @triode13 Actually, I don’t want to close the question yet because I cannot be absolutely sure (haven’t had enough time to see if this really fixed it), I think I fixed the issue.

    I did what this blog post recommended, and it seems to have worked.

    In short: There is this git repo: https://github.com/lwfinger/rtlwifi_new, based on the address I think maintained by the same guy who you mentioned in your answer.

    I did

    $ git clone https://github.com/lwfinger/rtlwifi-new.git ~/src/rtlwifi-new
    $ cd ~/src/rtlwifi-new
    $ make
    $ sudo make install
    $ modprobe rtl8821ae

    Then reboot. Not a single disconnect since then. The guy also said he had further issues, I did not encounter them. With that said, I’ll wait a few days till I declare this issue solved, but seems very promising so far.

    Note to anyone wishing to use this:

    Like the blog’s author says, the git repo apparantly has “linux-headers” as a dependency, so one might need to do

    $ sudo pacman -S linux-headers

    but I already had this installed.

  • I consider the issue fixed, as I have not encountered any disconnects after hours of constant usage.

  • Glad to hear!

  • Sorry for the noob question, what happens when you manually compile & install a driver (rtl8821ae in this case) and later receive a kernel upgrade via package manager? Do you have to manually uninstall the driver, or what else?

  • @eleius I am a linux newb, so I don’t actually know. However I suspect nothing will happen and the kernel will keep using the driver. If that fails, I guess one can reload the kernel module. If the kernel upgrade would break the driver, then I assume Mr. Finger will update his repo.

    Now, I don’t particularily understand git, but afaik it allows for dynamic updates, but because I had to make install, I’m not sure. With that said, in this case, probably redownloading the updated archive and then make installing would work fine.

    Waiting for a more experienced user to confirm or deny.

  • There was a kernel upgrade today, and yup, it’s doing it again. I simply reloaded the module and I’ll see how it goes. The git repo was updated 2 months ago, so unless the reloading fixes it again, I’ll be fucked till Mr. Finger decides to update the repo.

  • I have redownloaded the git repo (probably pointless) and recompiled the driver. I did

    $ sudo modprobe -r rtl8821ae && sudo modprobe rtl8821ae ips=0 fwlps=0 swlps=1 disable_watchdog=1 int_clear=0

    I have no idea what this does, but the situation seems marginally better. With that said, I am running a pinging session of a website in a terminal and periodically I see the ping time jump up to 8-9000 ms, though the network manager doesn’t seem to disconnect me anymore.

    I guess I could roll back the kernel update and wait a bit with updating, but I am disappoint.

  • Hello everyone! I am new here, and new to Antergos / Arch. But I had some experience with Linux n the past (long time ago).

    Well, I also have a ASUS laptop with Realtek rtl8821ae wireless card. I also have the issue when the network simply stop working but the indicator on gnome says it is connected.

    I’ve tried the suggested fix, building and installing the module from https://github.com/lwfinger/rtlwifi_new but, after that I could connect to wifi through gnome interface, but I wasn’t able to ping anything. It simply did not work at all.

    I just want to state that if anyone is having this problem, you can use:
    $ sudo make uninstall
    in the folder you have issued the install command. It will restore the driver you were using before.

    For information, the kernel I am using is 4.11.7-1-ARCH.

  • @DanNOG Did you also try it with

    sudo modprobe rtl8821ae ips=0 fwlps=0 swlps=1 disable_watchdog=1 int_clear=0
    

    ? I kept having issues though, which I could not fix after a while, so I ended ué using the LTS kernel. Which did work for me, but I also had to download the rpo and run it with the parameters I have given. But it does work now.

  • @Ulrich said in Wifi connectivity issues (rtl8821ae):

    LTS kernel

    No I did not tried this. I am a bit confused. What do you mean by ¨ended up using LTS Kernel?" I am just using the kernel that I got when installing Antergos. I’ve posted the kernel version because I believe that we are probably using different Kernels, since it worked for you.

    So, to summarize, you are using rtlwifi_new loaded with that parameters, right? But in what kernel?

    Thank you.

  • @DanNOG Heya, sorry for the delay, I had some stuff iRL. Anyways, Arch Linux (and thus Antergos) has an lts (long-term stable) kernel, that is basically an older version of the kernel that nontheless keeps getting security and bugfix updates, and is slowly getting updated (mine switched from 4.9.35-1-LTS to 4.9.36-1-LTS recently).

    If you don’t have it already installed, you should install the linux-lts and linux-lts-headers via pacman or pamac, and if you use proprietary nvidia drivers (probably the same shizzle for AMD drivers but I don’t use AMD GPU) you should install nvidia-lts as well (it will replace the current nvidia drivers).

    Afterwards, when you boot, grub should look something like

    • Antergos
    • Advanced options for Antergos
    • Other shizzle like Windows Boot Loader etc.

    I am only paraphrasing here, don’t remember the exact menu titles. You should go into Advanced options, and there you’ll have something like

    • Antergos
    • Antergos (fallback)
    • Antergos (LTS kernel)
    • Antergos (LTS kernel, fallback)

    and you should choose the LTS kernel as boot option.


    Note the following things:

    • I don’t think it actually makes the difference, but certainly doesn’t hurt, make a file
    /etc/modprobe.d/rtl8821ae.conf
    

    and into it write

    options rtl8821ae ips=0 fwlps=0 swlps=1 disable_watchdog=1 int_clear=0
    
    • It seems to me that every time there is a kernel update, you need to recompile the driver you have downloaded from the github repo. So every time you receive a kernel update do
    sudo modprobe -r rtl8821ae
    make && sudo make install
    sudo modprobe rtl8821ae
    

    all while your terminal is open in the rtlwifi_new folder. Based on the files there and the make and make install output, I think compiling will take the currently active kernel into account, but I am not sure. At any rate, even the update to the LTS kernel borked my wifi again, but doing this restored it.

    • I dunno if the drivers in the repo work with the latest kernel or not, I have only tried with the LTS kernel after my recent fiasco with the latest kernel, but I do would like to say that after the third bleeding edge kernel update, I didn’t even try recompiling, at the time I didn’t realize that would help. But it should, by all means, work with the LTS kernel.

    • This solution is not perfect, I still get occasional 9-10 sec drops in the connection, but unlike how it was previously, it won’t disconnect me from the network or make the network manager go crazy. This drop is only visible in the sense that sometimes pages will take long to load and if you do a ping to some website you will occasionally see like 4-5 packets have like 9-10k ms latencies.

  • @Ulrich Thanks a lot for the detailed explanation. I was already trying the parameters options you had suggested before. Although I hadnt installed the lts kernel, I did not have any kernel updates so far.

    The driver from that repo with the arguments worked for me, without the args was not connecting. But the problem of huge latency problems time to time still occurs.

    I am getting back to my windows and Mac OS. I was trying Antergos, and I liked it, as a replacement for my MAC OS, I have a old macbook pro (2011) and I don’t think I will buy a new one. Apple have disappointed me and lot of people whit the way it is being evolving MPBs.

    Thanks a lot!

  • @DanNOG said in Wifi connectivity issues (rtl8821ae):

    rtlwifi_new

    Is also aviable on AUR:

    https://aur.archlinux.org/packages/rtlwifi_new-dkms/

    As this is dkms enabled it will rebuild and load modules automatik on new kernels…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad Good to know! Thanks. I will give this a try!

  • @DanNOG Funny, I was just about to write here that the arguments were causing problems for me. I had some weird CPU lockups, which I intuited that they might be caused by those args. When I removed them, things went fine. My wifi works fine as well. In fact, it seems some of the latency issues have lessened as well but I might be hallucinating.

    But at any rate, if the args work for you, I am glad.

    @joekamprad Ooooh, I seem to recall I have searched the AUR for this package and found nothing, but I might have only dreamt it then :D .

rtl8821ae1 wifi90 issues51 connectivity1 Posts 17Views 1800
Log in to reply