• System won't boot after updates- getting 'Can't find UUID' error


    Hello,

    So, long story short, I’ve installed bunch of up updates today, rebooted my laptop and after that system won’t boot again. I’m getting the following message:

    “mount : can’t find UUID=40bfd785-a096-43c6-8a20-2fdce1fa4779
    You are now being dropped into an emergency shell.
    sh: can’t access tty; job control turned off”

    And keyboard doesn’t work on that screen.

    here’s output of blkid:

    /dev/sda1: UUID="5B6A-4321" TYPE="vfat" PARTUUID="7186c7f7-46f1-4381-965d-ca25d5ffdab6"
    /dev/sda2: UUID="40bfd785-a096-43c6-8a20-2fdce1fa4779" TYPE="ext4" PARTUUID="06e63c8d-9d3a-4b54-a4a0-b3ce7fa20ead"
    /dev/sda3: UUID="8a08362a-214b-41a5-a335-bb8a8343cab8" TYPE="swap" PARTUUID="73f8ef8f-8152-4a07-8a90-a09d57470faa"
    /dev/sda4: UUID="73c74afc-f6c4-414a-85fc-5b1016ae34a7" TYPE="crypto_LUKS" PARTUUID="2b4e75ee-f4fc-43b7-a3f0-5527f295e291"
    /dev/sdb1: UUID="2017-01-04-04-06-41-00" LABEL="ANTERGOS" TYPE="iso9660" PTUUID="5a674d81" PTTYPE="dos" PARTUUID="5a674d81-01"
    /dev/sdb2: SEC_TYPE="msdos" LABEL="ARCHISO_EFI" UUID="34B2-53AE" TYPE="vfat" PARTUUID="5a674d81-02"
    /dev/loop0: TYPE="squashfs"
    
    

    parted -l:

    Model: ATA Samsung SSD 850 (scsi)
    Disk /dev/sda: 500GB
    Sector size (logical/physical): 512B/512B
    Partition Table: gpt
    Disk Flags: 
    
    Number  Start   End     Size    File system     Name  Flags
     1      1049kB  51.0MB  50.0MB  fat32
     2      51.0MB  100GB   100GB   ext4
     3      100GB   116GB   16.0GB  linux-swap(v1)
     4      116GB   500GB   384GB
    
    
    Model: Samsung Flash Drive DUO (scsi)
    Disk /dev/sdb: 32.1GB
    Sector size (logical/physical): 512B/512B
    Partition Table: msdos
    Disk Flags: 
    
    Number  Start  End     Size    Type     File system  Flags
     2      115kB  67.2MB  67.1MB  primary  fat16        esp
    
    

    efibootmgr -v:

    BootCurrent: 000C
    Timeout: 0 seconds
    BootOrder: 001A,0019,000C,000A,0006,0007,0008,0009,000B,000D,000E,000F,0010,0011,0012,0013
    Boot0000  Setup	FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
    Boot0001  Boot Menu	FvFile(126a762d-5758-4fca-8531-201a7f57f850)
    Boot0002  Diagnostic Splash Screen	FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
    Boot0003  Startup Interrupt Menu	FvFile(f46ee6f4-4785-43a3-923d-7f786c3c8479)
    Boot0004  ME Configuration Menu	FvFile(82988420-7467-4490-9059-feb448dd1963)
    Boot0005  Rescue and Recovery	FvFile(665d3f60-ad3e-4cad-8e26-db46eee9f1b5)
    Boot0006* USB CD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
    Boot0007* USB FDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
    Boot0008* ATAPI CD0	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a35401)
    Boot0009* ATA HDD2	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f602)
    Boot000A* ATA HDD0	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f600)
    Boot000B* ATA HDD1	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f601)
    Boot000C* USB HDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,33e821aaaf33bc4789bd419f88c50803)
    Boot000D* PCI LAN	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
    Boot000E* ATAPI CD1	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a35403)
    Boot000F* ATAPI CD2	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a35404)
    Boot0010  Other CD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a35406)
    Boot0011* ATA HDD3	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f603)
    Boot0012* ATA HDD4	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f604)
    Boot0013  Other HDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f606)
    Boot0014* IDER BOOT CDROM	PciRoot(0x0)/Pci(0x16,0x2)/Ata(0,1,0)
    Boot0015* IDER BOOT Floppy	PciRoot(0x0)/Pci(0x16,0x2)/Ata(0,0,0)
    Boot0016* ATA HDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f6)
    Boot0017* ATAPI CD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a354)
    Boot0018* PCI LAN	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
    Boot0019* ubuntu	HD(1,GPT,4bc6e6b6-f3fd-423c-b6ab-d837ebebb500,0x800,0x18000)/File(\EFI\ubuntu\shimx64.efi)
    Boot001A* antergos_grub	HD(1,GPT,7186c7f7-46f1-4381-965d-ca25d5ffdab6,0x800,0x17d78)/File(\EFI\antergos_grub\grubx64.efi)
    
    

    mkinitcpio -p linux gives following result:

    ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
      -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
    ==> ERROR: specified kernel image does not exist: `/boot/vmlinuz-linux'
    ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
      -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
    ==> ERROR: specified kernel image does not exist: `/boot/vmlinuz-linux'
    

    Thank you in advance for any help/tips.

  • do you have lts kernel installed?
    do you try fallback?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • do you have lts kernel installed?
    No, I was using stable release (4.11)
    do you try fallback?
    Yes, effect is exactly the same - frozen screen​ with mount error

  • What i want to say is that your problem is kernel related, so have the LTS Kernel installed aside from standard Kernel, can keep your neck free in a lot of cases…

    But can be also a grub problem (if you use grub to boot, as it looks like) so also give rewriting grub entry a try?

    is this what you find before?
    I fixed it! I had to add “nvme” to /etc/mkinitcpio.conf and regenerate the initramfs.img with
    mkinitcpio -p linux
    (https://bbs.archlinux.org/viewtopic.php?id=208132)

    what do you have inside your /etc/mkinitcpio.conf ?
    seems to that there is something wrong (for actual kernel, may working before) HOOKS= may have block inside?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • is this what you find before?
    I fixed it! I had to add “nvme” to /etc/mkinitcpio.conf and regenerate the initramfs.img with
    mkinitcpio -p linux
    (https://bbs.archlinux.org/viewtopic.php?id=208132)

    Yes also, but mkinitcpio -p linux gives me the output mentioned earlier

    what do you have inside your /etc/mkinitcpio.conf ?
    seems to that there is something wrong (for actual kernel, may working before) HOOKS= may have block inside?

    taht’s my /etc/mkinitcpio.conf file:

    # vim:set ft=sh
    # MODULES
    # The following modules are loaded before any boot hooks are
    # run.  Advanced users may wish to specify all system modules
    # in this array.  For instance:
    #     MODULES="piix ide_disk reiserfs"
    MODULES="dm_mod dm_crypt ext4 aes_x86_64 sha256 sha512 nvme"
    
    # BINARIES
    # This setting includes any additional binaries a given user may
    # wish into the CPIO image.  This is run last, so it may be used to
    # override the actual binaries included by a given hook
    # BINARIES are dependency parsed, so you may safely ignore libraries
    BINARIES=""
    
    # FILES
    # This setting is similar to BINARIES above, however, files are added
    # as-is and are not parsed in any way.  This is useful for config files.
    FILES=""
    
    # HOOKS
    # This is the most important setting in this file.  The HOOKS control the
    # modules and scripts added to the image, and what happens at boot time.
    # Order is important, and it is recommended that you do not change the
    # order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
    # help on a given hook.
    # 'base' is _required_ unless you know precisely what you are doing.
    # 'udev' is _required_ in order to automatically load modules
    # 'filesystems' is _required_ unless you specify your fs modules in MODULES
    # Examples:
    ##   This setup specifies all modules in the MODULES setting above.
    ##   No raid, lvm2, or encrypted root is needed.
    #    HOOKS="base"
    #
    ##   This setup will autodetect all modules for your system and should
    ##   work as a sane default
    #    HOOKS="base udev autodetect block filesystems"
    #
    ##   This setup will generate a 'full' image which supports most systems.
    ##   No autodetection is done.
    #    HOOKS="base udev block filesystems"
    #
    ##   This setup assembles a pata mdadm array with an encrypted root FS.
    ##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
    #    HOOKS="base udev block mdadm encrypt filesystems"
    #
    ##   This setup loads an lvm2 volume group on a usb device.
    #    HOOKS="base udev block lvm2 filesystems"
    #
    ##   NOTE: If you have /usr on a separate partition, you MUST include the
    #    usr, fsck and shutdown hooks.
    HOOKS="base udev autodetect modconf block keyboard keymap encrypt resume filesystems fsck"
    
    # COMPRESSION
    # Use this to compress the initramfs image. By default, gzip compression
    # is used. Use 'cat' to create an uncompressed image.
    #COMPRESSION="gzip"
    #COMPRESSION="bzip2"
    #COMPRESSION="lzma"
    #COMPRESSION="xz"
    #COMPRESSION="lzop"
    #COMPRESSION="lz4"
    
    # COMPRESSION_OPTIONS
    # Additional options for the compressor
    #COMPRESSION_OPTIONS=""
    
  • @bigchris said in System won't boot after updates- getting 'Can't find UUID' error:

    HOOKS="base udev autodetect modconf block

    so may remove block here and try to mkinitcpio again?
    I AM NOT SHURE HERE AND AT THE MOMENT I HAVE NO TIME TO RESERCH MORE …

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad said in System won't boot after updates- getting 'Can't find UUID' error:

    so may remove block here and try to mkinitcpio again?

    The same output :/

updates26 system53 uuid3 boot148 Posts 7Views 159
Log in to reply