• Laptop shutting down at 23% battery.


    Hey guys, I’m running a dual boot Antergos/Win10 on an ASUS ROG G551JW. For quite some time now my laptop’s been shutting down at about 23% battery, only under Antergos. After the shutdown the laptop won’t start (as if the battery was down to 0) until I plug it in, and after boot (in either Linux or Win) I get 24% battery level.
    Journalctl has nothing useful on the matter - normal logs go as they should and then, suddenly, reboot message.
    The only info I found on the matter is in this topic on the Arch forums. But there’s no solution there. Any ideas?

  • @TemplarRei said in Laptop shutting down at 23% battery.:

    ASUS ROG G551JW

    I would count on actual Kernel to be the problem here… do you try LTS Kernel?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad No, can you point me to a walkthrough on downgrading the kernel? I’m using latest via pacman currently.
    P.S. Thanks for the attention :)

  • @TemplarRei Hi, on my laptop I can boot into LTS Kernel just by going in to the “Advanced settings for Antergos” when the system boots, but you have to be ready with your triggerfinger because the option disappear after 5 seconds. Hope it’s the same on your computer. Good luck.

    Peace, Love and Penguins.

  • @TemplarRei
    No need to downgrade LTS Kernel is installable side by side with actual one.

    $ sudo pacman -S linux-lts
    $ sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    after this you can do what @Cats-n-Dogs say on bootup:

    going in to the “Advanced settings for Antergos” when the system boots

    and choose LTS to boot

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad said in Laptop shutting down at 23% battery.:

    $ sudo pacman -S linux-lts

    Sorry for the intrusion, you would miss the cabesera, even if you do it by default:

    sudo pacman -S linux-lts-headers
    
  • and if you have to use nvidia driver

    $ sudo pacman -S nvidia-lts
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Thanks, guys!
    Was out of town, but I’ll try it out after work today or tommorrow and post-back with results ^_^

  • Is it possible that battery wear saver got somehow activated? should normally kick in from 20 and stop charging at 80%. other choice would be a dodgy battery that runs flat close to 24% and reports inaccurate capacity (loses voltage real quick) then charges up very fast from zero to 25% in the time system boots…

    But then it won’t be replicated in Windoze…

  • Follow up. LTS kernel did not help at all, but it turns out that reinstalling all battery-related drivers, extensions, plugins and whatsnot on both platforms helps. It didn’t prolong my battery life, it just accuratelly alerts me now, instead of dying at 23%.
    Sorry for the late follow-up :/
    P.S. How do I mark the question as solved?

  • upower acpid tlp …

    or what do you reinstall ?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • # tlp stat
    --- TLP 1.0 --------------------------------------------
    
    +++ Configured Settings: /etc/default/tlp
    TLP_ENABLE=1
    TLP_DEFAULT_MODE=AC
    TLP_PERSISTENT_DEFAULT=0
    DISK_IDLE_SECS_ON_AC=0
    DISK_IDLE_SECS_ON_BAT=2
    MAX_LOST_WORK_SECS_ON_AC=15
    MAX_LOST_WORK_SECS_ON_BAT=60
    CPU_HWP_ON_AC=balance_performance
    CPU_HWP_ON_BAT=balance_power
    SCHED_POWERSAVE_ON_AC=0
    SCHED_POWERSAVE_ON_BAT=1
    NMI_WATCHDOG=0
    ENERGY_PERF_POLICY_ON_AC=performance
    ENERGY_PERF_POLICY_ON_BAT=powersave
    DISK_DEVICES="sda sdb"
    DISK_APM_LEVEL_ON_AC="254 254"
    DISK_APM_LEVEL_ON_BAT="128 128"
    SATA_LINKPWR_ON_AC=max_performance
    SATA_LINKPWR_ON_BAT=min_power
    AHCI_RUNTIME_PM_TIMEOUT=15
    PCIE_ASPM_ON_AC=performance
    PCIE_ASPM_ON_BAT=powersave
    RADEON_POWER_PROFILE_ON_AC=high
    RADEON_POWER_PROFILE_ON_BAT=low
    RADEON_DPM_STATE_ON_AC=performance
    RADEON_DPM_STATE_ON_BAT=battery
    RADEON_DPM_PERF_LEVEL_ON_AC=auto
    RADEON_DPM_PERF_LEVEL_ON_BAT=auto
    WIFI_PWR_ON_AC=off
    WIFI_PWR_ON_BAT=on
    WOL_DISABLE=Y
    SOUND_POWER_SAVE_ON_AC=0
    SOUND_POWER_SAVE_ON_BAT=1
    SOUND_POWER_SAVE_CONTROLLER=Y
    BAY_POWEROFF_ON_AC=0
    BAY_POWEROFF_ON_BAT=0
    BAY_DEVICE="sr0"
    RUNTIME_PM_ON_AC=on
    RUNTIME_PM_ON_BAT=auto
    USB_AUTOSUSPEND=1
    USB_BLACKLIST_BTUSB=0
    USB_BLACKLIST_PHONE=0
    USB_BLACKLIST_WWAN=1
    RESTORE_DEVICE_STATE_ON_STARTUP=0
    
    +++ System Info
    System         = Dell Inc. Not Specified Inspiron 5423
    BIOS           = A08
    Kernel         = 4.9.36-1-lts #1 SMP Wed Jul 5 17:34:52 CEST 2017 x86_64
    /proc/cmdline  = BOOT_IMAGE=/boot/vmlinuz-linux-lts root=UUID=df548a45-26e2-448c-8c6a-964a8bcd1b6b rw quiet
    Init system    = systemd 
    Boot mode      = UEFI
    
    +++ TLP Status
    State          = enabled
    Last run       = 07:23:27,     19 sec(s) ago
    Mode           = battery
    Power source   = battery
    
    +++ Processor
    CPU model      = Intel(R) Core(TM) i7-3517U CPU @ 1.90GHz
    
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq  =   800000 [kHz]
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq  =  3000000 [kHz]
    
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq  =   800000 [kHz]
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq  =  3000000 [kHz]
    
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_min_freq  =   800000 [kHz]
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_max_freq  =  3000000 [kHz]
    
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_min_freq  =   800000 [kHz]
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_max_freq  =  3000000 [kHz]
    
    /sys/devices/system/cpu/intel_pstate/min_perf_pct      =  26 [%]
    /sys/devices/system/cpu/intel_pstate/max_perf_pct      = 100 [%]
    /sys/devices/system/cpu/intel_pstate/no_turbo          =   0
    /sys/devices/system/cpu/intel_pstate/turbo_pct         =  49 [%]
    /sys/devices/system/cpu/intel_pstate/num_pstates       =  23
    
    x86_energy_perf_policy: program not installed.
    
    /sys/module/workqueue/parameters/power_efficient       = Y
    /proc/sys/kernel/nmi_watchdog                          = 0
    
    +++ Undervolting
    PHC kernel not available.
    
    +++ Temperatures
    CPU temp               =    46 [°C]
    Fan speed (fan1)       =     0 [/min]
    
    +++ File System
    /proc/sys/vm/laptop_mode               =     2
    /proc/sys/vm/dirty_writeback_centisecs =  6000
    /proc/sys/vm/dirty_expire_centisecs    =  6000
    /proc/sys/vm/dirty_ratio               =    20
    /proc/sys/vm/dirty_background_ratio    =    10
    /proc/sys/fs/xfs/xfssyncd_centisecs    =  6000
    
    +++ Storage Devices
    /dev/sda:
      Model     = WDC WD5000LPVT-75G33T0                  
      Firmware  = 01.01A01
      APM Level = 128
      Status    = active/idle
      Scheduler = deadline
    
      Runtime PM: control = on, autosuspend_delay =   -1
    
      SMART info:
          4 Start_Stop_Count          =     4441 
          5 Reallocated_Sector_Ct     =        0 
          9 Power_On_Hours            =     2025 [h]
         12 Power_Cycle_Count         =     3391 
        191 G-Sense_Error_Rate        =      250 
        193 Load_Cycle_Count          =   100613 
        194 Temperature_Celsius       =       21    [°C]
        241 Total_LBAs_Written        =    1.561 [TB]
    
    /dev/sdb:
      Model     = Micron C400 RealSSD mSATA 32GB          
      Firmware  = 01MG    
      APM Level = 128
      Status    = active/idle
      TRIM      = supported
      Scheduler = deadline
    
      Runtime PM: control = on, autosuspend_delay =   -1
    
      SMART info:
          5 Reallocated_Sector_Ct     =        0 
         12 Power_Cycle_Count         =     3392 
        177 Wear_Leveling_Count       =      100 [%]
        178 Used_Rsvd_Blk_Cnt_Chip    =        4 
        179 Used_Rsvd_Blk_Cnt_Tot     =        0 
        180 Unused_Rsvd_Blk_Cnt_Tot   =     2157 
        241 Total_LBAs_Written        =    0.689 [TB]
    
    
    +++ SATA Aggressive Link Power Management
    /sys/class/scsi_host/host0/link_power_management_policy  = min_power
    /sys/class/scsi_host/host1/link_power_management_policy  = min_power
    /sys/class/scsi_host/host2/link_power_management_policy  = min_power
    /sys/class/scsi_host/host3/link_power_management_policy  = min_power
    /sys/class/scsi_host/host4/link_power_management_policy  = min_power
    /sys/class/scsi_host/host5/link_power_management_policy  = min_power
    
    +++ AHCI Host Controller Runtime Power Management
    /sys/bus/pci/devices/0000:00:1f.2/ata1/power/control = on
    /sys/bus/pci/devices/0000:00:1f.2/ata2/power/control = on
    /sys/bus/pci/devices/0000:00:1f.2/ata3/power/control = on
    /sys/bus/pci/devices/0000:00:1f.2/ata4/power/control = on
    /sys/bus/pci/devices/0000:00:1f.2/ata5/power/control = on
    /sys/bus/pci/devices/0000:00:1f.2/ata6/power/control = on
    
    +++ PCIe Active State Power Management
    /sys/module/pcie_aspm/parameters/policy = default (using bios preferences)
    
    +++ Intel Graphics
    /sys/module/i915/parameters/enable_rc6       =  3 (enabled + deep)
    /sys/module/i915/parameters/enable_dc        = -1 (use per-chip default)
    /sys/module/i915/parameters/enable_fbc       =  0 (disabled)
    /sys/module/i915/parameters/enable_psr       =  0 (disabled)
    /sys/module/i915/parameters/modeset          = -1 (use per-chip default)
    /sys/module/i915/parameters/semaphores       =  1 (enabled)
    
    +++ Radeon Graphics
    /sys/class/drm/card1/device/power_dpm_state = battery
    /sys/class/drm/card1/device/power_dpm_force_performance_level = off
    
    +++ Wireless
    bluetooth = on
    wifi      = on
    wwan      = none (no device)
    
    hci0(btusb)                   : bluetooth, not connected
    wlp7s0(wl)                    : wifi, connected, power management = on
    
    +++ Audio
    /sys/module/snd_hda_intel/parameters/power_save            = 1
    /sys/module/snd_hda_intel/parameters/power_save_controller = Y
    
    +++ Runtime Power Management
    Device blacklist = (not configured)
    Driver blacklist = amdgpu nouveau nvidia radeon (default)
    
    /sys/bus/pci/devices/0000:00:00.0/power/control = auto (0x060000, Host bridge, ivb_uncore)
    /sys/bus/pci/devices/0000:00:01.0/power/control = auto (0x060400, PCI bridge, pcieport)
    /sys/bus/pci/devices/0000:00:02.0/power/control = auto (0x030000, VGA compatible controller, i915)
    /sys/bus/pci/devices/0000:00:14.0/power/control = auto (0x0c0330, USB controller, xhci_hcd)
    /sys/bus/pci/devices/0000:00:16.0/power/control = auto (0x078000, Communication controller, mei_me)
    /sys/bus/pci/devices/0000:00:1a.0/power/control = auto (0x0c0320, USB controller, ehci-pci)
    /sys/bus/pci/devices/0000:00:1b.0/power/control = auto (0x040300, Audio device, snd_hda_intel)
    /sys/bus/pci/devices/0000:00:1c.0/power/control = auto (0x060400, PCI bridge, pcieport)
    /sys/bus/pci/devices/0000:00:1c.3/power/control = auto (0x060400, PCI bridge, pcieport)
    /sys/bus/pci/devices/0000:00:1c.5/power/control = auto (0x060400, PCI bridge, pcieport)
    /sys/bus/pci/devices/0000:00:1d.0/power/control = auto (0x0c0320, USB controller, ehci-pci)
    /sys/bus/pci/devices/0000:00:1f.0/power/control = auto (0x060100, ISA bridge, lpc_ich)
    /sys/bus/pci/devices/0000:00:1f.2/power/control = auto (0x010400, RAID bus controller, ahci)
    /sys/bus/pci/devices/0000:00:1f.3/power/control = auto (0x0c0500, SMBus, i801_smbus)
    /sys/bus/pci/devices/0000:02:00.0/power/control = auto (0x030000, VGA compatible controller, radeon)
    /sys/bus/pci/devices/0000:07:00.0/power/control = auto (0x028000, Network controller, wl)
    /sys/bus/pci/devices/0000:09:00.0/power/control = auto (0x020000, Ethernet controller, alx)
    
    +++ USB
    Autosuspend         = enabled
    Device whitelist    = (not configured)
    Device blacklist    = (not configured)
    Bluetooth blacklist = disabled
    Phone blacklist     = disabled
    WWAN blacklist      = enabled
    
    Bus 002 Device 002 ID 8087:0024 control = auto, autosuspend_delay_ms =     0 -- Intel Corp. Integrated Rate Matching Hub (hub)
    Bus 002 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 2.0 root hub (hub)
    Bus 001 Device 005 ID 1bcf:2982 control = auto, autosuspend_delay_ms =  2000 -- Sunplus Innovation Technology Inc.  (uvcvideo)
    Bus 001 Device 004 ID 0a5c:21d7 control = auto, autosuspend_delay_ms =  2000 -- Broadcom Corp. BCM43142 Bluetooth 4.0 (btusb)
    Bus 001 Device 003 ID 0bda:0129 control = auto, autosuspend_delay_ms =  2000 -- Realtek Semiconductor Corp. RTS5129 Card Reader Controller (rtsx_usb)
    Bus 001 Device 002 ID 8087:0024 control = auto, autosuspend_delay_ms =     0 -- Intel Corp. Integrated Rate Matching Hub (hub)
    Bus 001 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 2.0 root hub (hub)
    Bus 004 Device 001 ID 1d6b:0003 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 3.0 root hub (hub)
    Bus 003 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 2.0 root hub (hub)
    
    +++ Battery Status
    /sys/class/power_supply/BAT0/manufacturer                   = SMP-SDI2.0
    /sys/class/power_supply/BAT0/model_name                     = DELL 8JVDG27
    /sys/class/power_supply/BAT0/cycle_count                    = (not supported)
    /sys/class/power_supply/BAT0/charge_full_design             =   4000 [mAh]
    /sys/class/power_supply/BAT0/charge_full                    =   3177 [mAh]
    /sys/class/power_supply/BAT0/charge_now                     =   2205 [mAh]
    /sys/class/power_supply/BAT0/current_now                    =    891 [mA]
    /sys/class/power_supply/BAT0/status                         = Discharging
    
    Charge                                                      =   69.4 [%]
    Capacity                                                    =   79.4 [%]
    
    +++ Warnings
    * Kernel log shows ata errors (2) possibly caused by the configuration
      SATA_LINKPWR_ON_AC/BAT=min_power or medium_power.
      Consider using medium_power or max_performance instead.
      See the FAQ: http://linrunner.de/en/tlp/docs/tlp-faq.html#warnings
      Details:
    [    8.073502] ata2: SError: { HostInt CommWake }
    [    8.074219] ata2: hard resetting link
    [    8.407736] ata2: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
    [    8.408552] ata2.00: ACPI cmd ef/10:06:00:00:00:00 (SET FEATURES) succeeded
    [    8.408558] ata2.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
    [    8.408561] ata2.00: ACPI cmd b1/c1:00:00:00:00:00 (DEVICE CONFIGURATION OVERLAY) filtered out
    --
    [  310.521893] ata2: SError: { HostInt CommWake }
    [  310.521910] ata2: hard resetting link
    [  310.851493] ata2: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
    [  310.852530] ata2.00: ACPI cmd ef/10:06:00:00:00:00 (SET FEATURES) succeeded
    [  310.852534] ata2.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
    [  310.852536] ata2.00: ACPI cmd b1/c1:00:00:00:00:00 (DEVICE CONFIGURATION OVERLAY) filtered out
    
    
    
  • Hello guys!, I have a similar issue, my laptop is an Asus Rog G75VW with dual boot W10, is been shutting down at 5 minutes, again only under Antergos. in windows 10 the battery last 25 or 30 minutes, power config report on windows says that my battery is at 50% life aprox. Is there a tweak or kernel that changes this behavior?

  • @carlosgomez.deb do you try to reinstal related stuff as discribed as a solution?

    @TemplarRei said in Laptop shutting down at 23% battery.:

    Follow up. LTS kernel did not help at all, but it turns out that reinstalling all battery-related drivers, extensions, plugins and whatsnot on both platforms helps. It didn’t prolong my battery life, it just accuratelly alerts me now, instead of dying at 23%.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

shutdown18 battery16 Posts 14Views 749
Log in to reply