• can't install anything from yaourt !!

    Hello , i can no longer install any thing from aur and can’t search also on Pamac yaourt

    when i tried to install something like android studio

    yaourt -S android-studio
    curl error: Problem with the SSL CA cert (path? access rights?)
    error: target not found: android-studio

    the method i tried to upgrade:

    pacman -Scc
    pacman -Syy
    pacman-key --refresh-keys
    pacman -Syu

    any suggestion , thanks

  • run

    $ sudo curl-config --ca

    and you will get something, e.g. /etc/ssl/certs/ca-certificates.crt, back it up(in case you need it)

    $ sudo mv /etc/ssl/certs/ca-certificates.crt /etc/ssl/certs/ca-certificates.crt.bak

    go to caExtract.html download the latest cacert.pem, e.g. cacert-2017-06-07.pem
    replace the original ‘ca-certificates.crt’ with the latest cacert.pem , e.g.

    $ sudo mv cacert-2017-06-07.pem /etc/ssl/certs/ca-certificates.crt

    try to

    yaourt -S android-studio


    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2

  • @joekamprad hello, Thanks for reply
    i think my problem was ca-certificates.crt doesn’t exist

    Thanks solved 🙂

yaourt25 Posts 3Views 416
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.