• Trying to install Tomahawk


    Hi, im a newbie linux user that just started to mess arround with it, and i’m trying to install tomahawk, but everytime it gives me the error

    ‘error: liblastfm-qt5: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is invalid
    :: File /var/cache/pacman/pkg/liblastfm-qt5-1.1.0.r637-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

    i’ve tried installing liblastfm-qt5 manually but it still gives me the same error, and i can’t find a solution to this online.
    Any advice would be really nice.
    Ps: be easy on me with the code talk(if needed), like i said i’m a total noob.

  • Clear cache with sudo pacman -Sc. Then, do the update with sudo pacman -Syyu.

    Then, try to install liblastfm-qt5.

  • Thanks for the reply, but it still gives me the same issue. since my post i also tried doing yaourt tomahawk but all it did was stay 20 minutes installing some things that i have no idea what it was only to fail at the end.

  • i have been having the same problem with a different package and finally resolved it tonight. you are in a bit of a vicious circle where your keys are bad and you can’t update them because you need them to update.

    What you need to do is set the antergos repo to ignore GPG signature checks in /etc/pacman.conf and then update/reinstall the antergos-keyring package.

  • wget http://mirrors.antergos.com/antergos/x86_64/antergos-keyring-20170524-1-any.pkg.tar.xz
    pacman -U antergos-keyring-20170524-1-any.pkg.tar.xz
    sudo pacman -Scc
    sudo pacman-key --refresh-keys
    sudo pacman -Syyu
    
    $ rm -R /etc/pacman.d/gnupg/
    $ pacman-key --init
    $ pacman-key --populate archlinux antergos
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • I think there’s something wrong with the website “hkp://pool.sks-keyservers.net” because everytime i try to do the line

    sudo pacman-key --refresh-keys
    

    it tells me

     ==> ERROR: A specified local key could not be updated from a keyserver.  
    

    i tried doing it another way or atleast i think it is i really don’t know anything about terminal language,

    rm -R /etc/pacman.d/gnupg/
    rm -R /root/.gnupg/  # only if the directory exists
    gpg --refresh-keys
    pacman-key --init && pacman-key --populate
    pacman-key --refresh-keys
    

    But it gives me the same error, i’ll wait until i can access the website before i try anything else, Thanks for both of your replies joekamprad and oldillusion.

  • Have you tried executing this sudo pacman -Scc command before going on to refresh the keys?

    Keep trying, never give up. In the end, you will find that it was all worth it

    (NOTE: This is still @A-User, I just changed my username and picture)

  • Yes, i said yes to both cache and unused repositories, still gives me the error.

  • @Jouka said in Trying to install Tomahawk:

    hkp://pool.sks-keyservers.net

    are you behind any proxy VPN e.t.c ?
    try:

    sudo pacman-key --refresh-keys --keyserver ipv4.pool.sks-keyservers.net
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • No, not that i know of atleast, i’ve also tried to ping the sks-keyserver website with no response, and after a long time(8 minutes or so) this is what i got

    [[email protected] ~]$ sudo pacman-key --refresh-keys --keyserver ipv4.pool.sks-keyservers.net
    gpg: refreshing 94 keys from hkp://ipv4.pool.sks-keyservers.net
    gpg: keyserver refresh failed: Server indicated a failure
    ==> ERROR: A specified local key could not be updated from a keyserver.
    
    
  • Well i found what i was doing wrong
    on my firefox settings on tracking, “change block list” i had disconnect.me protection, when i took it off it fixed it.

    After i did all that code succesfully i tried to install tomahawk again, but it gave me the same error =(.

tomahawk3 Posts 11Views 220
Log in to reply