• lightdm + wayland


    Hello clean Antregos Gnome install so i default have lightdm. when i want log-in i don`t have wayland session. i switch to gdm and now when i want to log-in i have wayland session and i can use it without problem but i noticed that gdm is little monster and lightm take less resources and my laptop works better with lightdm.

    maybe someone know why wayland dont work with lightdm? if it is lightdm bug i will report it on lightdm website or maybe i missing something and i need edit lightdm.conf ?? ps: have intel 520 graphics card

  • there are no options to “enable” wayland for your Gnome Session inside lightdm.conf it is the session you can choose gnome/gnome-classic/gnome-xorg where gnome is the wayland session starter.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • i lanuch under lightdm all 3 session gnome/gnome-classic/gnome-xorg and all 3 session return me after i run

    echo $XDG_SESSION_TYPE
    x11
    

    only on gdm return me that i run wayland

    edit i found the same error that lightdm works on x11 in older posts:
    https://forum.antergos.com/topic/5466/prolem-w-lightdm-after-fresh-install-won-t-boot-into-wayland?page=1

  • You can try this one:

    edit /etc/profile and add:

    export XDG_SESSION_TYPE=wayland
    

    at the end of the file

    $ su
    echo export XDG_SESSION_TYPE=wayland >> /etc/profile
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • you can also switch to GDM and the wayland option will be there at login. well it wont say wayland but just pick Gnome as it will be the default.

lightdm93 wayland38 Posts 5Views 622
Log in to reply