• Antergos installation won't work (black/white screen of death)


    Hey,

    I wanted to install Antergos on my computer, but it won’t work.

    1. I tried to install the Antergos Live ISO. But after choosing “Start Antergos Live” a black screen appeared with a blinking cursor. No “F”-buttons were working, the terminal couldn’t be accessed. I tried several solutions like add “modprobe.blacklist=nouveau” to the boot line, but nothing worked.

    So:

    1. I’ve downloaded the “fixed” ISO by Pilzbauer. I’ve tried to install it by following the tutorial in the wiki …/install/installing-antergos-with-a-newer-nvidia-gpu/. But again it didn’t work. A white screen appeared with “Oh no, something has gone wrong”. I really don’t know what to do else. Looks like, I have to install archlinux instead.

    Any other ideas? Thanks in advance

  • @Ruper said in Antergos installation won't work (black/white screen of death):

    install/installing-antergos-with-a-newer-nvidia-gpu

    Telephone to @Community-Moderators

  • As far as i know there is not a workoing solution for that problem, last ones get Antergos installed on not working newer nvidia gpu, done this by removing the card and replug after install…
    Archlinux natural do not have this issue because it do not need X for installation.
    Also the Pilzbauer Iso seems to be outdated.
    But do you try set nomodeset on Pilzbauer Iso?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Yes, I tried to set nomodeset, but it didn’t work. The white screen appears again.

  • Oh no indicates that the gpu driver is installed properly. I presume you tried to install Gnome3 which might start with wayland instead of xorg. wayland in it’s still unfinished and only almost working state doesn’t work with the nvidia drivers. Can you select Gnome on xorg at login?
    J.

  • No, I didn’t install gnome. See above, after trying to boot Antergos by selecting “start antergos live” this error appears.

  • @Ruper Can you provide some info about the hardware you’re trying to install Antergos on?

  • Sure.

    Intel Core i5-3450 3,1 GHZ
    12 GB RAM Memory
    AMD Radeon HD 7800 Series
    asrock z77 pro3

  • @Ruper Thanks. I was suspicious about graphic subsystem. Unfortunately, I don’t know ATI cards well enough to make any suggestion.

  • @Ruper You should be able to plug in your monitor to the integrated graphics port and get an install that way (using the regular Antergos ISO). I had to do that for my GTX 1070 before I could get the nvidia package installed. Afterwards, you can (while still plugged into the integrated card) install the xf86-video-ati driver most likely. I suggest you follow the wiki here and get your stack built up right with mesa and stuff and you should be good to go.

    Disclaimer, after you install the packages, I believe the install process blacklists the intel card so you can switch the monitor connection after you get the pkg installed.

    PS: I also had an AMD 4850 before my GTX 1070 and it worked fine after getting the drivers and such. the Opensource AMD drivers are getting very good these days.

    EDIT: added reference to the right ISO

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • @Ruper said in Antergos installation won't work (black/white screen of death):

    Sure.

    Intel Core i5-3450 3,1 GHZ
    12 GB RAM Memory
    AMD Radeon HD 7800 Series
    asrock z77 pro3

    The Pilzbauer ISO is specially made for Nvidia cards.
    J.

  • I guess I should have specified that I was talking about the regular Antergos installer

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • @Jeannie____ said in Antergos installation won't work (black/white screen of death):

    Radeon HD 7800

    I do not see that this will caus a problem booting the installer…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @n_mag nope. This didn’t work. After selecting the boot option, my screen stays completely black. No cursor blinking, nothing.

  • @Ruper dang… even with your monitor in the intel graphics spot? Something really weird is wrong here it seems…

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • @Ruper An old trick. Try to boot with one additional parameter - vga=789 or vga=normal. Many times it helped to boot various Linuxes in the past. Just a shot in a dark.

  • @just no, it didn’t work.

    But: I’ve clicked on “no acpi” and finally it was booting normally. The installer appeared. But I didn’t try to install it yet. I will try it tomorrow.

    Any idea why it is working now? What’s the meaning behind “no acpi”? Will it cause any problems booting with this?

    Edit: Looks like the problem is solved. I updated my bios and now it boots normally. Had no time to install it, but i will try it in the next few days

installation212 death2 blackwhite1 Posts 17Views 1151
Log in to reply