• Antergos installation difficulties (UEFI && Bios mode)


    Hello,

    I have some difficulties to install Antergos properly on my main computer. It work well on my laptop, but it’s quite hard on my custom box.

    I want to install Antergos using UEFI mode, but I’ve never been able to get to Cnchi even once using that mode no matter what I try. It always freeze somewhere in the loading process.

    I’ve tried bios mode to see if I can get more luck that way and I find out that I have only two specifics ways to load the installer properly, anything else would freeze the same way as in UEFI mode.

    In bios mode, if I choose “No KMS”, it work well. If I choose “text mode” and use the kernel parameter “nomodeset”, it work as well. If I only use “text mode” or “nomodeset”, it froze.

    I wonder if it is possible boot in UEFI mode using “No KMS” or using “text mode” and “nomodeset”? If yes, how would I do that? If no, is bios mode my only option?

    Thank you very much!

    New Linux user | No more Windows in my life No more Windows at home | In love with Antergos && Arch! | A lot to learn!

  • First question on this is graphics card, number one problem on do not get to Live Environment

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Did you download the new image? There’s a new installer image just a few days old.

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @izznogooood Yes, I used 17.6 last night. Made my USB stick using dd. I think I will make my USB stick again just to be sute because I had 17.5 on it before. Maybe dd didn’t worked and 17.5 stayed on the stick? Or, is there an easy way to check which version is on the stick?

    New Linux user | No more Windows in my life No more Windows at home | In love with Antergos && Arch! | A lot to learn!

  • @joekamprad said in Antergos installation difficulties (UEFI && Bios mode):

    First question on this is graphics card, number one problem on do not get to Live Environment

    I have a GTX 970 and I know I have a nouveau problem. I’m pretty sure that nomodeset overcome that problem since I’m able to boot and install Antergos in legacy/bios mode using no kms or text mode with nomodeset.

    I’ve did a bunch of tests. In fact, I can’t remember all tests I’ve made since I have make so many of them! XD

    I’ve removed/disconnected everything I can (removed my 970, disconnected my printer, my Xbox controller, etc). Only things stay connected was cpu, ram, keyboard, mouse, screen, main ssd, all other hdd have been disabled in the bios.

    Not having my 970 connected give me the same result than when she is using nomodeset nouveau.modeset=0. When I remove quiet and splash, I can see that the boot sequence run and finish it’s job, but it left me at a black screen with cursor blinking in top left corner. Should I left “splash” parameter there?

    My cpu is a Pentium G3258 heavily overclocked. I have the same overclock since almost 2 year and always been ultra stable, never crashed even once.

    I have a very strong gut feeling that there is an other problem outside of nouveau. But I may be wrong, so I’m willing to try anything.

    I’ve read the logs using journalctl -xb but I’m not able to tell what is ok and what is wrong. I know that Plymouth fail to launch and throw an error, but I suspect that it is because I removed quiet and splash parameters.

    I also saw a mdadm error, so I turned off my hdd’s in bios and the error disappeared at next boot.

    I’m really clueless right now! XD

    New Linux user | No more Windows in my life No more Windows at home | In love with Antergos && Arch! | A lot to learn!

  • Do you have the possibility to turn off safeboot in your BIOS? If you can try that.

    Secondly, do this: https://forum.antergos.com/topic/7028/nvidia-card/9

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @izznogooood I already tried the second option. I can’t get to load the live environment even when my graphic card is out.

    I think safe boot already are disabled. Going to validate this when I’ll be back home.

    Thanks for your help guys, I really appreciate this! :)

    New Linux user | No more Windows in my life No more Windows at home | In love with Antergos && Arch! | A lot to learn!

  • If you remove the nvidia card from system you are using the internal graphics ? this should work without problems. There is mostly also a option inside efi-bios to boot from file, as a fallback option to get the usb stick booting.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad Removing my GTX 970 is not helping. I have the same result while using my onboard graphics.

    I’m curious about :

    There is mostly also a option inside efi-bios to boot from file, as a fallback option to get the usb stick booting.

    How can I know more on that subject?

    New Linux user | No more Windows in my life No more Windows at home | In love with Antergos && Arch! | A lot to learn!

  • @izznogooood I confirm that secure/safe boot is disable.

    New Linux user | No more Windows in my life No more Windows at home | In love with Antergos && Arch! | A lot to learn!

  • I don’t know if that can help someone to understand what is going on, but I finally find a way to save my journal log file. I join it to this post:

    [0_1496796469462_journal.log](Uploading 100%)

    Thank you for your time and your help!

    Edit : File upload don’t seems to work.

    New Linux user | No more Windows in my life No more Windows at home | In love with Antergos && Arch! | A lot to learn!

  • I uploaded my logs on google drive:

    journal.log

    New Linux user | No more Windows in my life No more Windows at home | In love with Antergos && Arch! | A lot to learn!

  • @iSpeakVeryWell as every distributor have their own Efi-Bios structure and all different options and names inside the menu it is not like giving you a link ;)
    It should be somehere under some like “Boot Maintenance Management”

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Do you know what internal card is inside? and what is your monitor size resolution?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • This is my cpu : https://ark.intel.com/products/82723/Intel-Pentium-Processor-G3258-3M-Cache-3_20-GHz

    They say hd graphics. It’s something like hd 4000.

    New Linux user | No more Windows in my life No more Windows at home | In love with Antergos && Arch! | A lot to learn!

  • @iSpeakVeryWell should work without a problem… the only thing comes to my mind is maybe you got a big screen

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad I’ve tried my two monitors. My main screen is a 24 inch 144hz. My second screen is a 27 inch 60hz. Both are 1920x1080. I used a displayport cable with my 144hz. With my 60hz, I’ve tried HDMI and DVI.

    New Linux user | No more Windows in my life No more Windows at home | In love with Antergos && Arch! | A lot to learn!

  • someone with more knowledge about the Antergos EFI boot can give a hint on how to add this to boot?

    press “e” key in order to temporary modify the boot options.
    Add, on top, a new line by pressing “Enter” containing:

    set gfxpayload=1920x1080
    

    then [F10] to save and boot

    may help i do not know what modes are supported on your system but give it a try…

    You can try also to add this:

    vga=0x361
    

    or:

    acpi=off
    

    (edit command)

    after pressing “e”

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • From your logs i can see this:

    Jun 07 00:23:17 ant-17.6 kernel: [drm] VGACON disable radeon kernel modesetting.
    Jun 07 00:23:17 ant-17.6 kernel: [drm:radeon_init [radeon]] *ERROR* No UMS support in radeon module!
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad said in Antergos installation difficulties (UEFI && Bios mode):

    From your logs i can see this:

    Jun 07 00:23:17 ant-17.6 kernel: [drm] VGACON disable radeon kernel modesetting.
    Jun 07 00:23:17 ant-17.6 kernel: [drm:radeon_init [radeon]] *ERROR* No UMS support in radeon module!
    

    Yeah, this bug me as well… I don’t know why I got this message since my pc are intel/nvidia. I have nothing amd/ati.

    Also, I’ve tried your commands and they did not worked. Aren’t those commands for grub?

    New Linux user | No more Windows in my life No more Windows at home | In love with Antergos && Arch! | A lot to learn!

uefi35 installation199 bios15 Posts 20Views 1013
Log in to reply