• Error al actualizar pamac


    Hola, estoy en Antergos con XFCE. Tengo 8 actualizaciones disponibles pero me da error en el paquete Pamac al querer actualizar…

    [[email protected] ~]$ sudo pacman -S pamac
    resolviendo dependencias…
    buscando conflictos entre paquetes…
    
    Paquetes (1) pamac-4.3.7-1
    
    Tamaño total de la descarga:    0,34 MiB
    Tamaño total de la instalación:  2,61 MiB
    
    :: ¿Continuar con la instalación? [S/n] s
    :: Recibiendo los paquetes…
     pamac-4.3.7-1-x86_64     345,5 KiB   109K/s 00:03 [######################] 100%
    (1/1) comprobando las claves del depósito          [######################] 100%
    (1/1) verificando la integridad de los paquetes    [######################] 100%
    error: pamac: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is unknown trust
    :: El archivo /var/cache/pacman/pkg/pamac-4.3.7-1-x86_64.pkg.tar.xz está dañado (paquete no válido o dañado (firma PGP)).
    ¿Quiere eliminarlo? [S/n] s
    error: no se pudo realizar la operación (paquete no válido o dañado (firma PGP))
    Ocurrieron errores, por lo que no se actualizaron los paquetes
    
    

    Lo que hice a continuación es quitar el paquete, el problema es que ahora no puedo volver a instalarlo.

    Nota 1: Logré instalar pamac pero desde el repositorio AUR, el problema es que ahora me aparecen actualizaciones para instalar pamac y desinstalar pamac-aur lo cual tampoco me deja ya que me da error al instalarlo… Dejo a continuación lo que me aparece.

    [[email protected] ~]$ sudo pacman -S pamac
    [sudo] password for muchosoft: 
    resolviendo dependencias…
    buscando conflictos entre paquetes…
    :: pamac y pamac-aur están en conflicto. ¿Quitar pamac-aur? [s/N] s
    
    Paquetes (2) pamac-aur-4.3.6-1 [quitando]  pamac-4.3.7-1
    
    Tamaño total de la instalación:  2,61 MiB
    Tamaño neto tras actualizar:    0,76 MiB
    
    :: ¿Continuar con la instalación? [S/n] s
    (1/1) comprobando las claves del depósito          [######################] 100%
    descargando las claves requeridas…
    error: key "CDBD406AA1AA7A1D" could not be looked up remotely
    error: la clave requerida no está presente en el depósito
    error: no se pudo realizar la operación (error inesperado)
    Ocurrieron errores, por lo que no se actualizaron los paquetes
    

    Gracias desde ya.

  • Hola!

    sudo rm /var/cache/pacman/pkg/antergos-keyring*
    sudo pacman-key --refresh-keys
    sudo pacman -Syyu
    sudo pacman -S pamac
    

    Más info:
    https://forum.antergos.com/topic/6984/error-with-antergos-keyring

error258 actualizar14 mapac1 Posts 2Views 524
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.