• Change Console Resolution


    I want to change and keep my virtual console resolution to 640x480x32.

    Here
    *

    • list item is my /etc/defagihttp://www.nbcnews.com/storyline/london-bridge-attack/london-bridge-attack-american-hit-head-police-bullet-witness-says-n768186ult/grub file

    GRUB_CMDLINE_LINUX=""
    GRUB_GFXPAYLOAD_LINUX=640x480x24
    GRUB_GFXMODE=769
    GRUB_GFXPAYLOAD_LINUX=keep
    GRUB_DISTRIBUTOR=“Antergos”
    GRUB_COLOR_NORMAL=green/black
    GRUB_CMDLINE_LINUX_DEFAULT=“quiet resume=UUID=3abb0425-b992-4c79-a7c8-c9d33bbc30fc”
    GRUB_TIMEOUT=5
    GRUB_DISABLE_RECOVERY=true
    GRUB_TERMINAL_INPUT=console
    GRUB_THEME="/boot/grub/themes/Antergos-Default/theme.txt"
    GRUB_DEFAULT=saved
    GRUB_PRELOAD_MODULES=“part_gpt part_msdos”

    Here are the POSTS in order of submission:

    This is something which used to be very easy to do with old GRUB, unfortunately it also set the X resolution which now with high resolution graphics would not work.

    If you don’t see well, you can adjust the size of the fonts, which is wonderful.

    Unfortunately the resulting virtual console font is very small. Also many of the console or CLI applications are written for 640x480 resolution and if I run these on my console, they are very small.

    Is there a way to easily change the virtual console font on the fly, or an easy way of keeping the console at a low resolution while allowing X Windows to run a high resolution which is what modern monitors and operating systems including GNOME and KDE especially want?

    I’ve tried searching for this, but it seems very complicated because when GRUB was changed KMS kernel mode set came about and if I am correct this is one of several problems in setting a low 640x480 resolution on virtual console.

    Note: I am not talking about Terminal which runs in X server, this is fine. I need to change the virtual console font or resolution so it appears to be using 640x480 resolution so that CLI users can see the applications in larger font size or decreased resolution. Console is accessed by pressing ALT + CTRL plus a number from 1 to 9, like ALT+CTL+2 (all at the same time). You can move console to console by ALT + right or left cursor key.

    Thanks in advance,

    djringjr

    ===================================

    seth posted this most helpful response and I wrote him after the Admin dust binned the topic.

    [https://wiki.archlinux.org/index.php/GRUB/Tips_and_tricks#Setting_the_framebuffer_resolution](link url)
    or
    [https://wiki.archlinux.org/index.php/GRUB/Tips_and_tricks#Disable_framebuffer](link url)

    Also

    man fbset

    for runtime manipulation.

    =================

    Then I posted the /etc/default/grub file above and the subject was placed in trash.

    I still need help, seth’s advice helped but I still see small letters in console. I can adjust terminal in X windows (in KDE or other Desktop Environment) but I’m insterested in large letters or lower resolution in the virtual console which I access by using Alt+Ctrl+F(2-6) keys all pressed at once. The boot up sequence is on console 1 and the X server with KDE is on console 7.

    I really wish someone would write a script to do this because the people most likely to need this do not see well.

    Please if you can, help me.

    Thanks,

    djringjr

  • Arch-WIKI Say:

    My fonts are too tiny
    See Fonts#Console fonts for how to change your console font to a large font. The Terminus font (terminus-font) is available in many sizes, such as ter-132n which is larger.
    Alternatively, disabling KMS by appending nomodeset as a kernel parameter will also make fonts readable.

    setfont temporarily change the font if passed a font name (in /usr/share/kbd/consolefonts/) such as

    $ setfont lat2-16 -m 8859-2
    

    The FONT variable in /etc/vconsole.conf is used to set the font at boot, persistently for all consoles. See man 5 vconsole.conf for details.

  • Has anyone figured out a way to keep the font size that is in GRUB menu and have it not be reset to a tiny font?

    I believe KMS is the problem, but I try nomodeset and it doesn’t work.

    Here is my /etc/default/grub file.

    GRUB boot loader configuration

    GRUB_DEFAULT=0
    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR=“Antergos”
    GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nomodeset vga=788 quiet”
    GRUB_CMDLINE_LINUX=“800xx600”

    Preload both GPT and MBR modules so that they are not missed

    GRUB_PRELOAD_MODULES=“part_gpt part_msdos”

    Uncomment to enable booting from LUKS encrypted devices

    #GRUB_ENABLE_CRYPTODISK=y

    Uncomment to enable Hidden Menu, and optionally hide the timeout count

    #GRUB_HIDDEN_TIMEOUT=5
    #GRUB_HIDDEN_TIMEOUT_QUIET=true

    Uncomment to use basic console

    GRUB_TERMINAL_INPUT=console

    Uncomment to disable graphical terminal

    #GRUB_TERMINAL_OUTPUT=console

    The resolution used on graphical terminal

    note that you can use only modes which your graphic card supports via VBE

    you can see them in real GRUB with the command `vbeinfo’

    GRUB_GFXMODE=auto

    GRUB_GFXMODE=800xx600x32

    Uncomment to allow the kernel use the same resolution used by grub

    GRUB_GFXPAYLOAD_LINUX=keep

    GRUB_GFXPAYLOAD_LINUX=800x600x32
    GRUB_GFXPAYLOAD_LINUX=keep

    Uncomment if you want GRUB to pass to the Linux kernel the old parameter

    format “root=/dev/xxx” instead of “root=/dev/disk/by-uuid/xxx”

    #GRUB_DISABLE_LINUX_UUID=true

    Uncomment to disable generation of recovery mode menu entries

    GRUB_DISABLE_RECOVERY=true

    Uncomment and set to the desired menu colors. Used by normal and wallpaper

    modes only. Entries specified as foreground/background.

    #GRUB_COLOR_NORMAL=“light-blue/black”
    #GRUB_COLOR_HIGHLIGHT=“light-cyan/blue”

    Uncomment one of them for the gfx desired, a image background or a gfxtheme

    #GRUB_BACKGROUND="/path/to/wallpaper"
    GRUB_THEME="/boot/grub/themes/Antergos-Default/theme.txt"

    Uncomment to get a beep at GRUB start

    #GRUB_INIT_TUNE=“480 440 1”

    Uncomment to make GRUB remember the last selection. This requires to

    set ‘GRUB_DEFAULT=saved’ above.

    #GRUB_SAVEDEFAULT=“true”

    Does anyone have a solution?

    Thanks,

    David

  • DEFAULT="quiet splash nomodeset vga=788 quiet"
    GRUB_CMDLINE_LINUX=“800xx600”
    

    The VGA= option is not valid anymore the right one is GRUB_CMDLINE_LINUX= is used now… but not with double x 😏

  • @joekamprad Thanks I don’t see well, I see the xx and I just put “800x600” but still I get small fonts.

    Here is my /etc/default/grub file:

    GRUB boot loader configuration

    GRUB_DEFAULT=0
    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR=“Antergos”
    GRUB_CMDLINE_LINUX_DEFAULT=“splash nomodeset quiet”
    GRUB_CMDLINE_LINUX=“800x600”

    Preload both GPT and MBR modules so that they are not missed

    GRUB_PRELOAD_MODULES=“part_gpt part_msdos”

    Uncomment to enable booting from LUKS encrypted devices

    #GRUB_ENABLE_CRYPTODISK=y

    Uncomment to enable Hidden Menu, and optionally hide the timeout count

    #GRUB_HIDDEN_TIMEOUT=5
    #GRUB_HIDDEN_TIMEOUT_QUIET=true

    Uncomment to use basic console

    GRUB_TERMINAL_INPUT=console

    Uncomment to disable graphical terminal

    #GRUB_TERMINAL_OUTPUT=console

    The resolution used on graphical terminal

    note that you can use only modes which your graphic card supports via VBE

    you can see them in real GRUB with the command `vbeinfo’

    GRUB_GFXMODE=auto

    GRUB_GFXMODE=800xx600x32

    Uncomment to allow the kernel use the same resolution used by grub

    GRUB_GFXPAYLOAD_LINUX=keep

    GRUB_GFXPAYLOAD_LINUX=800x600x32
    GRUB_GFXPAYLOAD_LINUX=keep

    Uncomment if you want GRUB to pass to the Linux kernel the old parameter

    format “root=/dev/xxx” instead of “root=/dev/disk/by-uuid/xxx”

    #GRUB_DISABLE_LINUX_UUID=true

    Uncomment to disable generation of recovery mode menu entries

    GRUB_DISABLE_RECOVERY=true

    Uncomment and set to the desired menu colors. Used by normal and wallpaper

    modes only. Entries specified as foreground/background.

    #GRUB_COLOR_NORMAL=“light-blue/black”
    #GRUB_COLOR_HIGHLIGHT=“light-cyan/blue”

    Uncomment one of them for the gfx desired, a image background or a gfxtheme

    #GRUB_BACKGROUND="/path/to/wallpaper"
    GRUB_THEME="/boot/grub/themes/Antergos-Default/theme.txt"

    Uncomment to get a beep at GRUB start

    #GRUB_INIT_TUNE=“480 440 1”

    Uncomment to make GRUB remember the last selection. This requires to

    set ‘GRUB_DEFAULT=saved’ above.

    #GRUB_SAVEDEFAULT=“true”

    Can you see what I am doing wrong?

    Thank you.

    djringjr

  • @djringjr Unfortunately the forum distorts what I post. My comment lines starting with # come out as being large bold font and do not show the comment character.

    //# GRUB boot loader configuration
    
    GRUB_DEFAULT=0
    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR="Antergos"
    GRUB_CMDLINE_LINUX_DEFAULT="splash nomodeset quiet"
    GRUB_CMDLINE_LINUX="800x600"
    
    # Preload both GPT and MBR modules so that they are not missed
    GRUB_PRELOAD_MODULES="part_gpt part_msdos"
    
    # Uncomment to enable booting from LUKS encrypted devices
    #GRUB_ENABLE_CRYPTODISK=y
    
    # Uncomment to enable Hidden Menu, and optionally hide the timeout count
    #GRUB_HIDDEN_TIMEOUT=5
    #GRUB_HIDDEN_TIMEOUT_QUIET=true
    
    # Uncomment to use basic console
    GRUB_TERMINAL_INPUT=console
    
    # Uncomment to disable graphical terminal
    #GRUB_TERMINAL_OUTPUT=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    # GRUB_GFXMODE=auto
    GRUB_GFXMODE=800xx600x32
    
    # Uncomment to allow the kernel use the same resolution used by grub
    GRUB_GFXPAYLOAD_LINUX=keep
    # GRUB_GFXPAYLOAD_LINUX=800x600x32
    # GRUB_GFXPAYLOAD_LINUX=keep
    
    # Uncomment if you want GRUB to pass to the Linux kernel the old parameter
    # format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    GRUB_DISABLE_RECOVERY=true
    
    # Uncomment and set to the desired menu colors.  Used by normal and wallpaper
    # modes only.  Entries specified as foreground/background.
    #GRUB_COLOR_NORMAL="light-blue/black"
    #GRUB_COLOR_HIGHLIGHT="light-cyan/blue"
    
    # Uncomment one of them for the gfx desired, a image background or a gfxtheme
    #GRUB_BACKGROUND="/path/to/wallpaper"
    GRUB_THEME="/boot/grub/themes/Antergos-Default/theme.txt"
    
    # Uncomment to get a beep at GRUB start
    #GRUB_INIT_TUNE="480 440 1"
    
    # Uncomment to make GRUB remember the last selection. This requires to
    # set 'GRUB_DEFAULT=saved' above.
    #GRUB_SAVEDEFAULT="true"
    
    
  • @djringjr said in Change Console Resolution:

    nomodeset

    why do you have the nomodeset option? and splash? nomodeset prohibits the modesetting for graphic resolution by kernel:

    “Adding the nomodeset parameter instructs the kernel to not load video drivers and use BIOS modes instead until X is loaded.”

resolution18 console5 Posts 8Views 1437
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.