• Headphone jack not working


    Hello

    After a recent update, my audio works fine through laptop speakers but not when I plug headphones into the jack. It makes no sound through the headphones but it does mute the speakers.

    I’ve tried stopping the systemd services for pulseaudio and starting them with higher loglevels but I’m not getting any indication of what’s going on

    Here’s my audio device per lspci:

    00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)
    	Subsystem: Lenovo Device 3806
    	Kernel driver in use: snd_hda_intel
    

    Here’s snd_hda at boot

    Jun 05 04:09:48 tempest kernel: snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
    Jun 05 04:09:48 tempest kernel: snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC299: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
    Jun 05 04:09:48 tempest kernel: snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    Jun 05 04:09:48 tempest kernel: snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
    Jun 05 04:09:48 tempest kernel: snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
    Jun 05 04:09:48 tempest kernel: snd_hda_codec_realtek hdaudioC0D0:    inputs:
    Jun 05 04:09:48 tempest kernel: snd_hda_codec_realtek hdaudioC0D0:      Mic=0x19
    Jun 05 04:09:48 tempest kernel: snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12
    

    The sound subsystems in Linux seem to be governed by a multitude of userspace junk and kernel junk and I’ve no idea what configuration to look out for. The amount of lines of configuration files I’ve seen while trying to find something out about this is ridiculous. There are about 2600 lines of configuration in /usr/share/pulseaudio/alsa-mixer/paths/

    Here’s a pastebin with pulseaudio running with --log-level=4:
    https://pastebin.com/t4s8tAB4

    Here’s where dmesg says my outputs are:

    [    2.621369] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input19
    [    2.621414] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input20
    [    2.621450] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input21
    [    2.621491] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input22
    [    2.621529] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input23
    [    2.621571] input: HDA Intel PCH HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input24
    [    2.621613] input: HDA Intel PCH HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input25
    

    Yet when I run alsamixer I only see one master output.

    So, what I’m thinking is that somewhere some subsystem, be it alsa or pulse or whatever, isn’t setting the right output when it gets a signal from the driver that I’ve inserted a headphone, or the outputs aren’t plug and play and that I need to define them somewhere, or my kernel’s somehow broken.

    I’m running on the latest kernel, 4.11.3-1-ARCH #1 SMP PREEMPT

    Does anyone have experience with this type of problem?

  • @henry.baldursson said

    After a recent update…

    Not a solution, but to cut a long story short, when it comes to " After a recent update…", the first thing I do is booting with the lts kernel. Most of the times the issue is fixed till a permanent fix arrives at the current kernel.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • yeah, slight problem with that. I was very conservative when I installed:

    ➜  ~ df -h /boot
    Filesystem      Size  Used Avail Use% Mounted on
    /dev/nvme0n1p7   61M   46M   15M  76% /boot
    ➜  ~ 
    

    (>ლ)

  • @henry.baldursson said in Headphone jack not working:

    I’ve tried stopping the systemd services for pulseaudio and starting them with higher loglevels

    how do you do this?

    and allways good to take a look to alsamixer in cases like this.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • @joekamprad I did take a look at alsamixer.

    I stop the service with systemctl --user stop pulseaudio.service and same for pulseaudio.socket then start pulseaudio on the commandline with --log-level=4

intel24 sndhda1 pulseaudio11 alsa4 Posts 5Views 256
Log in to reply